Results 1 to 12 of 12

Thread: Webalizer problem

  1. #1
    Join Date
    May 2006
    Posts
    2

    Webalizer problem

    I couldn't make webalizer from customapache:

    cd /usr/local/directadmin/customadmin
    ./build clean
    ./build update
    ./build all

    ...

    File already exists: webalizer-2.01-10-src.tgz
    creating cache ./config.cache
    checking for gcc... gcc
    checking whether the C compiler (gcc ) works... yes
    checking whether the C compiler (gcc ) is a cross-compiler... no
    checking whether we are using GNU C... yes
    checking whether gcc accepts -g... yes
    checking whether ln -s works... yes
    checking for a BSD compatible install... /usr/bin/install -c
    checking how to run the C preprocessor... gcc -E
    checking whether char is unsigned... no
    checking for db_185.h... no
    checking for errno.h... yes
    checking for socket... no
    checking for main in -lsocket... no
    checking for sys/socket.h... yes
    checking for main in -lnsl... no
    checking for main in -l44bsd... no
    checking for main in -lm... no
    checking for main in -lz... no
    configure: error: z library not found... please install zlib.
    Trying to make webalizer...
    make: no target to make.

    ---

    ./build zlib
    File already exists: zlib-1.2.3.tar.gz
    Checking for gcc...
    Checking for shared library support...
    Building shared library libz.so.1.2.3 with gcc.
    Checking for unistd.h... Yes.
    Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()
    Checking for vsnprintf() in stdio.h... Yes.
    Checking for return value of vsnprintf()... Yes.
    Checking for errno.h... Yes.
    Checking for mmap support... Yes.
    Trying to make libz...
    gcc -fPIC -O3 -DUSE_MMAP -c example.c
    gcc -fPIC -O3 -DUSE_MMAP -c adler32.c
    gcc -fPIC -O3 -DUSE_MMAP -c compress.c
    gcc -fPIC -O3 -DUSE_MMAP -c crc32.c
    gcc -fPIC -O3 -DUSE_MMAP -c gzio.c
    gcc -fPIC -O3 -DUSE_MMAP -c uncompr.c
    gcc -fPIC -O3 -DUSE_MMAP -c deflate.c
    gcc -fPIC -O3 -DUSE_MMAP -c trees.c
    gcc -fPIC -O3 -DUSE_MMAP -c zutil.c
    gcc -fPIC -O3 -DUSE_MMAP -c inflate.c
    gcc -fPIC -O3 -DUSE_MMAP -c infback.c
    gcc -fPIC -O3 -DUSE_MMAP -c inftrees.c
    gcc -fPIC -O3 -DUSE_MMAP -c inffast.c
    gcc -shared -o libz.so.1.2.3 adler32.o compress.o crc32.o gzio.o uncompr.o defla
    te.o trees.o zutil.o inflate.o infback.o inftrees.o inffast.o
    rm -f libz.so libz.so.1
    ln -s libz.so.1.2.3 libz.so
    ln -s libz.so.1.2.3 libz.so.1
    gcc -fPIC -O3 -DUSE_MMAP -o example example.o -L. libz.so.1.2.3
    gcc -fPIC -O3 -DUSE_MMAP -c minigzip.c
    gcc -fPIC -O3 -DUSE_MMAP -o minigzip minigzip.o -L. libz.so.1.2.3
    cp zlib.h zconf.h /usr/local/include
    chmod 644 /usr/local/include/zlib.h /usr/local/include/zconf.h
    cp libz.so.1.2.3 /usr/local/lib
    cd /usr/local/lib; chmod 755 libz.so.1.2.3
    cd /usr/local/lib; if test -f libz.so.1.2.3; then rm -f libz.so libz.so.1; ln
    -s libz.so.1.2.3 libz.so; ln -s libz.so.1.2.3 libz.so.1; (ldconfig || true) >
    /dev/null 2>&1; fi
    cp zlib.3 /usr/local/share/man/man3
    chmod 644 /usr/local/share/man/man3/zlib.3


    My system: FreeBSD 6.1-RELEASE

    ---

    Kind Regards, Alex

  2. #2
    Join Date
    Oct 2004
    Location
    Australia
    Posts
    59
    I'm having exactly the same problem as ahk with webalizer and zlib.

    Is anyone else having this problem on FreeBSD 6.1? I didn't even notice it until I had a look at /var/log/directadmin/errortaskq.log where it said:

    Unable to run webalizer for domain.com: /usr/local/bin/webalizer: not found

    Steve
    Hopton Hosting - Webhosting for Australians

    http://www.hoptonhosting.com.au

  3. #3
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    i've made

    ./build clean
    ./build update
    ./build all y

    when i put my eeye on the screen (after maybe 3 mins) i got this

    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.
    Trying to make webalizer...
    make: no target to make.

    i think is the same problem...
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  4. #4
    Join Date
    Oct 2004
    Location
    Australia
    Posts
    59
    It probably is the same problem, I went out for a smoke during the install so I must have missed that.

    Steve
    Hopton Hosting - Webhosting for Australians

    http://www.hoptonhosting.com.au

  5. #5
    Join Date
    Jul 2004
    Location
    Sweden / Varberg
    Posts
    97
    Me to webalizer not working?
    can I install from port?

  6. #6
    Join Date
    Apr 2006
    Location
    Zaventem
    Posts
    61
    Did anyone find a solution yet concerning this webalizer problem?

  7. #7
    Join Date
    Apr 2006
    Location
    Zaventem
    Posts
    61
    ok, this seemed to work for me:

    wget -O /usr/local/bin/webalizer http://files.directadmin.com/service...d6.0/webalizer

    chmod 755 /usr/local/bin/webalizer

    echo "action=tally&value=all" >> /usr/local/directadmin/data/task.queue
    Last edited by mdr; 06-29-2006 at 12:01 PM.

  8. #8
    Join Date
    Sep 2006
    Posts
    795

  9. #9
    Join Date
    Sep 2006
    Posts
    128
    Originally posted by mdr
    ok, this seemed to work for me:

    wget -O /usr/local/bin/webalizer http://files.directadmin.com/service...d6.0/webalizer

    chmod 755 /usr/local/bin/webalizer

    echo "action=tally&value=all" >> /usr/local/directadmin/data/task.queue
    Could you please update the link?

  10. #10
    Join Date
    Sep 2006
    Posts
    128
    I found it myself by looking in the setup.sh file.
    http://files.directadmin.com/services/freebsd6.0/

  11. #11
    Join Date
    Sep 2006
    Posts
    795
    ** BUMP **

  12. #12
    Join Date
    Aug 2004
    Location
    uk
    Posts
    1,582
    interesting its happened here also, has anyone notified john yet?

Similar Threads

  1. webalizer problem
    By bluesky in forum General Technical Discussion & Troubleshooting
    Replies: 0
    Last Post: 11-03-2011, 02:28 AM
  2. Webalizer - problem
    By tomek1 in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 05-20-2009, 10:29 AM
  3. Webalizer Problem
    By lunders in forum General Technical Discussion & Troubleshooting
    Replies: 4
    Last Post: 05-04-2006, 04:54 AM
  4. Odd problem with Webalizer
    By disoft in forum User-Level Difficulties
    Replies: 4
    Last Post: 03-15-2005, 03:13 PM
  5. problem with my webalizer
    By leblover in forum Admin-Level Difficulties
    Replies: 6
    Last Post: 10-14-2004, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •