Page 1 of 3 123 LastLast
Results 1 to 20 of 55

Thread: Exim 4.67 Released

  1. #1
    Join Date
    May 2005
    Location
    Montreal, QC, Canada
    Posts
    108

    Exim 4.67 Released

    Download Exim 4.67. Here's the changelog and new stuff.

    For FreeBSD 5.x/6.x users, update Exim as follows (when the file is available from DA):

    # cp /etc/exim.conf /etc/exim.conf.bak
    # fetch http://files.directadmin.com/service...xim-4.67-1.tgz
    # pkg_delete exim-4.xx-x
    # pkg_add da_exim-4.67-1.tgz

    Note: If you have Dovecot, you may need to apply some patches on your exim.conf file after the update.

    Restart Exim through DA control panel or from the command prompt as so:

    # /usr/local/etc/rc.d/exim restart
    FreeBSD <3

  2. #2
    Join Date
    Mar 2004
    Posts
    519
    What patchs? Or is that only FreeBSD that needs patching?

  3. #3
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,744
    He's talking about:
    Code:
    cd /usr/local/directadmin/customapache
    patch -p0 < exim.conf.dovecot.patch
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  4. #4
    Join Date
    Nov 2004
    Location
    Milano(Italy)
    Posts
    143
    MondoWeb.net - Chiedi il tuo forum gratuitamente

  5. #5
    Join Date
    Sep 2006
    Posts
    194
    work with openssl 0.9.8e?

  6. #6
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,744
    Sure it works Tested on few systems.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  7. #7
    Join Date
    Mar 2004
    Location
    Edinburgh,Scotland
    Posts
    329
    No src rpm as of yet.

    Jon

  8. #8
    Join Date
    Mar 2004
    Location
    Edinburgh,Scotland
    Posts
    329

    Redhat Src RPM now uploaded


  9. #9
    Join Date
    Nov 2004
    Location
    Milano(Italy)
    Posts
    143
    I use Debian 3.1 and i want update to 4.67 but there isn't http://files.directadmin.com/service..._exim-4.67.deb
    MondoWeb.net - Chiedi il tuo forum gratuitamente

  10. #10
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,744
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  11. #11
    Join Date
    Nov 2006
    Location
    India
    Posts
    345
    Updated via update.script

  12. #12
    Join Date
    Aug 2006
    Posts
    108
    Quote Originally Posted by AleSSaNDRo View Post
    I use Debian 3.1 and i want update to 4.67 but there isn't http://files.directadmin.com/service..._exim-4.67.deb
    It's available now and updated ok.

  13. #13
    Join Date
    Nov 2004
    Location
    Milano(Italy)
    Posts
    143
    Quote Originally Posted by fwpeter View Post
    It's available now and updated ok.
    Yes, i have contacted support by email in 29/4
    MondoWeb.net - Chiedi il tuo forum gratuitamente

  14. #14
    Join Date
    May 2004
    Posts
    1,074
    Update failed for me on RHE3 server. It won't build. It fails while trying to link to TLS.

    awk '{ print ($1+1) }' cnumber.h > cnumber.temp
    rm -f cnumber.h; mv cnumber.temp cnumber.h
    gcc version.c
    rm -f exim
    gcc -o exim
    tls.o(.text+0x4c8): In function `tls_init':
    : undefined reference to `SSL_CTX_set_info_callback'
    collect2: ld returned 1 exit status
    make[1]: *** [exim] Error 1
    make[1]: Leaving directory `/usr/src/redhat/SOURCES/da_exim-4.67/build-Linux-i386'
    make: *** [go] Error 2


    Does anyone know why this is happening?
    Last edited by rldev; 06-13-2007 at 09:02 AM.

  15. #15
    Join Date
    Dec 2005
    Location
    Lewistown, Pennsylvania, USA
    Posts
    624
    Hello,

    I'm currently running Exim 4.66 on CentOS 4.4 and am trying to upgrade to Exim 4.67. I used the following commands to upgrade using the source RPM:

    Code:
    # cd /usr/src/redhat/SRPMS
    # wget http://files.directadmin.com/services/da_exim-4.67-1.src.rpm
    # rpmbuild --rebuild da_exim-4.67-1.src.rpm
    # rpm -Uvh /usr/src/redhat/RPMS/i386/da_exim-4.67-1.i386.rpm
    When I execute the last command, I'm presented with the following:

    Code:
    Preparing...                ###########################################
    [100%]
            file /etc/aliases from install of da_exim-4.67-1 conflicts with
    file from package setup-2.5.37-1.3
    Am I doing something wrong? Also, how can you check the Exim version?
    Sincerely yours,
    Jeremy Landes
    jlandes[at]landeserve.com
    Do you want to donate to me? It would be much appreciated.

  16. #16
    Join Date
    Nov 2004
    Location
    The Netherlands
    Posts
    123
    Hi Jlandes,

    You need to use the option --force at the rpm -Uvh. For example:

    rpm -Uvh --force --nodeps /usr/src/redhat/RPMS/i386/da_exim-4.67-1.i386.rpm

    If you want to know which version of Exim you have just log in to DirectAdmin and take a look at the "System information" in the admin panel.

    Hope this helps.

    Dennis

  17. #17
    Join Date
    Dec 2005
    Location
    Lewistown, Pennsylvania, USA
    Posts
    624
    Thanks for the info, I'll give this a shot.
    Sincerely yours,
    Jeremy Landes
    jlandes[at]landeserve.com
    Do you want to donate to me? It would be much appreciated.

  18. #18
    Join Date
    Feb 2006
    Location
    Bosnia and Herzegovina
    Posts
    38
    Can this source rpm provided by DA be used to build a rpm package for 64bit CentOS?

  19. #19
    Join Date
    Dec 2005
    Location
    Lewistown, Pennsylvania, USA
    Posts
    624
    My install was successful. Thanks again for the tip.
    Sincerely yours,
    Jeremy Landes
    jlandes[at]landeserve.com
    Do you want to donate to me? It would be much appreciated.

  20. #20
    Join Date
    May 2007
    Posts
    12
    update successful~ thanks a lot

Page 1 of 3 123 LastLast

Similar Threads

  1. exim 4.71 released
    By Meesterlijk in forum Required Software Version Updates
    Replies: 27
    Last Post: 08-14-2010, 08:04 AM
  2. [exim-announce] Exim 4.68 Released
    By CoolZero in forum Required Software Version Updates
    Replies: 3
    Last Post: 09-16-2007, 10:22 AM
  3. Exim 4.61 Released
    By modem in forum Required Software Version Updates
    Replies: 68
    Last Post: 08-20-2007, 02:36 PM
  4. Exim 4.65 Released
    By mmx in forum Required Software Version Updates
    Replies: 16
    Last Post: 01-09-2007, 06:37 AM
  5. Exim 4.64 Released
    By mmx in forum Required Software Version Updates
    Replies: 10
    Last Post: 12-21-2006, 10:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •