Results 1 to 5 of 5

Thread: TLS Error

  1. #1
    Join Date
    May 2005
    Posts
    169

    TLS Error

    Hi jeff...

    Just passed my new Debian / Dovecot / exim / Clamav box on spamassassin 2... and since then i get strange errors in mainlog :

    2007-07-06 17:09:38 TLS error on connection from myserver.oxyd.net (myserver.oxyd.net) [xxx.xx.xx.xxx] (SSL_CTX_use_PrivateKey_file file=/etc/exim.key): error:0200100D:system library:fopen:Permission denied

    Do you have an idea on the problem.???

    Had no choice passing to debian, but it's hard to find my "petit" since migration happened (i'm having problems with clamav, nagios, mrtg, and now exim)

    Thks for any detailed information on how to repair

  2. #2
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,123
    I believe this has been discussed before; have you done a search in these forums for exim tls?

    Today that search returns 14 posts. I believe one of those threads will hold the answer.

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  3. #3
    Join Date
    May 2005
    Posts
    169

    solution

    Hi jeff, thks for your reply

    For information, subject has not been delt with (a search with exim tls and error gives 0 result)...

    And i have found the solution in google with 4 answers only for that error...

    In fact in this case, the rights on the certificates and key are not owned by the mail User / Group.

    a chown later, and restarting exim, seemed to have solved the panic log errors

    Yours tdldp

  4. #4
    Join Date
    Jan 2009
    Location
    Los Angeles CA
    Posts
    233

    Smile

    At the peril of rehashing an old subject, I had this same issue today and after Googling
    Code:
    Directadmin error:0200100D:system library:fopen:Permission denied
    I landed on this page and after some careful reading I did the following:

    Code:
    [root@cp ~]# ls -l /etc/exi*
    -rwxr-xr-x 1 root root  1399 Jan  6 12:25 /etc/exim.cert
    -rwxr-xr-x 1 root root 35574 Jan 18 13:53 /etc/exim.conf
    -rw------- 1 root root   887 Jan  6 12:25 /etc/exim.key
    -rwxr-xr-x 1 root root  6912 Jan 14 11:48 /etc/exim.pl
    Subsequently I ran the following as mentioned a few posts up from here:
    Code:
    chown mail:mail /etc/exim.cert 
    chown mail:mail /etc/exim.key
    Then to verify I ran ;
    Code:
    [root@cp ~]# ls -l /etc/exi*
    -rwxr-xr-x 1 mail mail  1399 Jan  6 12:25 /etc/exim.cert
    -rwxr-xr-x 1 root root 35574 Jan 18 13:53 /etc/exim.conf
    -rw------- 1 mail mail   887 Jan  6 12:25 /etc/exim.key
    -rwxr-xr-x 1 root root  6912 Jan 14 11:48 /etc/exim.pl
    PROBLEM SOLVED!!!!!
    Open Source may be free but it sure ain't cheap!
    90% of being smart is knowing what you are dumb at!;
    Specialized web hosting and dedicated VPS
    LAX Web
    NoBaloney RIP Jeff, you are sorely missed old friend

  5. #5
    Join Date
    Dec 2010
    Posts
    56
    thx nealdxmhost.
    You solved my problem right away.

Similar Threads

  1. Replies: 3
    Last Post: 11-28-2012, 01:56 AM
  2. Replies: 8
    Last Post: 01-10-2012, 08:24 AM
  3. DA error,Socket write error: Unknown error
    By stick in forum DirectAdmin General Discussion
    Replies: 1
    Last Post: 11-26-2010, 04:53 PM
  4. Replies: 2
    Last Post: 06-12-2010, 10:43 AM
  5. Service Monitor Error [mysql] works, but displays blank error
    By rndinit0 in forum General Technical Discussion & Troubleshooting
    Replies: 2
    Last Post: 01-20-2006, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •