Results 1 to 7 of 7

Thread: [EXIM 4.68] Problem with CentOS5

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Sep 2005
    Location
    The Netherlands
    Posts
    118

    [EXIM 4.68] Problem with CentOS5

    Hi,

    Yust updated Exim to 4.68 on two boxes running CentOS5, and it went wrong. Someone familiar with the error below? I tried to remove "/var/run/exim/pid" and "/var/lock/subsys/exim".
    Boxes are P4-2400 and Athlon 2600.

    Code:
    awk '{ print ($1+1) }' cnumber.h > cnumber.temp
    rm -f cnumber.h; mv cnumber.temp cnumber.h
    gcc version.c
    rm -f exim
    gcc -o exim
    rfc2047.o: In function `rfc2047_decode2':
    rfc2047.c:(.text+0x395): undefined reference to `libiconv_open'
    rfc2047.c:(.text+0x45a): undefined reference to `libiconv'
    rfc2047.c:(.text+0x539): undefined reference to `libiconv_close'
    collect2: ld returned 1 exit status
    make[1]: *** [exim] Error 1
    make[1]: Leaving directory `/usr/local/updatescript/exim-4.68/build-Linux-i386'
    make: *** [go] Error 2
    
    Installation directory is /usr/sbin
    
    
    *** /usr/local/updatescript/exim-4.68/build-Linux-i386/exim does not exist or is empty
    *** Have you built Exim successfully?
    *** Exim installation failed ***
    make: *** [install] Error 1
    cp: cannot stat `/usr/sbin/exim-4.68-1': No such file or directory
    chmod: cannot access `/usr/sbin/exim': No such file or directory
    Shutting down exim:
    Starting exim: /etc/init.d/exim: line 30: /usr/sbin/exim: No such file or directory
    
    
    
    Exim update done
    [root@server78 updatescript]#

  2. #2
    Join Date
    Sep 2005
    Location
    The Netherlands
    Posts
    118
    Quickfix: (CentOS 5)

    cd ~
    wget http://files.directadmin.com/service....68-1.i386.rpm
    rpm -Uvh --force --nodeps da_exim-4.68-1.i386.rpm
    service exim start

    >> exim works. Use dovecot? >> time to patch
    cd /usr/local/directadmin/customapache
    ./build todovecot [enter, enter, enter]

    >> Restart dovecot manualy if the script doesnt
    service dovecot restart

    Done.

    Weal, i suppose there is something wront while doing a dirchange in your script?
    Last edited by Randy; 09-14-2007 at 02:48 PM.

  3. #3
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,744
    Or, just edit Local/Makefile, add these lines:
    Code:
    HAVE_ICONV=yes   
    CFLAGS=-O -I/usr/local/include   
    EXTRALIBS_EXIM=-L/usr/local/lib -liconv

    And run:
    Code:
    make
    make install
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  4. #4
    Join Date
    Nov 2007
    Posts
    37
    Hello,


    I have some troblesw with exim, i try to upgrade from 4.67 to 4.68, i use update.script, but i have some problem.

    My Os is CentOS 4.5

    The error is:

    *** /usr/local/updatescript/exim-4.68/build-Linux-i386/exim does not exist or is empty
    *** Have you built Exim successfully?
    [root@s1 ~]#
    *** Exim installation failed ***
    [root@s1 ~]#
    [root@s1 ~]# *** /usr/local/updatescript/exim-4.68/build-Linux-i386/exim does not exist or is empty
    Starting exim: /etc/init.d/exim: line 30: /usr/sbin/exim: No such file or directory
    -bash: bill: command not found
    [root@s1 ~]# *** Have you built Exim successfully?
    -bash: bill: command not found
    [root@s1 ~]# *** Exim installation failed ***
    -bash: bill: command not found
    [root@s1 ~]# make: *** [install] Error 1
    -bash: make:: command not found
    [root@s1 ~]# cp: cannot stat `/usr/sbin/exim-4.68-1': No such file or directory
    > chmod: cannot access `/usr/sbin/exim': No such file or directory
    > Shutting down exim:
    > Starting exim: /etc/init.d/exim: line 30: /usr/sbin/exim: No such file or directory

    Now the exim is down, : [root@s1 build-Linux-i386]# /etc/init.d/exim start
    Starting exim: /etc/init.d/exim: line 30: /usr/sbin/exim: No such file or directory

    Also i try to upgrade thys . :

    rpm -U da_exim-4.68-1.i386.rpm

    file /etc/aliases from install of da_exim-4.68-1 conflicts with file from package setup-2.5.37-1.3


    Have any sugestion?

    Eduard.
    Last edited by Eduard; 01-10-2008 at 02:01 AM.

  5. #5
    Join Date
    Nov 2007
    Posts
    37
    Hello,

    The problem is solved,


    HTML Code:
    rpm -Uvh --force --nodeps da_exim-4.68-1.i386.rpm
    
    [root@s1 install]# /etc/init.d/exim start
    Starting exim:
    [root@s1 install]# /etc/init.d/exim status
    exim (pid 3411 3401) is running...

  6. #6
    Join Date
    Jan 2008
    Posts
    12
    Quote Originally Posted by Eduard View Post
    Hello,

    The problem is solved,


    HTML Code:
    rpm -Uvh --force --nodeps da_exim-4.68-1.i386.rpm
    
    [root@s1 install]# /etc/init.d/exim start
    Starting exim:
    [root@s1 install]# /etc/init.d/exim status
    exim (pid 3411 3401) is running...
    Finally someone posted how they solved it when its resolved!

Similar Threads

  1. trouble updating CentOS5 using yum
    By tincboy in forum General Technical Discussion & Troubleshooting
    Replies: 3
    Last Post: 04-12-2012, 08:32 AM
  2. ClamAV Install on 64 Bit CentOS5
    By topdog in forum Installation / System Requirements
    Replies: 10
    Last Post: 08-19-2010, 02:16 AM
  3. Error installing DA on Centos5.2
    By MXB-Media in forum Installation / System Requirements
    Replies: 2
    Last Post: 10-28-2008, 02:58 PM
  4. Exim 4.69 on centos5 32bit
    By Dauser2007 in forum How-To Guides
    Replies: 2
    Last Post: 09-24-2008, 08:10 PM
  5. mutliserver and centos5 64bit.
    By spirit in forum Installation / System Requirements
    Replies: 2
    Last Post: 06-10-2007, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •