View Poll Results: Do you like use update.script ?

Voters
340. You may not vote on this poll
  • yes, all time

    239 70.29%
  • no, some time

    45 13.24%
  • some time

    56 16.47%
Page 6 of 47 FirstFirst ... 4567816 ... LastLast
Results 101 to 120 of 936

Thread: [tools] update.script

  1. #101
    Join Date
    Feb 2007
    Posts
    486
    how to upgrade phpmyadmin to lastest version? other remain.

  2. #102
    Join Date
    Jun 2007
    Posts
    14
    eAccelerator requires Zend Engine API version 220060519.
    The Zend Engine API version 20050606 which is installed, is outdated.

    after installing eaccelerator
    CENTOS 5
    php 5.2.5
    anybody got idea how to fix it?

  3. #103
    Join Date
    Mar 2005
    Location
    Kingdom of Bahrain
    Posts
    957
    MODsecurity 2.1.5

    Wael

  4. #104
    Join Date
    Jan 2008
    Location
    Sweden
    Posts
    3
    Quote Originally Posted by @how@ View Post
    MODsecurity 2.1.5

    Wael
    This can only be installed on Apache 2.2.6, not the current Apache 2.2.8 that DA uses?

  5. #105
    Join Date
    Mar 2005
    Location
    Kingdom of Bahrain
    Posts
    957
    Quote Originally Posted by skenliv View Post
    This can only be installed on Apache 2.2.6, not the current Apache 2.2.8 that DA uses?
    work with 2.2.X

    Wael

  6. #106
    Join Date
    Mar 2005
    Location
    Kingdom of Bahrain
    Posts
    957
    Modsecurity2 Makefile fixed now and work with apache 2.2.x only

    Wael

  7. #107
    Join Date
    Dec 2007
    Posts
    28
    I am trying to run kiss start but get the error

    eth0: error fetching interface information: Device not found
    Could not determine MAIN_IP. Firewall script aborted!

    I have a VPS and my network interfaces are named differently

    [root@server ~]# ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:127.0.0.1 P-t-P:127.0.0.1 Bcast:0.0.0.0 Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
    RX packets:1103907 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1148960 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:174237091 (166.1 MiB) TX bytes:892270665 (850.9 MiB)

    venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:my.ip.addr.ess P-t-P:my.ip.address Bcast:ip.address.bcast Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

    venet0:1 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:my.ip.addr.ess P-t-P:my.ip.addr.ess Bcast:my.ip.addr.ess Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

    So what shud I have to do

  8. #108
    Join Date
    Dec 2007
    Posts
    28
    Well I tried changing eth0 to mine venet0:0 but now the error is different

    Since the ip_tables, ipt_state, and/or ipt_multiport modules do not exist, KISS can not function. Firewall script aborted!

    Any suggestion

  9. #109
    Join Date
    Sep 2007
    Posts
    7
    Hello,

    I like to update my mysql server to the last version ,

    MySQL 5.0.45 (You need to build php after upgrade)

    But how i can build php after upgrade?

    Thanks!

  10. #110
    Join Date
    Jan 2008
    Location
    /dev/null
    Posts
    702
    Quote Originally Posted by albyb View Post
    Hello,

    I like to update my mysql server to the last version ,

    MySQL 5.0.45 (You need to build php after upgrade)

    But how i can build php after upgrade?

    Thanks!
    Just upgrade your MySQL and after that download (the lastest version of) PHP and rebuild it.

    Then you are done.

  11. #111
    Join Date
    Jan 2008
    Location
    Sweden
    Posts
    3
    rizwan65:
    Kiss or APF will not work on an VPS because the kernel is not built with ip_tables on. If you need firewall, talk to your supplier of the VPS.

  12. #112
    Join Date
    Jan 2008
    Posts
    8
    I have installed modsecurity2 successfully with the update.script. However, now it seems to block all webmail from DA. See Apache Error Log:

    [Sat Jan 26 21:52:34 2008] [error] [client IP_ADDRESS] ModSecurity: Warning. Match of "rx ModSecurity" against "WEBSERVER_ERROR_LOG" required. [id "960913"] [msg "Invalid request"] [severity "CRITICAL"] [hostname "IP_ADDRESS"] [uri "/squirrelmail"] [unique_id "xxx"]

    How do I define appropriate rules to open all the webmails (Roundcube, Squirrelmail etc)?

  13. #113
    Join Date
    Feb 2007
    Posts
    53
    Quote Originally Posted by rizwan65 View Post
    Well I tried changing eth0 to mine venet0:0 but now the error is different

    Since the ip_tables, ipt_state, and/or ipt_multiport modules do not exist, KISS can not function. Firewall script aborted!

    Any suggestion

    Quote Originally Posted by ITDevil View Post
    you need to link xt_state.ko to ipt_state.ko and xt_multiport.ko to ipt_multiport.ko


    Code:
    $ ln -s /lib/modules/2.6.18-53.1.4.el5/kernel/net/netfilter/xt_state.ko /lib/modules/2.6.18-53.1.4.el5/kernel/net/ipv4/netfilter/ipt_state.ko
    
    $ ln -s /lib/modules/2.6.18-53.1.4.el5/kernel/net/netfilter/xt_multiport.ko /lib/modules/2.6.18-53.1.4.el5/kernel/net/ipv4/netfilter/ipt_multiport.ko
    REPLACE 2.6.18-53.1.4.el5 with your Kernel Folder

    I hope it helps
    i posted this solution a couple days ago

  14. #114
    Join Date
    Jan 2008
    Posts
    8
    Quote Originally Posted by hkim View Post
    I have installed modsecurity2 successfully with the update.script. However, now it seems to block all webmail from DA. See Apache Error Log:

    [Sat Jan 26 21:52:34 2008] [error] [client IP_ADDRESS] ModSecurity: Warning. Match of "rx ModSecurity" against "WEBSERVER_ERROR_LOG" required. [id "960913"] [msg "Invalid request"] [severity "CRITICAL"] [hostname "IP_ADDRESS"] [uri "/squirrelmail"] [unique_id "xxx"]

    How do I define appropriate rules to open all the webmails (Roundcube, Squirrelmail etc)?
    Anyone? It can not be just me who have experienced this problem? I tried to put in:

    <LocationMatch "^/squirrelmail">
    SecRemoveById 960913
    </LocationMatch>

    in /etc/modsecurity2/exclude.conf but it resulted in total stall of the httpd service. I saw then that it is not recommended to edit the .conf files since DirectAdmin rewrites them? What to do then?

  15. #115
    Join Date
    Apr 2007
    Posts
    14
    After upadate the ClamAV, I cannot send and receive email:
    I check the log:

    2008-01-27 16:08:40 1JJHYF-0001oR-KX malware acl condition: clamd: unable to connect to UNIX socket /tmp/clamd (Connection refused)
    Can you help me ?

  16. #116
    Join Date
    Mar 2006
    Posts
    361
    Quote Originally Posted by energetic View Post
    After upadate the ClamAV, I cannot send and receive email:
    I check the log:



    Can you help me ?
    Make sure /tmp/clamd exists.

  17. #117
    Join Date
    Apr 2007
    Posts
    14
    Do I need to create /tmp/clamd manually ?

  18. #118
    Join Date
    Jan 2008
    Posts
    8
    Quote Originally Posted by hkim View Post
    Anyone? It can not be just me who have experienced this problem? I tried to put in:

    <LocationMatch "^/squirrelmail">
    SecRemoveById 960913
    </LocationMatch>

    in /etc/modsecurity2/exclude.conf but it resulted in total stall of the httpd service. I saw then that it is not recommended to edit the .conf files since DirectAdmin rewrites them? What to do then?
    Is there anyone who got modsecurity2 to work with DirectAdmin and the updatescript? I have now disabled this but would like to have the kind of protection that modsecurity2 provides.

  19. #119
    Join Date
    Feb 2006
    Posts
    204

    SA update gives version.pm error

    After updating to SA 3.2.4 i get this:

    Code:
    Can't locate version.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib
    Any suggestions?

  20. #120
    Join Date
    Jul 2005
    Posts
    2,008
    update perl module

    perl -MCPAN -eshell

    install version

Page 6 of 47 FirstFirst ... 4567816 ... LastLast

Similar Threads

  1. Update script not working
    By Daskew78 in forum System-Level Technical Discussion
    Replies: 2
    Last Post: 10-29-2010, 06:31 PM
  2. Custom script after update
    By AxlF in forum CustomBuild
    Replies: 1
    Last Post: 07-13-2010, 01:06 PM
  3. Update error update script cannot find Python
    By HageHosting in forum DirectAdmin Version Updates
    Replies: 9
    Last Post: 11-24-2009, 06:10 AM
  4. All-in-1 update script
    By MadHag in forum DirectAdmin General Discussion
    Replies: 2
    Last Post: 09-14-2008, 10:25 AM
  5. wat about weal's update script?
    By snaaps in forum DirectAdmin General Discussion
    Replies: 14
    Last Post: 12-02-2007, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •