Results 1 to 10 of 10

Thread: [warn] module php5_module is already loaded, skipping

  1. #1
    Join Date
    Oct 2004
    Location
    Rio de Janeiro - Brasil
    Posts
    183

    [warn] module php5_module is already loaded, skipping

    hello,

    I got this error when I restart apache:

    [warn] module php5_module is already loaded, skipping

    this is normal?

  2. #2
    Join Date
    Nov 2004
    Location
    Germany - Bremen
    Posts
    195
    You have two of the lines in your httpd.conf: LoadModule php5_module /usr/lib/apache/libphp5.so

    Look into /etc/httpd/conf/httpd.conf and remove one off these lines

    LoadModule php5_module /usr/lib/apache/libphp5.so

  3. #3
    Join Date
    Oct 2004
    Location
    Rio de Janeiro - Brasil
    Posts
    183
    hi,

    yes, this works.

    thank you.

  4. #4
    Join Date
    Feb 2005
    Location
    The Netherlands
    Posts
    313
    The php5_module is loaded directly in:

    /etc/httpd/conf/httpd.conf

    but also in the by that file included:

    /etc/httpd/conf/extra/httpd-phpmodules.conf

    which one should I delete when I'm using the custombuild system?

  5. #5
    Join Date
    Jan 2006
    Posts
    223
    Quote Originally Posted by tristan View Post
    The php5_module is loaded directly in:

    /etc/httpd/conf/httpd.conf

    but also in the by that file included:

    /etc/httpd/conf/extra/httpd-phpmodules.conf

    which one should I delete when I'm using the custombuild system?
    It doesn't really matter in my opinion but the most suitable place to load the module is within httpd-phpmodules.conf. You'll want to keep httpd.conf as clean as possible.

  6. #6
    Join Date
    Feb 2005
    Location
    The Netherlands
    Posts
    313
    Thanks! Sounds reasonable, going to implement that...

  7. #7
    Join Date
    Oct 2003
    Location
    USA
    Posts
    266
    thank you, this removed the warning

  8. #8
    Join Date
    Apr 2012
    Posts
    142
    There is no "OK" when Starting, is it OK?

    [root@server ~]# service httpd restart
    Stopping httpd: [ OK ]
    Starting httpd:
    [root@server ~]#

  9. #9
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,947
    If it gets started and running without issues then it's OK.

  10. #10
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    And of course you can find and edit the httpd script (in CentOS usually at /etc/rc.d/init.d/httpd to print the OK if you want; it's an ordinary (though fairly complex) bash script.

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

Similar Threads

  1. module mod_php5.c is already added, skipping
    By azfandak in forum Apache (WWW)
    Replies: 2
    Last Post: 12-26-2008, 04:31 AM
  2. Apache not working after clean install - module php5_module not loaded + syntax error
    By Guillermo in forum General Technical Discussion & Troubleshooting
    Replies: 6
    Last Post: 12-23-2008, 08:41 AM
  3. CGI Module not loaded?
    By Rprp in forum Apache (WWW)
    Replies: 18
    Last Post: 05-31-2007, 07:07 AM
  4. [Wed Jun 14 19:56:10 2006] [warn] module perl_module is already loaded, skipping
    By crspyjohn in forum DirectAdmin General Discussion
    Replies: 3
    Last Post: 06-15-2006, 02:15 PM
  5. [warn] module perl_module is already loaded, skipping
    By IPaddress in forum Apache (WWW)
    Replies: 6
    Last Post: 08-30-2004, 08:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •