Results 1 to 11 of 11

Thread: After upgrading from 1.1.6 to 1.1.13 can't start Dovecot

  1. #1
    Join Date
    Oct 2008
    Posts
    8

    After upgrading from 1.1.6 to 1.1.13 can't start Dovecot

    Hello,

    After upgrading via custombuild from 1.1.6 to 1.1.13, I kept getting the following errors:

    /var/log/syslog
    Code:
    Dovecot v1.1.6 starting up 
    child 22685 (auth) returned error 89 (Fatal failure)
    auth(default): Fatal: Dovecot version mismatch: Master is v1.1.6, dovecot-auth is v1.1.13 (if you don't care, set version_ignore=yes)
    Fatal: Auth process died too early - shutting down
    When i try to service dovecot restart
    Code:
    Shutting down dovecot: /etc/init.d/dovecot: line 29: kill: (28733) - No such process
    
    Starting dovecot: Warning: Last died with error (see error log for more information): Auth process died too early - shutting down
    Os:Debian

    How do i fix this?

    Thanks.

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,748
    Try:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build dovecot
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Oct 2008
    Posts
    8
    Quote Originally Posted by smtalk View Post
    Try:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build dovecot
    Thanks but, ./build dovecot
    after
    Code:
    ......
    Making install in master
    make[2]: Entering directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    make[3]: Entering directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    test -z "/usr/libexec/dovecot" || /bin/mkdir -p "/usr/libexec/dovecot"
      /bin/sh ../../libtool   --mode=install /usr/bin/install -c 'ssl-build-param' '/usr/libexec/dovecot/ssl-build-param'
    libtool: install: /usr/bin/install -c ssl-build-param /usr/libexec/dovecot/ssl-build-param
    test -z "/usr/sbin" || /bin/mkdir -p "/usr/sbin"
      /bin/sh ../../libtool   --mode=install /usr/bin/install -c 'dovecot' '/usr/sbin/dovecot'
    libtool: install: /usr/bin/install -c dovecot /usr/sbin/dovecot
    /usr/bin/install: cannot remove `/usr/sbin/dovecot': Permission denied
    make[3]: *** [install-sbinPROGRAMS] Error 1
    make[3]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    make[2]: *** [install-am] Error 2
    make[2]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src'
    make: *** [install-recursive] Error 1
    Restarting dovecot.
    Shutting down dovecot: /etc/init.d/dovecot: line 29: kill: (3581) - No such process
    
    Starting dovecot: Warning: Last died with error (see error log for more information): Auth process died too early - shutting down

  4. #4
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,748
    Please post an output of:
    Code:
    whoami
    lsattr /usr/sbin/dovecot
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  5. #5
    Join Date
    Oct 2008
    Posts
    8
    server:~# whoami
    root
    server:~# lsattr /usr/sbin/dovecot
    suS-iadAc--------- /usr/sbin/dovecot

    Thanks

  6. #6
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,748
    Code:
    chattr -suSiadAc /usr/sbin/dovecot
    And try again
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  7. #7
    Join Date
    Oct 2008
    Posts
    8
    Quote Originally Posted by smtalk View Post
    Code:
    chattr -suSiadAc /usr/sbin/dovecot
    And try again
    I tried but it was not something

    Code:
    server:~# chattr -suSiadAc /usr/sbin/dovecot
    server:~#

  8. #8
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,748
    I wanted to say:

    Run the following afterwards:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build dovecot
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  9. #9
    Join Date
    Oct 2008
    Posts
    8
    I tried but I got the same errors

    Code:
    test -z "/usr/sbin" || /bin/mkdir -p "/usr/sbin"
      /bin/sh ../../libtool   --mode=install /usr/bin/install -c 'dovecot' '/usr/sbin/dovecot'
    libtool: install: /usr/bin/install -c dovecot /usr/sbin/dovecot
    /usr/bin/install: cannot remove `/usr/sbin/dovecot': Permission denied
    make[3]: *** [install-sbinPROGRAMS] Error 1
    make[3]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    make[2]: *** [install-am] Error 2
    make[2]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src/master'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/usr/local/directadmin/custombuild/dovecot-1.1.13/src'
    make: *** [install-recursive] Error 1
    Restarting dovecot.
    Shutting down dovecot: /etc/init.d/dovecot: line 29: kill: (25941) - No such process
    
    Starting dovecot: Warning: Last died with error (see error log for more information): Auth process died too early - shutting down
    Thanks

  10. #10
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,748
    Fixed using:
    Code:
    chattr -R -suSiadAc /usr/sbin
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  11. #11
    Join Date
    Oct 2008
    Posts
    8
    Thank you very much.

Similar Threads

  1. Dovecot will not start, please help!
    By frankc420 in forum General Technical Discussion & Troubleshooting
    Replies: 0
    Last Post: 11-13-2010, 05:21 AM
  2. can't start dovecot
    By xene in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 03-29-2009, 11:14 AM
  3. httpd failes to start after upgrading to 2.2.3
    By zurih in forum General Technical Discussion & Troubleshooting
    Replies: 6
    Last Post: 07-05-2008, 09:16 AM
  4. Upgrading Dovecot
    By keefe007 in forum Dovecot
    Replies: 1
    Last Post: 11-01-2006, 06:14 PM
  5. What to do after upgrading to Dovecot
    By albatroz in forum General Technical Discussion & Troubleshooting
    Replies: 3
    Last Post: 01-05-2006, 08:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •