Results 1 to 4 of 4

Thread: lenny with exim auth problem

  1. #1
    Join Date
    Jul 2009
    Location
    Romania, Bucharest
    Posts
    2

    lenny with exim auth problem

    Hello there,

    I'm a fresh member of this forum and software client, i think this is great, by for the last past days i have been dealing with some kind of a headake configuring exim on my debian lenny distro.

    I've try over and over again to google-it (on the exim auth problem) but there where poor topics related to my issue, but one link came in front of all, an archive, and it's about a past problem that a user had with exim in 2006, wich it never find solution.

    Here's the link :

    http://www.directadmin.com/forum/arc...p/t-15697.html

    I've even tried to install exim4, and switch the 2 versions of exim.pl i've found, one (older) from templates and the one from direct admin /servicies site.

    Same think with exim.conf and exim4.conf.

    The single big difference from the other users that shared the same problem is that i cannot send mail neither from squerremail, nor from other mail client ( but i can login and verify, dovecot work fine- i see).

    Some logs:

    login authenticator failed for localhost ([89.xx.xx.xx]) [127.0.0.1]: 535 Incorrect authentication data (set_id=client)

    login authenticator failed for ([10.xx.xx.x]) [86.xx.xx.xx]: 535 Incorrect authentication data (set_id=client)

    tcp 0 0 0.0.0.0:10025 0.0.0.0:* LISTEN 27073/exim4
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 27073/exim4
    tcp 0 0 0.0.0.0:2525 0.0.0.0:* LISTEN 27073/exim4


    Some some help will be great.

    Tnks in advance.

  2. #2
    Join Date
    Aug 2008
    Posts
    4,695

  3. #3
    Join Date
    Jul 2009
    Location
    Romania, Bucharest
    Posts
    2
    Ok, i've tried that link and still the problem persists.

    I must mention that in clients web page on the mail section i see : Cannot open the user password file for reading .

    Then i've searched the passwd file @ /etc/virtual/domain.com/passwd, on clients folder and found that passwd is an empty file.

    I belive that exim reads this file for authentication on users mail, as i can not send email, but i can authenticate on dovecot and search the inbox for emails.

    Also, after finding the passwd file being empty i've check the /home/client/.shadow file wich appear to be ok and written.

    In DA log it shows this line :

    Socket write error: fd is connected to a pipe or socket whose reading end is closed. When this happens the writing process will also receive a SIG_PIPE signal. (Thus, the write return value is seen only if the program catches, blocks or ignores this signal.)

    I'm stuck in a loop ...someone ?
    Last edited by metalalin; 07-13-2009 at 11:07 PM.

  4. #4
    Hello,

    We use "exim" and not "exim4".

    I would recommend first getting rid of the exim4 package.
    Once gone and stopped, type:
    Code:
    cd /usr/local/directadmin/scripts
    ./exim.sh
    which would re-install ours. A quick redo of scsi's comment would be a good idea to ensure you've got a clean exim.conf:
    http://help.directadmin.com/item.php?id=51

    If you're running dovecot don't forget to repatch.

    Note that for system account login, (eg same as DA login) for email, the /etc/virtual/domain.com/passwd does not apply at all. In fact, no domain applies for the system account email. It's real domain is your hostname. The /home/username/.shadow file is used for smtp-auth, and the /etc/shadow is used for everything else (dovecot, da login, ssh). If smtp-auth is failing try the following:

    Resave the password through DA. Click the big icon at the top, change the password, then repeat to set it back to the one you want. This should reset the /home/username/.shadow file's value. It might have been out of sync, or perhaps incorrect permissions. This will reset the value and permiissions.

    John

Similar Threads

  1. Exim segfaults with lenny
    By paulus in forum E-Mail
    Replies: 14
    Last Post: 01-18-2011, 09:34 AM
  2. Exim segfault on Debian 5 (Lenny)
    By HostingBrothers in forum E-Mail
    Replies: 4
    Last Post: 11-16-2010, 08:32 AM
  3. Exim SMTP AUTH problem
    By pug123 in forum E-Mail
    Replies: 2
    Last Post: 05-31-2007, 07:45 PM
  4. Exim domainowners Auth problem
    By davidb in forum E-Mail
    Replies: 9
    Last Post: 11-14-2006, 09:40 AM
  5. Exim SMTP auth problem
    By andyl in forum E-Mail
    Replies: 13
    Last Post: 02-04-2006, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •