Results 1 to 14 of 14

Thread: xslt extensions

  1. #1
    Join Date
    Jan 2011
    Posts
    10

    xslt extensions

    Hello , I just got the direct admin installed on my VPS but i am not able to figure out how to enable xslt extensions .

    It says as
    Code:
    For PHP5, make sure that PHP is compiled with the following extension:
    
                        --with-xsl
    So i have to run this on my terminal or add it some where ? and what does compiling means ?

    Thank You

  2. #2
    Join Date
    May 2009
    Location
    Erbil, Tarin Hills, Iraq
    Posts
    322
    If you run only php5, you find the configuration file here

    /usr/local/directadmin/custombuild/configure/ap2/configure.php5
    Open this and add;
    --with-xsl \
    And save

    If you run suPHP with php 4 and 5, you find the configuration file here

    /usr/local/directadmin/custombuild/configure/suphp/configure.php5
    Open this and add;
    --with-xsl \
    save it.

    You have you rebuild PHP after changes.

    ./build php y


    Use WinSCP to edit files on your server, much easier
    Last edited by ISOS6; 01-29-2011 at 01:42 PM.

  3. #3
    Join Date
    Jan 2011
    Posts
    10
    Hey thanks for the help . How can i rebuild php . I tried to use ./build php y in putty .. it said so such directory .

  4. #4
    Join Date
    May 2009
    Location
    Erbil, Tarin Hills, Iraq
    Posts
    322
    Have you changed the files?

    cd /usr/local/directadmin/custombuild
    ./build clean
    ./build php y

  5. #5
    Join Date
    Jan 2011
    Posts
    10
    Hello, Ya i changed the files and uploaded them and used the last command but for ./build php y it gave many errors like such directory not found and No targets specified and no makefile found. Stop. etc etc . Is it normal ?

  6. #6
    Join Date
    May 2009
    Location
    Erbil, Tarin Hills, Iraq
    Posts
    322
    Which OS are you using? Everything you do to install PHP again enter what I wrote in previous posts.

    Login with root in Putty

    cd /usr/local/directadmin/custombuild
    ./build clean
    ./build php y

  7. #7
    Join Date
    Jan 2011
    Posts
    10
    Now i got an error in the last

    /usr/local/directadmin/custombuild/configure/ap2/configure.php5: line 31: --with-xsl: command not found

    *** There was an error while trying to configure php. Check the configure/ap2/configure.php5 file

  8. #8
    Join Date
    May 2009
    Location
    Erbil, Tarin Hills, Iraq
    Posts
    322
    Put the entire contents of the configuration file here, let me see how it looks

  9. #9
    Join Date
    Jan 2011
    Posts
    10
    Here it is

    Code:
    #!/bin/sh
    ./configure \
    	--with-apxs2 \
    	--with-curl=/usr/local/lib \
    	--with-gd \
            --enable-gd-native-ttf \
            --with-ttf \
    	--with-gettext \
    	--with-jpeg-dir=/usr/local/lib \
    	--with-freetype-dir=/usr/local/lib \
    	--with-kerberos \
    	--with-openssl \
    	--with-mcrypt \
    	--with-mhash \
    	--with-mysql=/usr \
    	--with-mysqli=/usr/bin/mysql_config \
    	--with-pcre-regex=/usr/local \
    	--with-pdo-mysql=/usr \
    	--with-pear \
    	--with-png-dir=/usr/local/lib \
    	--with-zlib \
    	--with-zlib-dir=/usr/local/lib \
    	--enable-zip \
    	--with-iconv=/usr/local \
    	--enable-bcmath \
    	--enable-calendar \
    	--enable-ftp \
    	--enable-magic-quotes \
    	--enable-sockets \
    	--enable-mbstring
    	--with-xsl \

  10. #10
    Join Date
    May 2009
    Location
    Erbil, Tarin Hills, Iraq
    Posts
    322
    I have corrected now. slash should not be on the last line

    #!/bin/sh
    ./configure \
    --with-apxs2 \
    --with-curl=/usr/local/lib \
    --with-gd \
    --enable-gd-native-ttf \
    --with-ttf \
    --with-gettext \
    --with-jpeg-dir=/usr/local/lib \
    --with-freetype-dir=/usr/local/lib \
    --with-kerberos \
    --with-openssl \
    --with-mcrypt \
    --with-mhash \
    --with-mysql=/usr \
    --with-mysqli=/usr/bin/mysql_config \
    --with-pcre-regex=/usr/local \
    --with-pdo-mysql=/usr \
    --with-pear \
    --with-png-dir=/usr/local/lib \
    --with-zlib \
    --with-zlib-dir=/usr/local/lib \
    --enable-zip \
    --with-iconv=/usr/local \
    --enable-bcmath \
    --enable-calendar \
    --enable-ftp \
    --enable-magic-quotes \
    --enable-sockets \
    --enable-mbstring \
    --with-xsl
    Edit your file and rebuild with N

    ./build php n

  11. #11
    Join Date
    Jan 2011
    Posts
    10
    Thank You .. thank you very very much .

  12. #12
    Join Date
    Apr 2012
    Posts
    2
    I have trouble with same issue. i did all above but i get this error.

    Code:
    /usr/local/lib/libxslt.so: undefined reference to `xmlDictQLookup@LIBXML2_2.6.0'
    /usr/local/lib/libxslt.so: undefined reference to `xmlNewText@LIBXML2_2.4.30'
    /usr/local/lib/libxslt.so: undefined reference to `htmlSetMetaEncoding@LIBXML2_2.4.30'
    /usr/local/lib/libexslt.so: undefined reference to `xmlXPathPopBoolean@LIBXML2_2.4.30'
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] Error 1
    i googled all the web but i coulnt find any solution. can anybody help me? I use centos 5 with directadmin and php 5.2.17

  13. #13
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    Hello,

    I could try, send me a PM with your details for a quote.
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  14. #14
    Join Date
    May 2012
    Posts
    2
    Quote Originally Posted by melihucar View Post
    I have trouble with same issue. i did all above but i get this error.

    Code:
    /usr/local/lib/libxslt.so: undefined reference to `xmlDictQLookup@LIBXML2_2.6.0'
    /usr/local/lib/libxslt.so: undefined reference to `xmlNewText@LIBXML2_2.4.30'
    /usr/local/lib/libxslt.so: undefined reference to `htmlSetMetaEncoding@LIBXML2_2.4.30'
    /usr/local/lib/libexslt.so: undefined reference to `xmlXPathPopBoolean@LIBXML2_2.4.30'
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] Error 1
    i googled all the web but i coulnt find any solution. can anybody help me? I use centos 5 with directadmin and php 5.2.17
    please leave your configuration file ,let us see how it looks

    thank you

    طراحی وب سایت

Similar Threads

  1. xslt
    By vigneshwaran in forum Off-Topic Discussion
    Replies: 1
    Last Post: 02-13-2012, 03:32 AM
  2. Recompile PHP5 with xslt extension ?
    By circuit_breaker in forum Installation / System Requirements
    Replies: 2
    Last Post: 08-14-2010, 11:17 AM
  3. Need help with XSLT
    By kevin01 in forum MySQL / PHP
    Replies: 1
    Last Post: 02-02-2006, 09:04 AM
  4. xslt?
    By os2lover in forum MySQL / PHP
    Replies: 1
    Last Post: 01-05-2005, 03:03 PM
  5. Failing during 'make' while trying to add XSLT support to PHP
    By cbooth7575 in forum System-Level Technical Discussion
    Replies: 1
    Last Post: 12-13-2004, 08:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •