I am trying to install mod_scgi, but httpd-mmn is missing.

error: Failed dependencies:
httpd-mmn = 20051115 is needed by mod_scgi-1.13-1.el5.x86_64

I am using the CentOS with DirectAdmin from OVH's OS installer.

I have ran a YUM Update, and it didn't find anything. I do have httpd installed.