Results 1 to 3 of 3

Thread: Exim 4.7.6 Build Error?

  1. #1
    Join Date
    Nov 2005
    Location
    USA
    Posts
    228

    Exim 4.7.6 Build Error?

    OS FreeBSD 8.2 64bit
    #uname -a
    FreeBSD John.xxx.com 8.2-STABLE FreeBSD 8.2-STABLE #0: Thu Sep 8 09:21:59 CDT 2011 meeinter99@John.xxx.com:/usr/obj/usr/src/sys/Opteron64 amd64


    cyrus_sasl.c:282: error: 'SASL_FAIL' undeclared (first use in this function)
    cyrus_sasl.c:282: error: 'SASL_BUFOVER' undeclared (first use in this function)
    cyrus_sasl.c:283: error: 'SASL_BADMAC' undeclared (first use in this function)
    cyrus_sasl.c:283: error: 'SASL_BADAUTH' undeclared (first use in this function)
    cyrus_sasl.c:284: error: 'SASL_NOAUTHZ' undeclared (first use in this function)
    cyrus_sasl.c:284: error: 'SASL_ENCRYPT' undeclared (first use in this function)
    cyrus_sasl.c:285: error: 'SASL_EXPIRED' undeclared (first use in this function)
    cyrus_sasl.c:285: error: 'SASL_DISABLED' undeclared (first use in this function)
    cyrus_sasl.c:286: error: 'SASL_NOUSER' undeclared (first use in this function)
    cyrus_sasl.c:298: error: 'SASL_NOMECH' undeclared (first use in this function)
    cyrus_sasl.c:329: error: 'SASL_USERNAME' undeclared (first use in this function)
    cyrus_sasl.c: In function 'auth_cyrus_sasl_version_report':
    cyrus_sasl.c:359: error: 'SASL_VERSION_MAJOR' undeclared (first use in this function)
    cyrus_sasl.c:359: error: 'SASL_VERSION_MINOR' undeclared (first use in this function)
    cyrus_sasl.c:359: error: 'SASL_VERSION_STEP' undeclared (first use in this function)
    *** Error code 1

    Stop in /usr/local/directadmin/custombuild/exim-4.76/build-FreeBSD-amd64/auths.
    *** Error code 1

    Stop in /usr/local/directadmin/custombuild/exim-4.76/build-FreeBSD-amd64.
    *** Error code 1

    Stop in /usr/local/directadmin/custombuild/exim-4.76.
    -e \n*** The make has failed, would you like to try to make again? (y,n):

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,121
    And is cyrus-sasl installed?

    Try to install /usr/ports/security/cyrus-sasl2

  3. #3
    Join Date
    Nov 2005
    Location
    USA
    Posts
    228
    Good Job

    Thank

Similar Threads

  1. error on ./build exim
    By dreamfox in forum CustomBuild
    Replies: 8
    Last Post: 02-12-2013, 11:46 AM
  2. Exim 4.72 build fails
    By bdj in forum CustomBuild
    Replies: 25
    Last Post: 01-10-2011, 08:27 PM
  3. exim won't install with build
    By WaaaghNL in forum CustomBuild
    Replies: 4
    Last Post: 12-07-2009, 08:28 AM
  4. Exim build error
    By ostendo in forum CustomBuild
    Replies: 14
    Last Post: 01-30-2009, 03:09 AM
  5. Exim src.rpm build for x86_64
    By Sc0uT in forum Admin-Level Difficulties
    Replies: 0
    Last Post: 06-03-2007, 06:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •