Page 2 of 2 FirstFirst 12
Results 21 to 31 of 31

Thread: FreeBSD 9.0

  1. #21
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    With default install fail at the same line, checked, file services.tar.gz exist.

    Code:
    freebsd# cd packages/
    freebsd# ll
    total 96468
    -rw-r--r--   1 root  wheel       549081 Mar 25  2010 da_exim-4.71-1.tgz
    -rw-r--r--   1 root  wheel       765043 Dec  1  2010 da_proftpd-1.3.3c.tgz
    -rw-r--r--   1 root  wheel       799806 Aug 26 17:00 da_proftpd-1.3.3e.tgz
    drwxr-xr-x   6 3168  staff         1024 Jan 16 09:33 majordomo-1.94.5
    -rwxr-xr-x   1 root  wheel       312244 Jul 29  2003 majordomo-1.94.5.tar.gz
    -rw-r--r--   1 root  diradmin  21303054 Jan 16 00:40 mysql-4.1.20-unknown-freebsd5.3-i386.tar.gz
    -rw-r--r--   1 root  wheel     33945637 Jun 16  2011 mysql-5.1.57-freebsd8.0-x86_64.tar.gz
    drwxr-xr-x  14 root  wheel         1024 Jan 16 09:33 ncftp-3.2.4
    -rw-r--r--   1 root  diradmin    584479 Jan 16 00:15 ncftp-3.2.4-src.tar.gz
    -rw-r--r--   1 root  diradmin   4316983 Jan 16 00:35 phpMyAdmin-2.11.11.3-all-languages.tar.gz
    -rw-r--r--   1 root  diradmin  35644665 Oct 26 10:14 services.tar.gz
    -rw-r--r--   1 root  diradmin     15184 Jan 16 00:17 sysbk.tar.gz
    -rw-r--r--   1 root  wheel       168154 Mar 29  2010 webalizer
    Ive also noticed that if run "mysql" command i got this error:

    Code:
    Shared object "libncurses.so.5" not found, required by "mysql"
    So, maybe ncurses package get not installed for some reason or not correctly linked?

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  2. #22
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Tried install first ncurses using pkg_add but same result.

    Code:
    freebsd# ll /usr/lib/libncurses.so.5
    -rwxr-xr-x  1 root  wheel  151539 Jan 16 09:45 /usr/lib/libncurses.so.5
    freebsd# ll /usr/local/lib/libncurses.so.5
    lrwxr-xr-x  1 root  wheel  17 Dec  5 23:33 /usr/local/lib/libncurses.so.5 -> libncurses.so.5.9
    Actually the library seems to be correctly there...

    Any hint?

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  3. #23
    Hi guys, don't worry about MySQL 4, or 5.1.. That's just the default when mysql.sh doesn't have the OS version listed.
    With FreeBSD 9, it will include 5.5.20.

    I've updated the update.tar.gz for mysql.sh, proftpd.sh and exim.sh to support FreeBSD 9 with the newly built packages, found here:
    http://files1.directadmin.com/servic...ebsd9.0-64bit/

    and which are added to services_freebsd90_64.tar.gz
    Please allow 24 hours for files server rsync propagation, as the other files servers won't have it yet.

    The setup.sh has also been updated to find the new services file.

    The FreeBSD 8 binaries seem to be working on FreeBSD 9, so that will save us needing to build a new compile box (and a bit on our power bill )

    The code-name in the licenses OS list is FB964, and is in ALPHA testing, so something is most likely going to break at install time, and there will be minimal support at this stage of the game.
    Please post issues to the FreeBSD 9 64-bit BETA forum for the time being.

    Thanks to Andrea for providing us with the test box to compile the packages and to do very preliminary testing.

    John

  4. #24
    Actually, I did need to use this guide:
    http://help.directadmin.com/item.php?id=369

    but I'm not sure if that was a result of installing FreeBSD 8 bits on the FreeBSD 9 box.. in any case, we'll find out when we do a few fresh installs.

    John

  5. #25
    Join Date
    May 2005
    Location
    Montreal, QC, Canada
    Posts
    110
    Quote Originally Posted by DirectAdmin Support View Post
    Actually, I did need to use this guide:
    http://help.directadmin.com/item.php?id=369

    but I'm not sure if that was a result of installing FreeBSD 8 bits on the FreeBSD 9 box.. in any case, we'll find out when we do a few fresh installs.

    John
    This problem has persisted since FreeBSD 7.x. Each time I run ./build update, I must manually modify the 'build' script and remove the Kerberos references. I don't want to install the libraries as I have no use for Kerberos on a web server. I have always wondered why this was never taken into account: default FreeBSD installations do not install Kerberos, and DirectAdmin doesn't bother either. Why is it being referenced? It is the direct result of a lot of compile-time errors.
    FreeBSD <3

  6. #26
    I'm going to update the build scripts simply use make instead of the longer version if FreeBSD is being used.
    The line was likely added for the CentOS versions, and the compile "usually" works on FreeBSD, but it's not needed at all on FreeBSD, then we'll remove the CPPFLAGS part completely.

    John

  7. #27
    Join Date
    May 2008
    Posts
    424
    Works fine on FreeBSD 9 on my end... I am having problems with ipfw after the upgrade, but the rest is ok.

    P.S. A little bug in the build script:

    /usr/local/directadmin/custombuild: ./build update
    ./custombuild.tar.gz 100% of 106 kB 184 kBps
    extracting custombuild.tar.gz for 1.1 ...
    x custombuild/
    x custombuild/build
    x custombuild/configure/
    x custombuild/configure/dovecot/
    x custombuild/configure/dovecot/dovecot.conf
    x custombuild/configure/pureftpd/
    x custombuild/configure/pureftpd/configure.pureftpd
    x custombuild/configure/suphp/
    x custombuild/configure/suphp/configure.php5
    x custombuild/configure/suphp/configure.suphp
    x custombuild/configure/suphp/configure.php4
    x custombuild/configure/proftpd/
    x custombuild/configure/proftpd/configure.proftpd
    x custombuild/configure/ap1/
    x custombuild/configure/ap1/configure.apache_ssl
    x custombuild/configure/ap1/conf/
    x custombuild/configure/ap1/conf/extra/
    x custombuild/configure/ap1/conf/extra/httpd-userdir.conf
    x custombuild/configure/ap1/conf/extra/httpd-vhosts.conf
    x custombuild/configure/ap1/conf/extra/httpd-languages.conf
    x custombuild/configure/ap1/conf/extra/httpd-autoindex.conf
    x custombuild/configure/ap1/conf/extra/httpd-ssl.conf
    x custombuild/configure/ap1/conf/extra/httpd-default.conf
    x custombuild/configure/ap1/conf/extra/httpd-alias.conf
    x custombuild/configure/ap1/conf/extra/httpd-multilang-errordoc.conf
    x custombuild/configure/ap1/conf/extra/httpd-deflate.conf
    x custombuild/configure/ap1/conf/extra/httpd-info.conf
    x custombuild/configure/ap1/conf/extra/directadmin-vhosts.conf
    x custombuild/configure/ap1/conf/mime.types
    x custombuild/configure/ap1/conf/magic
    x custombuild/configure/ap1/conf/httpd.conf
    x custombuild/configure/ap1/configure.php5
    x custombuild/configure/ap1/configure.php4
    x custombuild/configure/ap2/
    x custombuild/configure/ap2/cert_config
    x custombuild/configure/ap2/conf/
    x custombuild/configure/ap2/conf/extra/
    x custombuild/configure/ap2/conf/extra/httpd-userdir.conf
    x custombuild/configure/ap2/conf/extra/httpd-vhosts.conf
    x custombuild/configure/ap2/conf/extra/httpd-languages.conf
    x custombuild/configure/ap2/conf/extra/httpd-autoindex.conf
    x custombuild/configure/ap2/conf/extra/httpd-ssl.conf
    x custombuild/configure/ap2/conf/extra/httpd-default.conf
    x custombuild/configure/ap2/conf/extra/httpd-alias.conf
    x custombuild/configure/ap2/conf/extra/httpd-dav.conf
    x custombuild/configure/ap2/conf/extra/httpd-directories-old.conf
    x custombuild/configure/ap2/conf/extra/httpd-mpm.conf
    x custombuild/configure/ap2/conf/extra/httpd-directories-new.conf
    x custombuild/configure/ap2/conf/extra/httpd-multilang-errordoc.conf
    x custombuild/configure/ap2/conf/extra/httpd-deflate.conf
    x custombuild/configure/ap2/conf/extra/httpd-mpm.conf_2.0
    x custombuild/configure/ap2/conf/extra/httpd-info.conf
    x custombuild/configure/ap2/conf/extra/directadmin-vhosts.conf
    x custombuild/configure/ap2/conf/extra/httpd-manual.conf
    x custombuild/configure/ap2/conf/mime.types
    x custombuild/configure/ap2/conf/magic
    x custombuild/configure/ap2/conf/httpd.conf
    x custombuild/configure/ap2/conf/httpd.conf_2.0
    x custombuild/configure/ap2/configure.php5
    x custombuild/configure/ap2/configure.apache
    x custombuild/configure/ap2/configure.php4
    ./versions.txt 100% of 5444 B 31 MBps
    File already exists: servers.txt
    MD5 Checksum on servers.txt passed.
    File already exists: httpd-2.4.1.tar.gz
    MD5 Checksum on httpd-2.4.1.tar.gz passed.
    File already exists: apr-1.4.6.tar.gz
    MD5 Checksum on apr-1.4.6.tar.gz passed.
    File already exists: apr-util-1.4.1.tar.gz
    MD5 Checksum on apr-util-1.4.1.tar.gz passed.
    File already exists: httpd_2
    File already exists: httpd_2_freebsd
    File already exists: httpd_2_debian
    File already exists: mime.types
    File already exists: mod_perl-2.0.4.tar.gz
    MD5 Checksum on mod_perl-2.0.4.tar.gz passed.
    File already exists: curl-7.24.0.tar.gz
    MD5 Checksum on curl-7.24.0.tar.gz passed.
    File already exists: pcre-8.20.tar.gz
    MD5 Checksum on pcre-8.20.tar.gz passed.
    File already exists: libmcrypt-2.5.8.tar.gz
    MD5 Checksum on libmcrypt-2.5.8.tar.gz passed.
    File already exists: mhash-0.9.9.9.tar.gz
    MD5 Checksum on mhash-0.9.9.9.tar.gz passed.
    File already exists: freetype-2.4.8.tar.gz
    MD5 Checksum on freetype-2.4.8.tar.gz passed.
    File already exists: libiconv-1.14.tar.gz
    MD5 Checksum on libiconv-1.14.tar.gz passed.
    File already exists: libxml2-2.7.6.tar.gz
    MD5 Checksum on libxml2-2.7.6.tar.gz passed.
    File already exists: libxslt-1.1.26.tar.gz
    MD5 Checksum on libxslt-1.1.26.tar.gz passed.
    File already exists: icu4c-4_8_1_1-src.tgz
    MD5 Checksum on icu4c-4_8_1_1-src.tgz passed.
    File already exists: php-5.4.0.tar.gz
    MD5 Checksum on php-5.4.0.tar.gz passed.
    File already exists: Mail-SpamAssassin-3.3.2.tar.gz
    MD5 Checksum on Mail-SpamAssassin-3.3.2.tar.gz passed.
    File already exists: clamav-0.97.3.tar.gz
    MD5 Checksum on clamav-0.97.3.tar.gz passed.
    File already exists: webalizer-2.23-05-src.tgz
    File already exists: proftpd-1.3.4a.tar.gz
    MD5 Checksum on proftpd-1.3.4a.tar.gz passed.
    File already exists: proftpd
    File already exists: proftpd_freebsd
    File already exists: proftpd_debian
    File already exists: suphp-0.7.1.tar.gz
    MD5 Checksum on suphp-0.7.1.tar.gz passed.
    File already exists: dovecot-2.1.1.tar.gz
    MD5 Checksum on dovecot-2.1.1.tar.gz passed.
    File already exists: dovecot.boot
    File already exists: dovecot.boot.freebsd
    File already exists: dovecot.boot.debian
    File already exists: dovecot.conf
    File already exists: exim.conf.dovecot.patch
    MD5 Checksum on exim.conf.dovecot.patch passed.
    File already exists: autoconf-2.68.tar.gz
    MD5 Checksum on autoconf-2.68.tar.gz passed.
    File already exists: m4-1.4.16.tar.gz
    MD5 Checksum on m4-1.4.16.tar.gz passed.
    File already exists: automake-1.11.1.tar.gz
    MD5 Checksum on automake-1.11.1.tar.gz passed.
    File already exists: libtool-2.4.tar.gz
    MD5 Checksum on libtool-2.4.tar.gz passed.
    Downloading .tar.gz...
    fetch: http://files.directadmin.com/service...build/.tar.gz: Not Found
    Downloaded file /usr/local/directadmin/custombuild/.tar.gz does not exist or is empty after download
    cwd is: /usr/local/directadmin/custombuild
    Fileserver might be down, using the backup file server..
    fetch: http://69.30.193.202/services/custombuild/.tar.gz: Not Found
    /usr/local/directadmin/custombuild:
    Last edited by wattie; 03-08-2012 at 02:10 PM.

  8. #28
    Join Date
    May 2008
    Posts
    424
    OK, so far everything is good and working properly. The problem mentioned above was not with ipfw but with NTPDATE application. I got ntpdate app running automatically at reboot. For some reason the firewall was stopping it and the system was hanging at boot.

    This I guess has absolutely nothing to do with directadmin. Everything in DA works properly, all software is running well. The only "issue" is that error message when doing ./build update:

    "Downloading .tar.gz...
    fetch: http://files.directadmin.com/service...build/.tar.gz: Not Found
    Downloaded file /usr/local/directadmin/custombuild/.tar.gz does not exist or is empty after download
    cwd is: /usr/local/directadmin/custombuild
    Fileserver might be down, using the backup file server..
    fetch: http://69.30.193.202/services/custombuild/.tar.gz: Not Found"

  9. #29
    Join Date
    May 2008
    Posts
    424
    DA Install (the setup.sh file) cannot work on FreeBSD 9 if there is no WGET installed from ports.

  10. #30
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    as far as i remember i did tell this to John and he did add a check for wget or fetch... are you using latest setup.sh or an old local copy?

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  11. #31
    Join Date
    May 2008
    Posts
    424
    I downloaded it directly from the server. Fresh FreeBSD 9.0 amd64 install. Sorry for the late reply.

    It was not the only thing I needed. Here is my ports list. I was adding things as soon as they was needed (of course some of them added dependencies):

    Code:
    autoconf-2.68                       =   up-to-date with port
    autoconf-wrapper-20101119           =   up-to-date with port
    automake-1.11.1                     =   up-to-date with port
    automake-wrapper-20101119           =   up-to-date with port
    bison-2.5,1                         =   up-to-date with port
    bsdpan-ExtUtils-Embed-1.14          !   Comparison failed
    cmake-2.8.7                         =   up-to-date with port
    cyrus-sasl-2.1.25_2                 =   up-to-date with port
    db41-4.1.25_4                       =   up-to-date with port
    exim-4.77-1                         !   Comparison failed
    expat-2.0.1_2                       =   up-to-date with port
    fontconfig-2.8.0_1,1                =   up-to-date with port
    freetype2-2.4.7                     <   needs updating (port has 2.4.9_1)
    gd-2.0.35_7,1                       =   up-to-date with port
    gettext-0.18.1.1                    =   up-to-date with port
    gmake-3.82                          =   up-to-date with port
    gmp-5.0.4                           =   up-to-date with port
    gnutls-2.12.18                      =   up-to-date with port
    help2man-1.40.8                     =   up-to-date with port
    jpeg-8_3                            =   up-to-date with port
    libgpg-error-1.10                   =   up-to-date with port
    libiconv-1.13.1_2                   =   up-to-date with port
    libidn-1.22                         =   up-to-date with port
    m4-1.4.16,1                         =   up-to-date with port
    nettle-2.4                          =   up-to-date with port
    p11-kit-0.11                        =   up-to-date with port
    p5-Locale-gettext-1.05_3            =   up-to-date with port
    perl-5.14.2_2                       =   up-to-date with port
    pkg-config-0.25_1                   =   up-to-date with port
    png-1.4.11                          =   up-to-date with port
    portupgrade-2.4.9.3_1,2             =   up-to-date with port
    proftpd-1.3.4a                      !   Comparison failed
    ruby-1.8.7.358,1                    =   up-to-date with port
    ruby18-bdb-0.6.6                    =   up-to-date with port
    wget-1.13.4_1                       =   up-to-date with port
    Looking at the list I manually had to add cmake (required for MySQL 5.5, elsewhere it was showing error), cyrus-sasl (for exim), perl-5.14 (for exim).

    Only the "portupgrade" port was not required by anything.
    Last edited by wattie; 04-20-2012 at 02:49 PM.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. FreeBSD Security Advisory FreeBSD-SA-04:05.openssl
    By rhoekman in forum FreeBSD 5.x
    Replies: 3
    Last Post: 10-20-2005, 10:28 PM
  2. Replies: 0
    Last Post: 03-29-2005, 06:52 AM
  3. Replies: 1
    Last Post: 07-10-2004, 12:52 AM
  4. Replies: 0
    Last Post: 07-01-2004, 01:36 AM
  5. FreeBSD Security Advisory FreeBSD-SA-04:05.openssl
    By rhoekman in forum FreeBSD 4.x
    Replies: 0
    Last Post: 03-17-2004, 09:46 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •