Results 1 to 17 of 17

Thread: Fatal Error on Admin Page

  1. #1
    Join Date
    Mar 2008
    Posts
    108

    Fatal Error on Admin Page

    At the bottom under Extra Features Section

    Fatal error: Directive 'allow_call_time_pass_reference' is no longer available in PHP in Unknown on line 0

    Possibly correlated with latest directadmin update 1.403

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    Hello,

    Do you have any 3rd plugins installed in Directadmin? Will you show a screenshot of a page with that error?
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  3. #3
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Have you updated PHP to a different release? Are you using default skin?

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  4. #4
    Join Date
    Mar 2008
    Posts
    108
    That's it, I have updated php. How to fix?

  5. #5
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Well, depend, if you changed php release and you are not using a default skin you have to update or skin or downgrade php to older release.

    If you are using a default skin you need to probably re-download the skin cause has not been updated, or, maybe directadmin is not up2date.

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    Quote Originally Posted by divinelighting View Post
    That's it, I have updated php. How to fix?
    You did not answer my questions. Here they are:

    Do you have any 3rd plugins installed in Directadmin? Will you show a screenshot of a page with that error?

    Note, default Directadmin with default skins does not give such an error. So you must be using something from 3rd parties.
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  7. #7
    Join Date
    Mar 2008
    Posts
    108
    No 3rd party plugins that I am aware of. Screenshot attached.
    Attached Images Attached Images

  8. #8
    Join Date
    Aug 2008
    Posts
    4,697
    You might be able to just turn off error display in php.ini

  9. #9
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Is DirectAdmin up2date?

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  10. #10
    Join Date
    Mar 2008
    Posts
    108
    Yes, directadmin is up to date.

    Now I have another issue, probably unrelated. Yesterday I accidentally deleted some web site files from /domains/MYDOMAIN.COM/
    I deleted folders public_ftp, .httpasswd, files private_html and some public_html files. I restored everything from yesterday's backup and all is good with one wierd exception: SSL is not working. The website is www.divinelighting.com and I disabled secure checkout because of the issue. However, you can see the error by changing the path to https. When that is done, a page with only "./public_html" is displayed.

    This is what I was told on the zencart forum:

    Firstly, I can confirm that your site is now fully functional without SSL. I suggest you keep it that way until the issue has been resolved, because it will still allow sales (and since you use PayPal express you probably don't *need* SSL anyway).

    Secondly, it is not a cache or sessions issue. This is easily confirmed by pointing your browser to any page on your site and using https:// rather than just http://

    Example:
    https://www.divinelighting.com shows the error
    http://www.divinelighting.com works just fine.

    By using these URL's explicitly is effectively showing that the problem has nothing to do with your zencart configuration files, or its session management. It could (in theory) be a cache problem, but trying URL's that I know wouldn't exist (eg https://www.divinelighting.com/wally) is a good way of elimitating this possibilty (if a page has never been requested before, it could never be in a cache).

    In other words, with just one single test to https://www.divinelighting.com/wally has elimiinated many possible causes. (including URL rewrites/redirects)

    OK, so here's the cruncher... I still can't think of *anything* that would cause the symptoms that are being presented. At the VERY LEAST I would have expected https://www.divinelighting.com/wally to redirect me to a page not found error (as it does when I attempt http://www.divinelighting.com/wally)

    So, where to from here? I really don't think this problem has anything to do with you or zencart. I'm thinking it has something to do with the server configuration itself. For reasons that I can't explain, your SSL server simply isn't doing what an SSL server should be doing. It appears to have no concept of what files it should be serving up and the fact that it is showing the folder name ./public_html can only be caused by a server configuration error.

    You will need to contact your host for help with this one. It is NOT something that you can fix yourself. Please feel free to post a copy of this posting when asking your host for help. It'll help prevent them feeding you billshot and suggesting that it is a zencart (or similar) configuration error.

    DO mention about the accidental deletion of your files because there *may* have been a 'symbolic link' (or similar) *hidden* in your public_html folder that got accidently deleted, and if so, they'll know about it and will be able to quickly restore it for you without any further investigationing

    Either way, it is stil lsomething that only your host can fix.

  11. #11
    Join Date
    Mar 2008
    Posts
    108
    I think the ssl problem is something to do with pivate_html, as it contains exactly the phrase "./public_html"

  12. #12
    Join Date
    Mar 2008
    Posts
    108
    Solved the SSL problem. Symbolic link was broken. Found solution here: http://www.webhostingtalk.com/archiv.../t-315593.html

    Deleted private_html and then executed

    ln -s /home/USERNAME/domains/DOMAIN.COM/public_html /home/USERNAME/domains/DOMAIN.COM/private_html
    As far as the php issue goes, if there is no obvious solution I will not worry about it, as I will be moving to a new server soon.

  13. #13
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    For reinstall the skin you should try:

    Code:
    cd /usr/local/directadmin/data/skins
    ./packskins.sh
    Sorry for didnt reply to SSL problem, timezone difference i suppose i was sleeping, if not, was an easy solution ^^

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  14. #14
    Join Date
    Mar 2008
    Posts
    108
    That didn't do it. I suspect the problem is a botched php upgrade/config.

  15. #15
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    I guess, you're running PHP 5.4. So follow this instructions made by Martynas Bendorius:

    You should comment out allow_call_time_pass_reference in php.ini, because it's no longer available. The following should fix it:

    Code:
    perl -pi -e 's/^allow_call_time_pass_reference/;allow_call_time_pass_reference/' /usr/local/lib/php.ini
    http://www.directadmin.com/forum/sho...391#post218391
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  16. #16
    Join Date
    Mar 2008
    Posts
    108
    The phrase allow_call_time_pass_reference is not in my php.ini

  17. #17
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

Similar Threads

  1. Replies: 1
    Last Post: 12-16-2008, 05:21 AM
  2. Fatal trap 12: page fault while in kernel mode
    By patrik in forum FreeBSD 6.x
    Replies: 27
    Last Post: 02-07-2008, 03:32 AM
  3. Direct Admin Interface: Fatal error: Call to undefined function apache_note()
    By andren in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 11-25-2007, 09:41 AM
  4. Direct admin login page error
    By Vincent in forum General Technical Discussion & Troubleshooting
    Replies: 18
    Last Post: 08-19-2007, 12:36 PM
  5. Replies: 4
    Last Post: 08-12-2007, 05:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •