Results 1 to 9 of 9

Thread: Pcre 8.31

  1. #1
    Join Date
    Sep 2004
    Posts
    137

    Pcre 8.31

    Version 8.31 was released 06th of July 2012 with 41 fixes.

    Version 8.30 was released 4th of February 2012 with 16 fixes.

    Version 8.21 was released 12th of December, 2011 with 29 fixes.

    custombuild is still on version 8.20.

  2. #2
    Join Date
    Apr 2009
    Posts
    1,939
    Here is the reason for the old version of pcre:

    # DirectAdmin added pcre 8.21 to custombuild in december last year, however it was having a bug that created problem for people running vBulletin http://www.directadmin.com/forum/showthread.php?t=42532 - because of that, DirectAdmin downgraded pcre 8.21 to pcre 8.20 in custombuild.

    # When pcre 8.30 was released, the vBulletin bug was fixed in that version, and DirectAdmin upgraded pcre in custombuild from version 8.20 to new version 8.30. But the new version pcre 8.30 did have problems with new DirectAdmin installs (existing installs did not get problems), because of that, DirectAdmin downgraded only a few minutes later from pcre 8.30 to pcre 8.20 in custombuild. Here is John replys about this on email dated March 7, 2012:

    I actually had to downgrade pcre again.

    Existing installs are fine to use pcre 8.30 (exim won't even use it without a recompile), but for new installs, all exim binaries are still linked against the old libpcre.so.0, whereas the new version creates libpcre.so.1, this will break exim since libpcre.so.0 won't exist.

    I'll have to:
    1) have custombuild create links to the new version from the old link
    2) test to ensure that the existing binaries, which are build vs the old version, still work with the new one... as there may be linking mismatches.
    So to summarize, pcre 8.21 has bug causing trouble for vBulletin, that bug was fixed in pcre 8.30, but pcre 8.30 cause problems as John describe in quoted text above.

    I have now sent DirectAdmin support email and asked him to try to find a solution to all this, so that he can add the new released pcre 8.31 to custombuild.

    Edit: I found this about pcre 8.30 http://www.directadmin.com/forum/showthread.php?t=43043 - please see user "Arieh" reply to that thread, he say httpd wouldn't compile after upgrade to pcre 8.30. I would guess that should be related to the problems John explain in the quoted text above, but I don't know.
    Last edited by ditto; 07-25-2012 at 01:48 AM.

  3. #3
    Join Date
    Sep 2004
    Posts
    137
    Ok. I'll just stick with pcre-8.20 with custombuild and adding 8.31 manually because I do need this particular version.

    But thanks for the reply. Knowing why something is the way it is helps

  4. #4
    Hello,

    Bottom line, is that the newer PCRE versions cause a lot of issues because it has many internal code changes.. so anything using it needs to be updated to match the new function calls.
    A lot of things have not yet done so.
    Also, they change from a .so.0 to a .so.1, so if we just compile the newer versions, then all pre-compiled binaries (like exim) will break.

    For now, apart from manual changes to the versions.txt, the solution will be to add a new entry to the options.conf for something like "new_pcre", or something like that, and have the option to turn it on *after* the old pcre is already compiled.
    Again, some things may not compile with it, so we need to ensure we can shut it off until we get the whole picture.
    This may be only added to custombuild 2.0, but will decide as it's nearer to release.

    John

  5. #5
    Join Date
    Sep 2004
    Posts
    137
    I'm happy it's being considered. I'll hold my breath while we wait.

  6. #6
    Join Date
    Apr 2009
    Posts
    1,939
    @Invader Zim, the newest pcre 8.32 is now available in custombuild (add new_pcre=yes to options.conf), I posted about it here http://www.directadmin.com/forum/showthread.php?t=45228

  7. #7
    Join Date
    Sep 2004
    Posts
    137
    Excellent! I shall have at it this very evening.

  8. #8
    Join Date
    Jan 2011
    Location
    New York
    Posts
    135
    Does it have as many issues?
    Need to contact DirectAdmin? Use SafeSubmit
    PM me for great SSL prices
    Got questions? Shoot me a PM!
    Check out my blog

  9. #9
    Join Date
    Sep 2004
    Posts
    137
    I really should've updated, shouldn't I? It works like a charm. All that's missing is an automatic car wash option.

Similar Threads

  1. Downgrade pcre-8.13 to pcre-8.12
    By pera in forum CustomBuild
    Replies: 0
    Last Post: 10-09-2011, 03:10 PM
  2. PCRE error
    By cmavroudis in forum CentOS
    Replies: 1
    Last Post: 06-22-2011, 06:59 AM
  3. It seems like mod_security want to use other PCRE?
    By janton in forum General Technical Discussion & Troubleshooting
    Replies: 7
    Last Post: 02-09-2011, 03:19 AM
  4. PCRE build problem --configure: error: in `/usr/local/directadmin/custombuild/pcre-7.
    By myplay.it in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 09-27-2009, 08:30 AM
  5. Pcre
    By ESKosters in forum CustomBuild
    Replies: 0
    Last Post: 03-01-2009, 06:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •