Results 1 to 10 of 10

Thread: PHP 5.4.8 and PHP 5.3.18 released!

  1. #1
    Join Date
    Oct 2003
    Location
    Switzerland
    Posts
    2,097

    PHP 5.4.8 and PHP 5.3.18 released!

    The PHP development team announces the immediate availability of PHP 5.4.8 and PHP 5.3.18. These releases fix over 20 bugs. All users of PHP are encouraged to upgrade to PHP 5.4.8, or at least 5.3.18.

    Key enhancements in these releases include:

    *Fixed bug #63111 (is_callable() lies for abstract static method)
    *Fixed bug #61442 (exception threw in __autoload can not be catched

    For source downloads of PHP 5.4.8 and PHP 5.3.18 please visit our downloads page

    The list of changes are recorded in the ChangeLog.
    Olivier
    interfaCentre - We design custom hosting solutions

    Custom apps, scripts and configurations for easy and secure access to all hosting services
    Full Personal Information Management suite with mobile synchronisation
    PHP, Ruby, Node.js and Python hosting with 1-click app install

  2. #2
    Join Date
    Oct 2012
    Location
    Hanoi
    Posts
    120
    Hi,
    I'm using php 5.4.7. How can I upgrade to this version?
    thanks

  3. #3
    Join Date
    Feb 2012
    Posts
    50
    Here's what I do:
    cd /usr/local/directadmin/custombuild
    ./build clean
    ./build update
    ./build update_versions

  4. #4
    Join Date
    Apr 2009
    Posts
    1,963
    Quote Originally Posted by saosangmo View Post
    Hi,
    I'm using php 5.4.7. How can I upgrade to this version?
    thanks
    You must wait until the new version is added in custombuild. First you do this to check what version is available:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build versions
    Then if there is a new php version, then you do this to upgrade:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build php n

  5. #5
    Join Date
    Oct 2012
    Location
    Hanoi
    Posts
    120
    thank ditto,
    I update php successfully.
    -saosangmo

  6. #6
    Join Date
    Mar 2012
    Posts
    161
    Quote Originally Posted by interfasys View Post
    The PHP development team announces the immediate availability of PHP 5.4.8 and PHP 5.3.18. These releases fix over 20 bugs. All users of PHP are encouraged to upgrade to PHP 5.4.8, or at least 5.3.18.
    Hello,
    Do you have any idea about php 5.4 and suhosin 0.9.33 compatible?
    I have tried to install php 5.4, but it does not load suhosin.so.

    Thank you.

  7. #7
    Join Date
    Oct 2003
    Location
    Switzerland
    Posts
    2,097
    Suhosin has not been updated yet to Support PHP 5.4. Not sure they ever will tbh.
    You can follow progress here:
    https://github.com/stefanesser/suhosin
    Olivier
    interfaCentre - We design custom hosting solutions

    Custom apps, scripts and configurations for easy and secure access to all hosting services
    Full Personal Information Management suite with mobile synchronisation
    PHP, Ruby, Node.js and Python hosting with 1-click app install

  8. #8
    Join Date
    Nov 2004
    Location
    The Netherlands
    Posts
    123
    Hi all,

    Getting:
    Warning: Unknown: open_basedir restriction in effect. File(pear/install-pear-nozlib.phar) is not within the allowed path(s): (/var/www/html/:/tmp/) in Unknown on line 0
    at the end of the install (Installing PEAR environment: /usr/local/lib/php/). I know what is wrong but I do not know where to look, because I update through custombuild. Any suggestions?

    Thanks!

  9. #9
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    Hello,

    You should update open_basedir directive in your php.ini, which can be located in

    /usr/local/lib/php.ini
    /usr/local/etc/php5/cgi/php.ini

    to include /usr/local/lib/php/
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  10. #10
    Join Date
    Nov 2004
    Location
    The Netherlands
    Posts
    123
    Hi zEitEr,

    Thanks for the reply.

    I added the line to mij php.ini but I got the same error.

    I looked at another configuration on another server and my open_basedir in the main php.ini was empty...I emptied the open_basedir on the server, with the error, and php was installed. Got a few error messages about some functions in PEAR though.

    Everything is working now.

Similar Threads

  1. PHP 5.4.5 and PHP 5.3.15 released!
    By nmb in forum Required Software Version Updates
    Replies: 0
    Last Post: 07-19-2012, 07:48 PM
  2. PHP 5.4.4 and 5.3.14 released
    By ditto in forum Required Software Version Updates
    Replies: 3
    Last Post: 06-20-2012, 03:28 PM
  3. PHP 5.2.10 Released
    By JackTon in forum Required Software Version Updates
    Replies: 7
    Last Post: 11-10-2009, 02:59 PM
  4. PHP 5.2.2 and PHP 4.4.7 Released!
    By CoolZero in forum Required Software Version Updates
    Replies: 14
    Last Post: 09-29-2007, 06:28 AM
  5. PHP 4.4.0 released
    By markus in forum Required Software Version Updates
    Replies: 30
    Last Post: 08-05-2005, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •