Results 1 to 7 of 7

Thread: rndc: connect failed: 127.0.0.1#953: connection refused

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Sep 2004
    Posts
    338

    rndc: connect failed: 127.0.0.1#953: connection refused

    On a CentOS 6.3 64bit version, clean install.

    Running the command:

    service named restart
    works fine!

    Running the command:

    rndc reload
    is yielding the error:

    rndc: connect failed: 127.0.0.1#953: connection refused
    Is there a fix for that yet?

    Thanks,

    -Sup.

  2. #2
    Join Date
    Aug 2008
    Posts
    4,697
    Do you have a controls clause in your named.conf

    Mine looks like this:

    Code:
    controls {
            inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };
    If not you might want to look for errors in /var/log/messages

    You can see the default named.conf here -> http://directadmin.com/named.conf
    Last edited by scsi; 10-29-2012 at 10:30 AM.

  3. #3
    Join Date
    Sep 2004
    Posts
    338
    Oct 29 20:41:11 server named[17538]: adjusted limit on open files from 65535 to 1048576
    Oct 29 20:41:11 server named[17538]: found 1 CPU, using 1 worker thread
    Oct 29 20:41:11 server named[17538]: using up to 4096 sockets
    Oct 29 20:41:11 server named[17538]: loading configuration from '/etc/named.conf'
    Oct 29 20:41:11 server named[17538]: /etc/named.conf:45: unknown key 'rndckey'
    Oct 29 20:41:11 server named[17538]: /etc/named.conf:76: zone '.': already exists previous definition: /etc/named.conf:47
    Oct 29 20:41:11 server named[17538]: /etc/named.rfc1912.zones:19: zone 'localhost': already exists previous definition: /etc/named.conf:52
    Oct 29 20:41:11 server named[17538]: loading configuration: failure
    Oct 29 20:41:11 server named[17538]: exiting (due to fatal error)


    I tried,. but I get the rndckey error as shown above.

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,023
    Just a guess (not even sure could it be related to your errors in logs or not)... make sure, you've got no Portreserve running on your server. I've got the same issue some time ago, I've spent some hours, before I found portreserve, which blocked rndc from connecting to 953 port.
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  5. #5
    Join Date
    Apr 2011
    Location
    Amsterdam, NL
    Posts
    94
    I had comparable problems and solved it by setting the owners and permissions for rndc.key as follows:
    Code:
    # ls -la rndc.key
    -rw-r-----. 1 root named 77 Jan 31  2012 rndc.key
    #

  6. #6
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    2,844
    I think it's something else... this is the error:
    Code:
     unknown key 'rndckey'
    Check you rndc.key if it indeed states rndckey or if it's rndc-key or rdnc_key or something else.
    The name in named.conf should be exactly the same as mentioned in the rndc.key file.
    Greetings, Richard.

Similar Threads

  1. Replies: 2
    Last Post: 12-13-2012, 10:34 PM
  2. connection refused
    By kurt22 in forum Dovecot
    Replies: 6
    Last Post: 08-11-2010, 09:41 AM
  3. URGENT: Unable to Connect/Connection Refused
    By drmacinyasha in forum General Technical Discussion & Troubleshooting
    Replies: 5
    Last Post: 08-01-2009, 08:16 AM
  4. Connection Refused.
    By RadMan in forum General Technical Discussion & Troubleshooting
    Replies: 2
    Last Post: 01-19-2009, 06:48 AM
  5. Stopping named: rndc: connect failed: connection refused
    By saeed in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 04-05-2004, 07:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •