Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Thread: Custombuild 2.0.0-beta1

  1. #1
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94

    Custombuild 2.0.0-beta1

    i just upgraded in CB 2 beta1 and found that httpd service is not working

    [root@srv1 custombuild]# service httpd start
    Starting httpd: httpd: Syntax error on line 18 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/mod_ruid2.so into server: /usr/lib/apache/mod_ruid2.so: cannot open shared object file: No such file or directory

  2. #2
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    ok i got that this problem come because of licap missing and wheni install libcap and trying to service httpd restart
    [root@srv1 custombuild]# service httpd restart
    Stopping httpd: [FAILED]
    Starting httpd: [Fri Oct 05 01:02:11 2012] [warn] module ruid2_module is already loaded, skipping
    httpd: Syntax error on line 19 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/mod_mpm_prefork.so into server: /usr/lib/apache/mod_mpm_prefork.so: cannot open shared object file: No such file or directory

  3. #3
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    [root@srv1 custombuild]# cat /etc/httpd/conf/extra/httpd-phpmodules.conf
    LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    LoadModule mpm_prefork_module /usr/lib/apache/mod_mpm_prefork.so
    LoadModule php5_module /usr/lib/apache/libphp5.so

    /usr/lib/apache/mod_mpm_prefork.so the file is not on their location
    what i need to do now?

  4. #4
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Did you upgrade apache? If yes you have to upgrade related modules

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  5. #5
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    yes i upgraded the apache also
    what is the related module and how to update them

  6. #6
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    It depend how did install them.

    Related are mod_ruid2 and mod_prefork.

    I still didnt use CB2.0 so i dont know how to install them with that, but, run ./build should ive the list of avaible commands.

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  7. #7
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    ok i updated all module even then one issue come but that will resolve by
    http://www.directadmin.com/forum/sho...t=42938&page=6

  8. #8
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,746
    I think you had custom configure scripts in /usr/local/directadmin/custombuild/custom. This way apache was not installed with all needed modules.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  9. #9
    Join Date
    Dec 2010
    Location
    PL/EU
    Posts
    170
    How to set in CB 2.0 own php.ini per user? For example: all users have default php.ini and few own config.

  10. #10
    The per-user php.ini will be in:
    /usr/local/directadmin/data/users/username/php/php-fpm5X.conf

    where the files would be either php-fpm53.conf or php-fpm54.conf.
    The php.ini options are set something like (for example):
    Code:
    php_admin_value[open_basedir] = /home/admin/:/tmp/:/var/tmp/:/usr/local/php53/lib/:/usr/local/php54/lib/
    We do have functionality already included in the template for custom entires into these files, just like the Custom Httpd Config options.
    There are both CUSTOM1 and CUSTOM2 tokens, at the top, and the bottom, depending on what you need to do.
    However, DA does not yet have code to fill those tokens, so although we do plan on implementing the code, right now, we need to get CB 2.0 released.
    We'll setup the CUSTOM1 and CUSTOM2 tokens later on, once it's all working well.

    John

  11. #11
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    i upgrade CB in 2.0 into my 4 server and in all i got one warning msg during the httpd restart
    Starting httpd: [so:warn] [pid 28337] AH01574: module ruid2_module is already loaded, skipping
    [Mon Sep 10 14:30:44.885231 2012] [core:warn] [pid 28337] AH00117: Ignoring deprecated use of DefaultType in line 111 of /etc/httpd/conf/httpd.conf.

    i try to comment out the line 111 which is "DefaultType text/plain"

    still i get the half warning msg.
    Starting httpd: [so:warn] [pid 28337] AH01574: module ruid2_module is already loaded, skipping

    my first question is "is their any problem in comment out the line which i do "
    how can i remove that warning msg

  12. #12
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    No problem on removing that line.
    Regarding mod_ruid2 probably you was already using mod_ruid2 before pass to CB2.0 so you got a double entrance, try:

    grep -R "mod_ruid2" /etc/httpd/conf/*

    You should receive i suppose 2 line in same file or different file, if yes, remove the line from /etc/httpd/conf/httpd.conf

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  13. #13
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    nothing happen after executing
    grep -R "mod_ruid2" /etc/httpd/conf/*

    also i try
    cat /etc/httpd/conf/httpd.conf | grep mod_ruid2

    still blank result

  14. #14
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    Well grep command take subdirectory aswell and check every file, that's why i did use that.

    Actually is strange that have no result, try using just mod_ruid or ruid between the ""

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  15. #15
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    [root@gps ~]# grep -R "mod_ruid" /etc/httpd/conf/*
    /etc/httpd/conf/extra/httpd-phpmodules.conf:LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    /etc/httpd/conf/httpd.conf:LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    /etc/httpd/conf/httpd.conf.backup:LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    /etc/httpd/conf/httpd.conf.bak:LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so

  16. #16
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    /etc/httpd/conf/httpd.conf.backup
    /etc/httpd/conf/httpd.conf.bak
    /etc/httpd/conf/httpd.conf
    3 files loading the module /usr/lib/apache/mod_ruid2.so
    what i need to remove to remove the error ?

  17. #17
    Join Date
    Oct 2004
    Location
    London, UK
    Posts
    6,641
    No, the backup are not important.

    You got the httpd-phpmodules.conf and httpd.conf

    I honestly dont know where CB2.0 put the include, the standard from previous install usually is in httpd.conf so the one in extra folder should be the one put from CB2.0, so, remove the linea in httpd.conf and restart apache

    Regards
    SeLLeRoNe - Andrea Iannucci
    DevOps Engineer - System Administrator
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  18. #18
    Join Date
    Aug 2012
    Location
    everwhere
    Posts
    94
    ok i checked
    in httpd.conf
    LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so is added and then on next line it include the mod_ruid.so file by httpd-phpmodules.conf
    so i comment out the LoadModule ruid2_module in httpd.conf and all working
    thanx for help

  19. #19
    Join Date
    Nov 2003
    Location
    germany
    Posts
    117
    Update one Server but i get an error.

    Gracefully shutting down php-fpm53: warning, no pid file found - php-fpm53 is not running ?
    Starting php-fpm53: [23-Oct-2012 16:10:09] ERROR: unable to bind listening socket for address '/usr/local/php53/sockets/webapps.sock': No such file or directory (2)

    I use:

    Custombuild2.0.0-beta
    #PHP settings.
    Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, no. php1/php2_mode: cli, cgi (mod_php or FPM)
    php1_release=5.3
    php2_release=5.4
    php1_mode=cgi
    php2_mode=cgi
    php_ini=yes
    #Possible values - production or development
    php_ini_type=production
    ioncube=yes
    zend=yes

    Directadmin
    Compiled on 'Debian 6.0 64-bit'
    Compile time: Oct 23 2012 at 03:15:19
    http://www.linuworx.de

  20. #20
    Join Date
    Nov 2003
    Location
    germany
    Posts
    117
    Any ideas ?
    http://www.linuworx.de

Page 1 of 2 12 LastLast

Similar Threads

  1. CustomBuild 1.1.19 and 1.2.13
    By smtalk in forum CustomBuild
    Replies: 4
    Last Post: 04-06-2010, 09:16 AM
  2. ANNOUNCE: Apache SpamAssassin 3.3.0-beta1 available
    By Meesterlijk in forum Required Software Version Updates
    Replies: 1
    Last Post: 12-20-2009, 05:27 AM
  3. [Dovecot-news] v1.1.beta1 released
    By hehachris in forum Required Software Version Updates
    Replies: 0
    Last Post: 09-23-2007, 07:12 AM
  4. phpMyAdmin 2.9.0-beta1 released & how to
    By @how@ in forum Required Software Version Updates
    Replies: 3
    Last Post: 08-30-2006, 09:24 AM
  5. phpMyAdmin 2.7.0-beta1
    By markus in forum Required Software Version Updates
    Replies: 1
    Last Post: 11-09-2005, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •