Results 1 to 2 of 2

Thread: Requires: libmysqlclient.so.16()(64bit)

  1. #1
    Join Date
    Aug 2005
    Posts
    284

    Requires: libmysqlclient.so.16()(64bit)

    Help, I'm trying to install a perl Mysql library but getting this error:

    [root@web2 yum.repos.d]# yum install perl-DBD-MySQL
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: centos-distro.cavecreek.net
    * extras: centos.icyboards.com
    * updates: mirrors.loosefoot.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
    --> Finished Dependency Resolution
    Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (base)
    Requires: libmysqlclient.so.16()(64bit)
    Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (base)
    Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    This is on Centos 6.3 64-bit.
    How can I get around this issue?

    p.s. what is strange to me is that on my other box i never had this problem and that box i installed it about a month ago.

  2. #2
    Join Date
    Jul 2005
    Posts
    2,008
    Install from cpan or source code instead.

Similar Threads

  1. libmysqlclient.so.15 is needed by package perl-DBD-MySQ
    By Suurbier in forum General Technical Discussion & Troubleshooting
    Replies: 9
    Last Post: 01-10-2012, 11:23 AM
  2. starting ./directadmin - libmysqlclient.so.16 problem
    By arboooz in forum Admin-Level Difficulties
    Replies: 49
    Last Post: 09-22-2011, 10:23 PM
  3. DA 1.39.0 & MySQL 5.5.13 libmysqlclient problem
    By jw00dy in forum General Technical Discussion & Troubleshooting
    Replies: 8
    Last Post: 06-27-2011, 02:50 PM
  4. libmysqlclient.so.10 is needed
    By chow in forum General Technical Discussion & Troubleshooting
    Replies: 6
    Last Post: 10-21-2004, 01:56 PM
  5. Missing libmysqlclient.so
    By ja3 in forum General Technical Discussion & Troubleshooting
    Replies: 0
    Last Post: 09-15-2004, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •