Results 1 to 4 of 4

Thread: successful upgrade to 9.1 release from 7.2

  1. #1
    Join Date
    Apr 2007
    Posts
    12

    successful upgrade to 9.1 release from 7.2

    since there is no 9.x forum, i thought i could post here.

    just wanted to let everyone know that I completed a 7.2 ( modified with ports instead of DA provided apps ) to 9.1 release upgrade successfully, and everything is working fine.

    used freebsd-update for kernel/system

    this is 64bit, and all ports were updated with portmaster.

    bind update was slightly complicated to 9.8.3 as the named config files required manual merging, but it worked out.

    the only thing was exim kept restarting so the whole name for the exim-xxxx.xx had to be put in the service.status file as opposed to just 'exim'

    a lot of the portmasters had to be restarted since dependencies had changed ( and some ports have been completely deleted. but as a result everything was cleaned and rebuild and performance is much better.

    everything took around 2 days worth of effort ( builds, troubleshooting, rebuilding )

  2. #2
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    The important question I can see is How much downtime was there during those two days?

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  3. #3
    Join Date
    Apr 2007
    Posts
    12
    apache was down for maybe 4 hours ( had to recompile all php dependencies twice over )
    mysql was pretty easy and straight forward.
    bind was down about 30 mins.
    This is all in a vm, mind you.

    perl dependencies took some investigation, but there wasn't much downtime as it was mostly p5-* modules individually being affected.

    oh yah, had to remove duplicate startup files from init/rc.d so things wouldn't try to start twice

  4. #4
    Join Date
    May 2008
    Posts
    686
    I started with FreeBSD 7.0 i386 version and since then I always upgrade to the RELEASE version as soon as it is released out there (DirectAdmin also works flawlessly, despite they do not sell licenses for i386 version for newer BSD releases). I use the "freebsd-update" utility. Minor version upgrades (X.Y -> X.Z) are "peace of cake":

    # freebsd-update upgrade -r X.Z-RELEASE
    // fix whatever merge issues are prompted
    # freebsd-update install
    # shutdown -r now
    // Here's the downtime until the server is restarted
    # freebsd-update install
    # shutdown -r now
    // Downtime for restart again (*)

    Major version upgrades (X.Y to Z.0) are a bit more complicated, because there are much more "merge issues", but it's nothing too complicated for anybody. There is however a headache with recompiling all ports after that (which is advised by the manuals despite that everything is working anyway). It takes lots of time (and server resources!) and sometimes few ports may fail to compile, then you figure out why, etc. But there's NO downtime during rebuilds.

    I never experienced downtime of Apache or other server software. When I upgrade - everything just works fine. I do recompile the main software packages of course but the services are not down during that time. Of course I never jumped with upgrade with such huge difference - 7.2 to 9.1 as the person said. I am always upgrading on small steps

    (*) People upgrading to FreeBSD 9.0 or higher - please note that with executing the second "shutdown -r now" your system will "hang". It will close all services (including SSH), but it will not reboot. The system will be pingable but that's all. It will need a "hard reset" - no other way to bring it back. This is a known bug, but it's still not resolved (9.1-RELEASE at the moment). Please consider this if you are upgrading remotely - be prepared to ask a technician from the DC to reboot with physical contact. This will avoid a "downtime by surprise". This bug is confirmed by the community. I experienced it on two different systems.
    Last edited by wattie; 01-27-2013 at 02:30 AM.

Similar Threads

  1. [WORKAROUND] Successful 8.2-RELEASE installation
    By farmer in forum FreeBSD 8.x 64-bit
    Replies: 8
    Last Post: 09-19-2012, 10:12 PM
  2. SSH immediatly logs me out after successful login
    By framon in forum System-Level Technical Discussion
    Replies: 2
    Last Post: 01-16-2011, 12:41 PM
  3. error 404 on port 2222 after a successful installation
    By tincboy in forum Installation / System Requirements
    Replies: 1
    Last Post: 08-14-2009, 04:56 AM
  4. Cannot Start DA after install successful
    By Chickenwing in forum Installation / System Requirements
    Replies: 3
    Last Post: 03-27-2008, 06:46 PM
  5. Successful password change confirmation
    By uogecko in forum Feedback & Feature Requests
    Replies: 0
    Last Post: 03-31-2005, 09:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •