Results 1 to 5 of 5

Thread: subdomain working/notworking/working etc

  1. #1
    Join Date
    May 2013
    Posts
    40

    subdomain working/notworking/working etc

    I have setup a subdomain on raadvanarbeid.nl: nop.raadvanarbeid.nl. Sometimes it's reachable, sometimes not. I want to install forum software (fudforum) in this sub, and even though I am running mod_ruid2 it sometimes(!) asks to change permissions on the folder containing the installer (raadvanarbeid.nl/nop).
    So when I can reach the sub I start the installer. When I reach the part where is says to change permissions I chmod to 777 and voila, the sub domain is no longer reachable. I can set it back to 755 to no avail. Last time I tried, it did not ask me to change permissions and I was able to finish the installation. But after it was finished I got the 'Oops, Google could not find etc' message again. When I ping nop.raadvanarbeid.nl I get "Unknown Host". I can of course still reach the subs folder by going to www.raadvanarbeid.nl/nop, but what's the point if the subdomain itself stops working all the time?
    I have another domain with a subdomain (blog.lastpost.tv) and this one worked from day one. As far as I can tell everything is set up identical. httpd.conf files are the same, DNS servers are the same, A records are the same. Did I miss anything?
    I'm running DA 1.44 on Centos 6.3 btw.

  2. #2
    Join Date
    Apr 2008
    Location
    Belgium
    Posts
    134
    Hi,

    When looking with intodns: http://www.intodns.com/raadvanarbeid.nl
    It shows a different SOA serial for your three nameservers.

    When trying nslookup on those nameservers:
    nslookup nop.raadvanarbeid.nl 83.137.145.229
    nslookup nop.raadvanarbeid.nl 83.137.145.236
    nslookup nop.raadvanarbeid.nl 164.138.29.124

    You will see that only the last one has the information for your subdomain.
    ns1.jungaservers.nl and ns2.jungaservers.nl don't know about your subdomain.

    Depending on what nameserver responds to the request, your website will work (temporarily).

    regards,
    Stijn

  3. #3
    Join Date
    May 2013
    Posts
    40
    Hi Stijn,

    Hartelijk dank. But I'll continue in English. That sounds like a logical explanation. Which leads to the question why the two nameservers of my registrar cannot resolve the sub. I'll remove them from the dns list to solve the problem for now, but I would like to find an answer to the above question...

  4. #4
    Join Date
    Apr 2008
    Location
    Belgium
    Posts
    134
    Hi,

    Not all registrars allow the use of their servers as secondary (slave) server. But they provide nameservers which you can set up through their own admin page.
    If your registrar does allow slave, then you will have to add their nameservers to your named.conf to allow replication of dns data.

    Some registrars also poll your server for changes, while others depend on your server telling them something has changed.

    regards,
    Stijn

  5. #5
    Join Date
    May 2013
    Posts
    40
    I was going to contact my registrar today about something else, I'll take this up with them as well.

    Tnx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •