Results 1 to 4 of 4

Thread: Password for new users is incorrect

  1. #1
    Join Date
    Sep 2004
    Posts
    151

    Password for new users is incorrect

    On our FreeBSD 9.2-RELEASE servers when we create a new user the password is always incorrect. We have to reset the password in order for it to work, both on reseller level when creating a new user, and on admin level when creating a new admin or reseller.

    Setting the password to the exact same string suddenly makes it work. Or right after creating a new user scrolling to the bottom to send a new password does work.

    Logging in via ftp however does work at all times.
    Last edited by Invader Zim; 12-19-2014 at 03:17 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,060
    Hello,

    You probably need to change passwd_format in /etc/login.conf

    https://www.freebsd.org/doc/zh_TW/bo...ook/crypt.html
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

  3. #3
    Join Date
    Sep 2004
    Posts
    151
    I don't think going back from sha512 to md5 is a really good idea. :/ It's weird because when you set the password the 2nd time all works just fine, it's only the first time.

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,060
    DA binaries for FreeBSD 9 do not support sha-512.

    Please check this: http://forum.directadmin.com/showthr...488#post235488 and this http://help.directadmin.com/item.php?id=248
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •