Results 1 to 4 of 4

Thread: PhpMyAdmin

  1. #1
    Join Date
    Jan 2013
    Posts
    6

    PhpMyAdmin

    Hi
    i have face the below error on phpmyadmin

    phpMyAdmin - Error
    Existing configuration file (./config.inc.php) is not readable.

    i tried the below commands but nothing changed

    cd /usr/local/directadmin/custombuild
    ./build update
    ./build clean
    ./build update_versions

    also i change the config file perm to 644

    any idea to resolve the problem?
    custombuild 2.0
    option =>

    #PHP Settings
    #PHP MODES: php-fpm, fastcgi, mod_php, suphp or lsphp
    php1_release=5.3
    php1_mode=mod_php
    php2_release=no
    php2_mode=php-fpm
    opcache=no
    htscanner=no
    php_ini=no
    php_timezone=Asia/Tehran
    php_ini_type=production
    ioncube=yes
    zend=no
    suhosin=no
    x_mail_header=yes
    #php5_cli=no
    #php5_cgi=yes

    #MySQL Settings
    mysql=5.6
    mysql_inst=no
    mysql_backup=yes
    mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups
    mysql_force_compile=no

    #WEB Server Settings
    webserver=apache
    modsecurity=no
    modsecurity_ruleset=comodo
    apache_ver=2.4
    apache_mpm=auto
    mod_ruid2=no
    harden_symlinks_patch=yes
    use_hostname_for_alias=no
    redirect_host=mail.artapardaz.ir
    redirect_host_https=no

    #WEB Applications Settings
    phpmyadmin=yes
    phpmyadmin_ver=4
    squirrelmail=yes
    roundcube=yes
    webapps_inbox_prefix=no

    #ClamAV-related Settings
    clamav=no
    clamav_exim=yes
    proftpd_uploadscan=no
    pureftpd_uploadscan=no
    suhosin_php_uploadscan=no

    #Mail Settings
    exim=no
    eximconf=no
    eximconf_release=2.1
    blockcracking=no
    easy_spam_fighter=no
    spamassassin=no
    dovecot=yes
    dovecot_conf=no
    pigeonhole=no

    #FTP Settings
    ftpd=pureftpd

    #Statistics Settings
    awstats=no
    webalizer=yes

    #CustomBuild Settings
    custombuild=2.0
    autover=no
    bold=yes
    clean=yes
    cleanapache=yes
    clean_old_tarballs=yes
    clean_old_webapps=yes
    downloadserver=files.directadmin.com

    #Cronjob Settings
    cron=no
    cron_frequency=weekly
    email=email@domain.com
    notifications=yes
    da_autoupdate=no
    updates=no
    webapps_updates=yes

    #CloudLinux Settings
    cloudlinux=no
    cagefs=no

    #Advanced Settings
    autoconf=yes
    automake=yes
    libtool=yes
    curl=yes
    new_pcre=no

    default_php=5
    php4_cli=no
    php4_cgi=no
    php5_cli=no
    php5_cgi=yes
    php5_ver=5.2
    secure_htaccess=no
    harden-symlinks-patch=no
    old_apr_util=no
    mail-header-patch=yes
    proftpd=yes
    pureftpd=no
    jail=no
    mailman=no
    new_zlib=no
    new_xml2=no
    new_suphp=no
    atmail=no
    uebimiau=no

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,975
    Your options.conf file seems to be messed up. Are you sure you followed upgrade instructions? I'd recommend applying #2 again: http://forum.directadmin.com/showthread.php?t=44743
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,476
    Hello,

    You are running mod_php without mod_ruid2.

    Try:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build set mod_ruid2 yes
    ./build php n
    ./builf rewrite_confs
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  4. #4
    Join Date
    Jan 2013
    Posts
    6

    solved!

    Hi,
    thanks from you two DA super heros.
    many of my problems solved by reading your posts in forum.
    In first step i enable the mod_ruid2 and problem solved.
    Thank You Again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •