Results 1 to 7 of 7

Thread: DirectAdmin 1.48.2 has been released

  1. #1

    DirectAdmin 1.48.2 has been released

    Hello,

    DirectAdmin 1.48.2 has been released.
    directadmin.com/versions.php?version=1.482

    This is a bugfix release, mainly to address login issues with session expiry and a segfault in the two-step auth feature.

    Bugfixes:


    This release came shortly after the release of 1.48.1, to address the above issues:
    http://forum.directadmin.com/showthread.php?t=51591

    If you are affected by the session expiry issue and cannot login to DA, update it from ssh like this:
    Code:
    cd /usr/local/directadmin
    echo "action=update&value=program" >> data/task.queue; ./dataskq d2000
    and when done, confirm you've got 1.48.2:
    Code:
    ./directadmin v
    John

  2. #2
    Join Date
    Jun 2015
    Posts
    8

    SSL Issue

    Hi,

    Since the 1.48.2 update.
    When you add an SSL Certificate to a user account. And then under the domain name check the box for Secure SSL.
    HTTP Stops and does not start anymore...
    Warning in SSH:

    Stopping httpd: [ OK ]
    Starting httpd: [Fri Jun 26 11:08:37.785220 2015] [core:warn] [pid 2326] AH00117: Ignoring deprecated use of DefaultType in line 61 of /etc/httpd/conf/httpd.conf.

    When i uncheck the SSL again and wait or restart HTTPD it Works again.

    Please release a quick fix for this.

    Thanks

  3. #3
    Join Date
    Sep 2008
    Location
    London UK
    Posts
    1,716
    Apache should run, that is just a warning - I have have same warning and Apache still starts.

    What is the error when SSL is enabled? Maybe you need to rewrite the configuration files.

  4. #4
    Join Date
    Jun 2015
    Posts
    8
    Hi,

    I found out what the problem was...

    DirectAdmin does not store the certificate bundle right.

    When DirectAdmin stores the file the

    -----END CERTIFICATE-----

    Line is not saved in the file:

    /usr/local/directadmin/data/users/<username>/domains/<domain>.nl.cacert

    So that must be a bug in DirectAdmin.
    We contacted DirectAdmin about this, if there is someone of DirectAdmin reading this. Please contact the right person and release an update.

    I had contact with the certificate authority (SSLCertificaten.nl) In The Netherlands, and they got many calls today about this.

    Below the .cacert file with some cuts so you can see what i mean.
    Code:
    -----BEGIN CERTIFICATE-----
    MIIENjCCAx6gAwIBAgIBATANBgkqhkiG9w0BAQUFADBvMQswCQYDVQQGEwJTRTEU
    MBIGA1UEChMLQWRkVHJ1c3QgQUIxJjAkBgNVBAsTHUFkZFRydXN0IEV4dGVybmFs
    <CUT HERE>
    Nr4TDea9Y355e6cJDUCrat2PisP29owaQgVR1EX1n6diIWgVIEM8med8vSTYqZEX
    c4g/VhsxOBi0cQ+azcgOno4uG+GMmIPLHzHxREzGBHNJdmAPx/i9F4BrLunMTA5a
    mnkPIAou1Z5jJh5VkpTYghdae9C8x49OhgQ=
    -----BEGIN CERTIFICATE-----
    MIIFdDCCBFygAwIBAgIQJ2buVutJ846r13Ci/ITeIjANBgkqhkiG9w0BAQwFADBv
    MQswCQYDVQQGEwJTRTEUMBIGA1UEChMLQWRkVHJ1c3QgQUIxJjAkBgNVBAsTHUFk
    <CUT HERE>
    PUsE2JOAWVrgQSQdso8VYFhH2+9uRv0V9dlfmrPb2LjkQLPNlzmuhbsdjrzch5vR
    pu/xO28QOG8=
    -----BEGIN CERTIFICATE-----
    MIIGDjCCA/agAwIBAgIQBqdDgNTr/tQ1taP34Wq92DANBgkqhkiG9w0BAQwFADCB
    hTELMAkGA1UEBhMCR0IxGzAZBgNVBAgTEkdyZWF0ZXIgTWFuY2hlc3RlcjEQMA4G
    <CUT HERE>
    jwLI5jqmBNFI+8NKAnb9L9K8E7bobTQk+p0pisehKxTxlgBzuRPpwLk6R1YCcYAn
    pLwltum95OmYdBbxN4SBB7SC

  5. #5
    Join Date
    Jun 2015
    Posts
    8
    Found out that when i do a cat followed by the file. The lines are not shown.

    But when i do a nano followed by the file the end lines are there.
    But http would not start.

    When i edit the file and manual place all CA Certs in there so all three under each other and save the file. Restart httpd than it works again.
    So there must be something wrong here.

  6. #6
    Join Date
    Jun 2015
    Posts
    8
    An other update.
    Tested it again on an other user... And there is an missing line feed see here: http://d.pr/i/1ApR

  7. #7
    Thanks for the report, bug found/fixed.
    https://www.directadmin.com/features.php?id=1767

    Sorry about that! Fix one bug, create 2 more...
    The binaries are in the pre-release section, and I'll release 1.48.3 tonight.

    If it appears that the "-----END CERTIFICATE-----" is missing, view the file with nano using the -N option (no convert), as windows \r\n (^M) characters tend to mess up the "cat" output, hiding the last lines.
    Basically, it line feeds, then overwrites the -----END CERTIFICATE----- with the -----BEGIN CERTIFICATE----- part.
    So the issue is actually just the missing \n character.

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •