Results 1 to 3 of 3

Thread: Ubuntu 15.04 (Vivid) is missing a dependency

  1. #1
    Join Date
    Oct 2010
    Location
    Denmark
    Posts
    52

    Ubuntu 15.04 (Vivid) is missing a dependency

    Hi guys,

    Planing to install DA on Ubuntu 15.04 (Vivid).
    DA on Debian 8 is set to stable and 15.04 is, quoting John:
    "Else upgrade to Ubuntu 15.04+, as it natively supports systemd, just like Debian 8"


    During the pre instal process I try to install dependencies (http://help.directadmin.com/item.php?id=354) libsystemd-daemon0 is not found. All the others were found and installed.

    Code:
    # apt-get install libsystemd-daemon0
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libsystemd-daemon0
    
    # lsb_release -da
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 15.04
    Release:        15.04
    Codename:       vivid
    
    # cat /etc/debian_version
    jessie/sid
    
    # hostnamectl
       Static hostname: wp-portal-02
             Icon name: computer-vm
               Chassis: vm
            Machine ID: 12202311b7a5c0c22042c3d655f6a6a5
               Boot ID: 490ce16ea3af45668e1a2ac73628acb4
        Virtualization: vmware
      Operating System: Ubuntu 15.04
                Kernel: Linux 3.19.0-15-generic
          Architecture: x86-64
    To the question, is libsystemd-daemon0 needed ?
    Looking at http://packages.ubuntu.com/search?keywords=systemd I found this:

    Package libsystemd-daemon0
    trusty (14.04LTS) (libs): systemd utility library
    204-5ubuntu20: amd64 i386
    trusty-updates (libs): systemd utility library
    204-5ubuntu20.13: amd64 i386
    utopic (libs): systemd utility library
    208-8ubuntu8: amd64 i386
    utopic-updates (libs): systemd utility library
    208-8ubuntu8.2: amd64 i386
    Thanks,
    Thomas

  2. #2
    Join Date
    Dec 2015
    Posts
    1

    I have the same problem

    When I use Ubuntu server 14.04.3, it have error "Unable to locate package libsystemd-dev"

    When I use Ubuntu server 15.10, it have error "Unable to locate package libsystemd-daemon0"


  3. #3
    Join Date
    Nov 2016
    Posts
    1

    It can't installed on Ubuntu

    It can't installed on Ubuntu ?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •