Results 1 to 4 of 4

Thread: PHP7 php_admin_value

  1. #1
    Join Date
    Mar 2015
    Posts
    5

    PHP7 php_admin_value

    Hello,

    I have php values in my httpd.conf:

    php_admin_value post_max_size 512M
    php_admin_value upload_max_filesize 512M
    php_admin_value open_basedir /home/XXX ....

    all works fine in PHP 5.2-.5.6 PHP7 ignore this values even sendmail is empty:

    httpd.conf

    php_admin_value sendmail_path '/usr/sbin/sendmail -t -i -f user@domain.tld -F user@domain.tld'

    php.ini:

    sendmail_path /usr/sbin/sendmail -t -i
    open_basedir not value

    this problem is in apache suphp and litespeed lsphp

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,238
    You cannot use php_admin_value/php_admin_flag with PHP compiled as CGI (suPHP), because these options are only supported when PHP is compiled as a module of Apache. Feel free to use php.ini sections to change the settings (http://php.net/manual/en/ini.sections.php). Otherwise - just switch to mod_ruid2+mod_php and you'll be able to use php_admin_value in Apache configuration files.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Mar 2015
    Posts
    5
    I'm using litespeed and php_admin_vaule doesn't work...
    Maybe you have any sugestions about this?
    PHP 5.5, 5.6 works fine i have problem only with 7.
    Last edited by fisher006; 12-15-2015 at 12:38 AM.

  4. #4
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,238
    I'd recommend contacting LiteSpeed support about that: https://store.litespeedtech.com/store/clientarea.php.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •