Page 1 of 12 12311 ... LastLast
Results 1 to 20 of 236

Thread: DirectAdmin 1.50.0 has been released

  1. #1

    DirectAdmin 1.50.0 has been released

    Hello,

    We're pleased to announce the release of DirectAdmin 1.50.0

    Version: 1.50.0

    This is a major release with numerous new features and fixes.
    The full list can be Found Here

    New Features


    plus many more.

    Bugfixes

    Plus various other fixes.

    Have fun!

    John

  2. #2
    Join Date
    Nov 2013
    Location
    Belgium
    Posts
    58
    Quote Originally Posted by DirectAdmin Support View Post
    Hello,

    We're pleased to announce the release of DirectAdmin 1.50.0

    Version: 1.50.0

    New Features

    • LetsEncrypt automatic 1-click install of FREE SSL certificates.

    Plus various other fixes.

    Have fun!

    John
    This is just great! Now I'm just wondering (if possible) how to added subdomains to the cert. Can we just comma seperate them? Don't want to test it too much due too the rate limit.

  3. #3
    Join Date
    Dec 2012
    Posts
    76
    Thx for the update.
    I've enabled lets encrypt but on 'user level' the SSL Certificates pages says that i need an owned IP before i can proceed
    'You can only add a certificate if you own the ip you are using'
    Followed the help link http://help.directadmin.com/item.php?id=261 but i only have one IP so the link to that was http://www.directadmin.com/technotes.html#ssl but the mentioned lines are already in my virtual hostconfig (http-vhosts.conf).
    Any idea how to fix?

  4. #4
    SSL rules haven't changed, but you can enable SNI if your OS supports it (most new ones do)
    http://www.directadmin.com/features.php?id=1100

    John

  5. #5
    Join Date
    Feb 2013
    Posts
    7
    I have enabled the SSL functie (Lets Encrypt), but there is no checkbox on the page with 'Free & automatic certificate from Let's Encrypt'.
    In Users\ssl.htm is no text shown.

    -----------

    |*if LETSENCRYPT="1"|
    <br><input type=radio name=request value="letsencrypt" disabled>Free & automatic certificate from <a class='listtitle' target=_blank href="https://letsencrypt.org/">Let's Encrypt</a></td>
    |*endif|

  6. #6
    Join Date
    Jun 2008
    Posts
    156
    updated and did this as you recommended
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build rewrite_confs

    still got this issue
    Challenge is invalid. Details: Invalid response
    john sent you email about the issue
    Last edited by Frej; 02-21-2016 at 03:03 AM.

  7. #7
    Join Date
    Dec 2014
    Posts
    12
    I had to set letsencrypt=2, with 1 it would not work.

    Is it possible to request a SSL certificate for my subdomains?

  8. #8
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,146
    Works fine for me with letsencrypt=1

    Code:
    # grep well /etc/httpd/conf/extra/httpd-alias.conf
    Alias /.well-known /var/www/html/.well-known
    ACTION REQUIRED
    You must have the .well-known Alias pointing to /var/www/html/.well-known, so update your CustomBuild configs:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build rewrite_confs
    http://www.directadmin.com/features.php?id=1828


    Is it possible to request a SSL certificate for my subdomains?
    Add you subdomain as a domain with its own public_html.
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  9. #9
    Join Date
    Jun 2008
    Posts
    156
    im on nginx so it still fails to create certificate

  10. #10
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,146
    With letsencrypt=1?
    Do you have
    /var/www/html/.well-known ?
    The Alias in nginx configs?
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  11. #11
    Join Date
    Jun 2008
    Posts
    156
    nah with =2
    and ive made sure to restart DA- i want my ssl to be on /home/admin/username/public_html

  12. #12
    Join Date
    Dec 2014
    Posts
    12
    Quote Originally Posted by zEitEr View Post
    Add you subdomain as a domain with its own public_html.
    Is there no other way? It would be a lot easier if DirectAdmin would request a SSL certificate for the subdomains as well. The third-party plugin for Let's Encrypt support in DirectAdmin was able to do this.

  13. #13
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,146
    Directadmin does not allow to install separate SSL certs for subdomains.

    Whether you use

    letsencrypt=1 with /var/www/html/.well-known
    or letsencrypt=2 with /home/user/domains/domain.com/public_html/.well-known

    it regulates only where a file will be set which is used once for domain ownership validation. All the certs are stored as always in /usr/local/directadmin/data/users/<user>/domains/
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  14. #14
    Join Date
    Jun 2008
    Posts
    156
    yes i know and thats the issue it doesnt create certificate at all there
    the folders are there

    Getting challenge from acme-server...
    Waiting for domain verification...
    Challenge is invalid. Details: Invalid response from http://domain/.well-known/acme-chall...OAfzO7TOZ4o3to [ip]: 404. Exiting...


    Quote Originally Posted by zEitEr View Post
    Directadmin does not allow to install separate SSL certs for subdomains.

    Whether you use

    letsencrypt=1 with /var/www/html/.well-known
    or letsencrypt=2 with /home/user/domains/domain.com/public_html/.well-known

    it regulates only where a file will be set which is used once for domain ownership validation. All the certs are stored as always in /usr/local/directadmin/data/users/<user>/domains/
    Last edited by Frej; 03-07-2016 at 05:22 PM.

  15. #15
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,146
    What error do you get?

    Currently I see an error on one server of the following kind:

    Code:
    Command::doCommand(/CMD_SSL)Domain domain.com  defaultdomain=yes usertype=2 multiple_ips=0 enable_ssl_sni=1
    Dynamic(api=0, error=1):
            text='Cannot Execute Your Request'
            result='Getting challenge for domain.com from acme-server...<br>
    Waiting for domain verification...<br>
    Challenge is invalid. Details: Could not connect to http://domain.com/.well-known/acme-challenge/R4eaNjBi9gwB6Tio-Ui3qtvi4HIStPU46gvsX8RFHKI. Exiting...
    at the same too 200 code in logs:

    Code:
    66.133.109.36 - - [21/Feb/2016:18:50:36 +0600] "GET /.well-known/acme-challenge/R4eaNjBi9gwB6Tio-Ui3qtvi4HIStPU46gvsX8RFHKI HTTP/1.1" 200 108 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    What might it be caused by?
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  16. #16
    Join Date
    May 2008
    Posts
    823
    letsencrypt fails with me with:

    Getting challenge for cphpvb.net from acme-server...
    [: : bad number
    [: : bad number
    /usr/local/directadmin/scripts/letsencrypt.sh: cannot create /var/www/html/.well-known/acme-challenge/: Is a directory
    [: -ne: unexpected operator
    Waiting for domain verification...
    rm: /var/www/html/.well-known/acme-challenge/: is a directory
    Challenge is . Details: . Exiting...
    p.s. both =1 and =2 options

  17. #17
    Join Date
    Jun 2008
    Posts
    156
    wheres the log u found it from

  18. #18
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,146
    The first ouput is directadmin's... debug mode. The same text you can see in browser.

    The second output that's Domain's apache/nginx logs from one of my servers.

    Tested with two domains on nginx+apache server.

    p.s. Other server is fine.
    Last edited by zEitEr; 02-21-2016 at 05:16 AM.
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  19. #19
    Join Date
    Jun 2008
    Posts
    156
    heres the result http://pastebin.com/xCYS4KqL
    Last edited by Frej; 02-21-2016 at 07:09 AM.

  20. #20
    Join Date
    Dec 2014
    Posts
    12
    Quote Originally Posted by zEitEr View Post
    Directadmin does not allow to install separate SSL certs for subdomains.
    AFAIK Let's Encrypt allows you to request a SSL certificate for your main domain and subdomains. So it should be possible.

Page 1 of 12 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •