Results 1 to 9 of 9

Thread: [bug] disable_ipv6=true is ignored when added into /etc/exim.variables.conf.custom

  1. #1
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,395

    [bug] disable_ipv6=true is ignored when added into /etc/exim.variables.conf.custom

    Hello,

    disable_ipv6=true is ignored when added into /etc/exim.variables.conf.custom

    Code:
    # cat exim.variables.conf.custom
    disable_ipv6=true
    the only way to make it to work is to add a whitespace after "=":

    Code:
    # cat /etc/exim.variables.conf.custom
    disable_ipv6= true
    Kindly check and fix if it's a bug.

  2. #2
    Thanks for the report. I believe I've found/fixed the bug.

    Was because CB does a check for ipv6=0|1 in the directadmin.conf, and does a perl regex accordingly.
    The value set would have been there, but only briefly, before the regex changed it.

    I've altered CB2 to only regex on the exim.variables.conf.default, allowing you to add an override.

    John

  3. #3
    Join Date
    Sep 2008
    Location
    London UK
    Posts
    1,647
    I actually found this issue myself, because I send 'message system' messages to a gmail address, they were sent to spam..... Realised exim was listening on ipv6 even though I added false to custom.... then I manually added it to the actual .conf file.

    No doubt the reason we disable ipv6 is this?
    Regards, Peter
    UK Web Hosting - Professional & Reliable Shared and VPS Hosting! Offering DirectAdmin licences on our VPS's

  4. #4
    Join Date
    Sep 2009
    Posts
    220
    That explains why I had problems with it in Exim. Might give it another try then.

  5. #5
    Join Date
    Sep 2016
    Posts
    2

    ipv6 not disabled

    I have added disable_ipv6=true to /etc/exim.variables.conf.custom . I also changed ipv6 to 0 in directadmin.conf . THis does not make exim ignore the ipv6 mechanism. It was after updating exim.conf to 4.5.0 that I could no longer add disable_ipv6=true to exim.conf as that would stop exim from (re)starting .

    So I'm still stuck with ipv6 being active on exim. If adding the appropriate changes to exim.conf and directadmin.conf does not work, and disable_ipv6=true no longer works in exim.conf , how can I then disable ipv6 on exim ?

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,395
    Hello Erik,

    after you changed directadmin.conf by setting ipv6=0 you should run:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build eximconf
    to get exim.conf updated in conjunction with the changes. And make sure that the commands do not produce errors.

  7. #7
    Join Date
    Feb 2006
    Posts
    231
    Just tried to disable IPv6 in Exim but the bug seems to be still there. Only way to make disable_ipv6=true work is to change it in exim.variables.conf. Putting the line in exim.variables.conf.custom (with or without space) is ignored by DA/Exim.

  8. #8
    Join Date
    Sep 2008
    Location
    London UK
    Posts
    1,647
    Quote Originally Posted by Remco00 View Post
    Just tried to disable IPv6 in Exim but the bug seems to be still there. Only way to make disable_ipv6=true work is to change it in exim.variables.conf. Putting the line in exim.variables.conf.custom (with or without space) is ignored by DA/Exim.
    You have to ./build exim_conf after editing the custom file

  9. #9
    Join Date
    Feb 2006
    Posts
    231
    Thanks Peter, must have overlooked that. Besides doing a ./build exim_conf I also had to put in a 'hard return' after the line disable_ipv6=true in file exim.variables.conf.custom. Works ok now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •