Page 1 of 2 12 LastLast
Results 1 to 20 of 35

Thread: DirectAdmin 1.51.0 has been released

  1. #1

    DirectAdmin 1.51.0 has been released

    Hello!

    We're very pleased to announce the release of DirectAdmin 1.51.0 (*finally*)

    This contains numerous new features and bug fixes.
    There are also some important security fixes.

    Many of the changes are in preparation for the new skin, but if you're a skin designer yourself, you're more than welcome to use them in your skin (ajax, search, etc..)

    The full list of changes are here:
    https://www.directadmin.com/versions...rsion=1.510000

    As for new features, the list is rather huge, so won't list them all:
    - dovecot_sni (exim_sni in there, but not quite done yet)
    - suspend templates folder
    - filemanager supports multiple file[] uploads (can ctrl-click select many files at once, for new skin, enhanced not changed)

    New features for the new skin (but any skin can use them)
    - skins.conf for per-skin settings (helps DA to control hardcoded things like tables)
    - ability to search for commands, users, domain, databases, emails, all in the search bar, and it isn't a pig!
    - filemanger recursive search.
    - json out for filemanager, tickets, and a few other areas.

    Security fixes:
    - changes to how we check the referer with logins and certain conditions for logout.
    - Awstats will now run as the User. Note this will count against the User's disk usage, so their usage will go up.

    ----

    Stay tuned, as we'll have good news about the new skin very shortly

    John

  2. #2
    Join Date
    Feb 2017
    Posts
    2

    Cool patch bug in 1.50.1 ?

    Hi
    I closed my report bugs of the previous version?
    bug insert in iedb.ir site.
    my email : iedb.team@gmail.com

  3. #3
    Join Date
    Oct 2004
    Location
    A Coruña, Spain
    Posts
    6,781
    Great work! Hope exim will come soon

    I would also like to suggest two things:
    1 - Ability to select "Request SSL Certificate for this domain" on user creation (that will act after 24h during the night tally requesting the SSL Cert with the standard requirements for the domain, if the domain still doesn't have an SSL Cert)
    2 - Ability to Request the SSL Certificate (with standard settings) for a domain without need to log as the user (using the email associated to the account on user creation as email for the SSL Cert).

    I guess those would be very useful

    Thanks
    SeLLeRoNe - Andrea Iannucci
    Head of Managed Service - Senior DevOps Engineer
    If you need my support write me an E-Mail to Support@CrazyNetwork.it

  4. #4
    Join Date
    Jul 2006
    Posts
    91
    John,

    I went over all of the changes. A quick suggestion especially given the number of updates in this release and for future releases.

    1) Please include a list of all new options that are in directadmin.conf and the API pointing to the Errata Page for each.
    2) Please include a list of Errata that requires manual changes.

    Is the awstats change automatically done at upgrade? If the upgrade fails what is the process to do over?

    Thanks,

    Kevin

  5. #5
    Join Date
    Feb 2017
    Posts
    6
    Hi,

    It would be nice to actually give a little credit on security bugs by a simple "discovered by", but what is more important, that after reading https://www.directadmin.com/features.php?id=1921 users might not realize, that it is a critical vulnerability that gives user a root privilege. I have also found a vulnerability in CloudLinux (waiting for them to fix it) that allows users to escape from CageFS, which combined with an exploit that I have sent You gives root even to users in CloudLinux's CageFS. People should know that they have to update ASAP. I know companies that usually do not update DA unless a security vulnerability was found and there is nothing in description saying that this is critical.

    Best regards,

    Bartosz Kwitniewski

  6. #6
    * CustomBuild and DA to add linked IPs to httpd-vhosts.conf and nginx-vhosts.conf

    My serevr uses nginx_apache, and after update DA, my /etc/httpd/conf/extra/httpd-vhosts.conf end up with:
    <VirtualHost IPv4:8080 LAN_IP:8080 [IPv6]:|PORT_80|>
    Which cause error for httpd. I edited it like below and it works:
    <VirtualHost IPv4:8080 LAN_IP:8080 [IPv6]:8080>
    100% Cloud SSD Hosting starting from $1.12

    Now accept Bitcoin payment!

    https://hostingkernel.com

  7. #7
    Join Date
    Apr 2008
    Location
    Belgium
    Posts
    143
    Hi,
    Just tried the nginx reverse proxy and I've got the same error.
    The second |LINKEDIP| has a |PORT_80| var instead of the real port.

    But, I also had another issue in /etc/nginx/nginx-vhosts.conf
    My LAN IP was included twice in this conf file.

    Code:
    server {
            listen       78.46.195.31:80;
            listen          172.31.1.100:80;
            listen       127.0.0.1:80;
            listen       [::1]:80;
            listen  172.31.1.100:80;
            listen  [2a01:4f8:c17:342:0:0:0:1]:80;
    ...
    With only apache as the web server the ports are replaced like they should.

    regards,
    Stijn
    Last edited by Kiekeboe100; 02-10-2017 at 12:51 PM.

  8. #8
    Join Date
    Apr 2009
    Posts
    2,247
    I have not upgraded yet, but just wanted to post a link to another user posible bug in the new version: "Afterupgrade DA to latest version "Full Usage Log" not showing anymore" http://forum.directadmin.com/showthread.php?t=54400 - does anyone else have that problem?

  9. #9
    Join Date
    May 2008
    Posts
    817
    Quote Originally Posted by ditto View Post
    I have not upgraded yet, but just wanted to post a link to another user posible bug in the new version: "Afterupgrade DA to latest version "Full Usage Log" not showing anymore" http://forum.directadmin.com/showthread.php?t=54400 - does anyone else have that problem?
    I deleted my older post. It was wrong. Full Usage Log does not work (FreeBSD 11).

  10. #10
    Join Date
    Apr 2009
    Posts
    2,247
    Quote Originally Posted by wattie View Post
    I deleted my older post. It was wrong. Full Usage Log does not work (FreeBSD 11).
    It is fixed in the new version: http://forum.directadmin.com/showthr...807#post278807

  11. #11
    Join Date
    May 2008
    Posts
    817
    Quote Originally Posted by ditto View Post
    Yep. Confirmed.

  12. #12
    I've sorted out the |PORT_80| / |PORT_443| issue in CustomBuild, rev 1645. Issue was the perl regex needed /g so multiple matches are all swapped.

    John

  13. #13
    Join Date
    Feb 2017
    Posts
    3
    Wow, this release I like)

  14. #14
    But, I also had another issue in /etc/nginx/nginx-vhosts.conf
    My LAN IP was included twice in this conf file.
    Same problem here.
    100% Cloud SSD Hosting starting from $1.12

    Now accept Bitcoin payment!

    https://hostingkernel.com

  15. #15
    Thanks for the report. I've added a check for the nginx-vhosts.conf rewrite for the LINKEDIPS to exclude the lan_ip, if it's one of the linked values.
    If you have time, please grab the pre-release binaries and let me know if that fixes it.

    I'll likely be pushing 1.51.2 shortly anyway, so this should be resolved quickly if we can confirm the above is working

    John

  16. #16
    Quote Originally Posted by DirectAdmin Support View Post
    Thanks for the report. I've added a check for the nginx-vhosts.conf rewrite for the LINKEDIPS to exclude the lan_ip, if it's one of the linked values.
    If you have time, please grab the pre-release binaries and let me know if that fixes it.

    I'll likely be pushing 1.51.2 shortly anyway, so this should be resolved quickly if we can confirm the above is working

    John
    It works fine now, thank you.
    100% Cloud SSD Hosting starting from $1.12

    Now accept Bitcoin payment!

    https://hostingkernel.com

  17. #17
    Join Date
    Jun 2015
    Posts
    9

    filemanager_pre.sh: missing envrionemt variables on CentOS 6

    Hi,

    It seems filemanager_pre.sh offers different environment variables for CentOS 6 and 7.
    for examples as far as I've checked ip is only available on CentOS 7 installations.

    Should I change some configuration settings in directadmin.conf to sort this out or this is a bug in DirectAdmin version released for CentOS 6?

    Thanks

  18. #18
    Join Date
    Feb 2005
    Posts
    235
    Hello,

    Since the last update, awstats isn't updating anymore on our cloudlinux servers. It's updating correctly on our centos servers though.

    Any idea how to fix this?

    Thanks

  19. #19
    Join Date
    Apr 2005
    Location
    Netherlands
    Posts
    32
    Quote Originally Posted by ViAdCk View Post
    Hello,

    Since the last update, awstats isn't updating anymore on our cloudlinux servers. It's updating correctly on our centos servers though.

    Any idea how to fix this?

    Thanks
    Do you use a /var/log partition? If yes, the new way of updating awstats as the user creates hardlinks in /var/user_logs to /var/log/httpd/domains and harlinks can only be used on the same partition. You can solve it by setting awstats=2 in /usr/local/directadmin/conf/directadmin.conf and run /usr/local/directadmin/scripts/awstats_process.sh <user> <domain> to test it.

    I don't like this solution to be honest and I asked DirectAdmin support to change /var/user_logs to /var/log/user_logs. This would solve this problem for everyone who's using a seperate /var/log partition and I can't think of any downside of changing this.

  20. #20
    Join Date
    Feb 2005
    Posts
    235
    Quote Originally Posted by hansmiddelhoek View Post
    Do you use a /var/log partition? If yes, the new way of updating awstats as the user creates hardlinks in /var/user_logs to /var/log/httpd/domains and harlinks can only be used on the same partition. You can solve it by setting awstats=2 in /usr/local/directadmin/conf/directadmin.conf and run /usr/local/directadmin/scripts/awstats_process.sh <user> <domain> to test it.

    I don't like this solution to be honest and I asked DirectAdmin support to change /var/user_logs to /var/log/user_logs. This would solve this problem for everyone who's using a seperate /var/log partition and I can't think of any downside of changing this.

    No, we don't have a separate partition. Everything is on the main / partition.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •