Results 1 to 7 of 7

Thread: ProFTPd 1.3.6 public_html symbolic link no longer valid

  1. #1
    Join Date
    Jun 2009
    Posts
    35

    Question ProFTPd 1.3.6 public_html symbolic link no longer valid

    Today, I updated to ProFTPd 1.3.6 using DA custombuild.
    Now when I try to connect via ftp the symbolic links are no longer recognized (they are shown as files and nothing can be done with them). This problem is equal to the problem described in http://forum.directadmin.com/showthread.php?t=42402 and https://forum.directadmin.com/showthread.php?t=49714

    I have tried all the proposed solutions, but none are working for me. Anyone else having this problem or any additional suggestions in order to have this issue fixed?

    Thank you in advance!

    Update: I found out that this problem happens when using public_html/ as external folder (in this case public_html is a symlink), when using a subfolder of the symlink for example public_html/a_folder then suddenly all is working fine for some reason...
    Last edited by nostech; 06-22-2017 at 08:02 AM. Reason: Aditional testing

  2. #2
    Join Date
    Mar 2007
    Posts
    76
    Any updates about this?

  3. #3
    Join Date
    Mar 2007
    Posts
    76
    I have downgraded to 1.3.5e.
    It contains the same CVE fix, and symlinks are working.

  4. #4
    Join Date
    Jun 2009
    Posts
    35
    That was my idea as well (since there were no actual replies on this thread) and since I noticed that (CVE fix) too on the ProFTPd website.

    Only may I ask, how you were able to tell custombuild to use version 1.3.5e instead of 1.3.6?

  5. #5
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,287
    To downgrade ProFTPd to 1.3.5 run this:

    Code:
    cd /usr/local/directadmin/custombuild
    echo "proftpd:1.3.5:" >> custom_versions.txt
    ./build update
    ./build clean
    ./build proftpd
    With regards, Alex.

    Professional Server Management for web hosting companies and individuals
    Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription
    Directadmin installation and optimization

    Click here if you need a Linux Admin

  6. #6
    Join Date
    Jun 2009
    Posts
    35
    Thanks zEitEr!

    Also for people on CB 1.1/1.2:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build set autover no
    vi versions.txt
    replace
    Code:
    proftpd:1.3.6:13270911c42aac842435f18205546a1b
    with
    Code:
    proftpd:1.3.5:
    Next
    Code:
    ./build update_data
    ./build proftpd

  7. #7
    Join Date
    Mar 2007
    Posts
    76
    Pay attention! These are different versions.
    You need to install proftpd 1.3.5e!

    It should be:
    Code:
    proftpd:1.3.5e:0df72d7bb47e1918c3bfced5cc852e71
    Also this version is nowhere to be found on the directadmin mirrors,
    you need to download it manually from the proftpd ftp server in the custombuild directory.
    Code:
    wget "ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.5e.tar.gz"
    Then compile with
    Code:
    ./build proftpd

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •