Results 1 to 5 of 5

Thread: Enable "Use a symbolic link from private_html to public_html..." => Permission denied

  1. #1
    Join Date
    Nov 2017
    Posts
    6

    Unhappy Enable "Use a symbolic link from private_html to public_html..." => Permission denied

    Hello,
    I chose "Use a symbolic link from private_html to public_html - allows for same data in http and https".
    I click Save then I have the following error.
    Code:
    Error creating symlink
    
    Details
    
    Permission denied
    I found that there is no private_html folder on the same folder with public_html folder.
    What should I do to fix?

  2. #2
    Join Date
    Nov 2017
    Posts
    6

    Smile

    I managed to fix the issue: I used the default 'admin' account to set up.
    So I made a new package, new reseller account, new user account, then I configure Let's Encrypt again. This time, everything is working as expected.
    But then I got '403 Forbidden'. So I changed owner of public_html to user account which were created before, everything is working Ok so far.

  3. #3
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,120
    Seems like you did not fix it but found a workaround.
    This should not happen, not even in the user level section of your admin account.
    Looks like something is wrong on a more global scale, you might want to try this to fix it globally:
    Code:
    cd /usr/local/directadmin/scripts
    ./set_permissions.sh user_homes
    Greetings, Richard.

  4. #4
    Join Date
    Nov 2017
    Posts
    6

    Question

    Quote Originally Posted by Richard G View Post
    Seems like you did not fix it but found a workaround.
    This should not happen, not even in the user level section of your admin account.
    Looks like something is wrong on a more global scale, you might want to try this to fix it globally:
    Code:
    cd /usr/local/directadmin/scripts
    ./set_permissions.sh user_homes
    Hello Richard,
    Thanks for your reply.
    Here is the result:
    Code:
    user_homes
    set /home root:root 711 flag
    set_user_home admin
    set /home/admin admin:admin 711 flag
    set /home/admin/.shadow admin:mail 640 flag
    set /home/admin/domains admin:admin 711 flag
    set /home/admin/domains/* admin:admin 711 flag
    set /home/admin/domains/default admin:admin 755 flag
    set /home/admin/domains/sharedip admin:admin 755 flag
    set /home/admin/domains/suspended admin:admin 755 flag
    set /home/admin/backups/* admin:admin 600 flag
    chown: cannot access `/home/admin/backups/*': No such file or directory
    chmod: cannot access `/home/admin/backups/*': No such file or directory
    set /home/admin/user_backups admin:admin 711 flag
    set /home/admin/user_backups/* admin:admin 755 flag
    chown: cannot access `/home/admin/user_backups/*': No such file or directory
    chmod: cannot access `/home/admin/user_backups/*': No such file or directory
    set /home/admin/imap admin:mail 770 flag -R
    set_user_home btico
    set /home/btico btico:btico 711 flag
    set /home/btico/.shadow btico:mail 640 flag
    set /home/btico/domains btico:btico 711 flag
    set /home/btico/domains/* btico:btico 711 flag
    set /home/btico/backups/* btico:btico 600 flag
    chown: cannot access `/home/btico/backups/*': No such file or directory
    chmod: cannot access `/home/btico/backups/*': No such file or directory
    set /home/btico/user_backups/* btico:btico 755 flag
    chown: cannot access `/home/btico/user_backups/*': No such file or directory
    chmod: cannot access `/home/btico/user_backups/*': No such file or directory
    set /home/btico/imap btico:mail 770 flag -R
    Is it an expected result?

  5. #5
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,120
    The result looks fine to me.
    The "No such file or directory" for "backups" and "user_backups" directory's should be fine. They will be created automatically as soon as the first backup by the user (or in case of user_backups by the admin or reseller) is made.
    So that's nothing to worry about.
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •