Results 1 to 7 of 7

Thread: Option All not allowed here

  1. #1
    Join Date
    Jun 2016
    Posts
    34

    Option All not allowed here

    I have problems with a Magento 2 installation. After a new install or an update the images, javascript etc. does not get loaded because of the .htaccess files in certain directories. In the error log is:

    {path}.htaccess: Option All not allowed here, referer: https://domain.com/

    I did a lot of searching and tried some custom httpd options such as:

    CUSTOM3
    AllowOverride All
    Allow from All

    But none off all seems to work. Can anyone help?

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,018
    It should be

    Code:
    Options All

  3. #3
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,292
    Wasn't this an Nginx issue with the symbolic links protection?
    I know this is from Plesk, but Cpanel has the same and maybe DA too?
    https://support.plesk.com/hc/en-us/a...t-allowed-here
    Greetings, Richard.

  4. #4
    Join Date
    Jun 2016
    Posts
    34
    Hi Alex, Also tried that in the custom 3 field. But it gets added to the config before the original one, so I guess it does not work. These are the first 3 lines of the <Directory>. The first line is the addition from custom 3:

    <Directory /home/theuser/domains/thedomain/public_html>
    Options All
    AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,Includes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,FollowSymLinks,None
    Options -ExecCGI
    php_admin_flag engine ON


    It should override the existing right?

  5. #5
    Join Date
    Jun 2016
    Posts
    34
    Quote Originally Posted by Richard G View Post
    Wasn't this an Nginx issue with the symbolic links protection?
    I know this is from Plesk, but Cpanel has the same and maybe DA too?
    https://support.plesk.com/hc/en-us/a...t-allowed-here
    I think that is the same problem. The only thing is that I think DirectAdmin does not have this setting like Plesk does.

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,018
    Try and re-define the variable:

    Code:
    |?ALLOW_OVERRIDE=AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,Includes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,FollowSymLinks,None|
    in CUSTOM3 section:

    Code:
    |?ALLOW_OVERRIDE=AllowOverride All|
    Please note I wouldn't do it for my own and my customers as it might bring issues with a security. And I don't understand why do you need
    Code:
    Options All
    ?

  7. #7
    Join Date
    Jun 2016
    Posts
    34
    It's because Magento 2 defaults this in their .htaccess files. You can change the htaccess files but every time you run an update the defaults are rewritten.
    The first line in the specific .htaccess is

    Options All -Indexes

    On line 23 is: Options +FollowSymLinks if I change this to Options +SymLinksifOwnerMatch the problem is also gone. But again, after Magento update this is overwritten.

    Maybe there is another option to get this working? Without any real security issues like you say?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •