Results 1 to 5 of 5

Thread: Anyone got PHP 7.1 working with ioncube/zend?

  1. #1
    Join Date
    Feb 2018
    Posts
    5

    Post Anyone got PHP 7.1 working with ioncube/zend?

    A new server running centos7 and php 7.1/7.2 compiled with zend and ioncube, showing up in php -v and php -i, but ioncube still not working. Any idea's?

  2. #2
    Join Date
    Feb 2018
    Posts
    5
    Output:

    [root@pasta ~]# php -v
    PHP 7.1.14 (cli) (built: Feb 11 2018 18:35:01) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.1.1, Copyright (c) 2002-2017, by ionCube Ltd.
    [root@pasta ~]# php -i |grep ioncube
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.1.1, Copyright (c) 2002-2017, by ionCube Ltd.
    Error log:

    Code:
    [Mon Feb 12 20:35:17.908207 2018] [php7:error] [pid 32386] [client 178.18.31.20:49260] PHP Fatal error:  The file /home/AAAAAAA/domains/AAAAAAA.com/public_html/access/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

  3. #3
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    11,680
    Hello,


    See the error:


    The file /home/AAAAAAA/domains/AAAAAAA.com/public_html/access/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

  4. #4
    Join Date
    Feb 2018
    Posts
    5
    Quote Originally Posted by zEitEr View Post
    Hello,


    See the error:


    The file /home/AAAAAAA/domains/AAAAAAA.com/public_html/access/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

    It is whmcs:

    https://docs.whmcs.com/System_Requirements

    And should work with PHP 5.6 and PHP7. They are not providing an alternative version for me to test.

  5. #5
    Join Date
    Feb 2018
    Posts
    5
    Damn, just noticed, it works with PHP7.0.X only, not 7.1 or 7.2!!

    Sorry and thanks anyway!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •