Results 1 to 7 of 7

Thread: apache reloaded every night at with dataskq

  1. #1
    Join Date
    Oct 2016
    Posts
    7

    Exclamation apache reloaded every night at with dataskq

    i have a new problem with directadmin in the last night apahce service stoped , i checked system log and find below log :
    Code:
    cat /var/log/directadmin/system.log | grep "2018:02:19-00:13"
    2018:02:19-00:13:06: nginx reloaded
    i checked cron logs and see in this time just run datasq cron running :
    Code:
    cat /var/log/cron | grep "Feb 19 00:13:0"
    Feb 19 00:13:01 bnmd CROND[35175]: (root) CMD (/usr/local/directadmin/dataskq)
    after watched historical log i find directadmin do this every night but i dont need this task and won't restart my webservice every night .
    how can i disable it permanently ?

  2. #2
    Join Date
    May 2014
    Posts
    77
    That's the standard in connection with the nightly tally. Please check https://help.directadmin.com/item.php?id=410

  3. #3
    Join Date
    Oct 2016
    Posts
    7
    Quote Originally Posted by dave097 View Post
    That's the standard in connection with the nightly tally. Please check https://help.directadmin.com/item.php?id=410
    thanks reply
    with your help i find https://www.directadmin.com/features.php?id=1020 and this feature fully help me but i set webserver to nginx_apache can i use this feature for this or should change it command to restart_nginx_apache_after_tally=0 ?

  4. #4
    Join Date
    May 2014
    Posts
    77
    Quote Originally Posted by momohammadi View Post
    thanks reply
    with your help i find https://www.directadmin.com/features.php?id=1020 and this feature fully help me but i set webserver to nginx_apache can i use this feature for this or should change it command to restart_nginx_apache_after_tally=0 ?
    There is no restart_nginx_apache_after_tally, only restart_apache_after_tally is available. I do not dare to say whether this option works for NGINX and Apache. Maybe you can test it?

    Why do you want to turn it off? do you have problems when doing a restart? We have also turned it on and we have no problems.

  5. #5
    Join Date
    Oct 2016
    Posts
    7
    yes some time after reload maybe web server won't start for any issue and all of my website goes down , also this action happen in badly hour

  6. #6
    Join Date
    May 2014
    Posts
    77
    I think, the option restart_apache_after_tally works only for Apache and not for NGINX. Maybe you can make a ticket or send a mail to support@directadmin.com?

  7. #7
    Join Date
    May 2014
    Location
    Netherlands Germany
    Posts
    342
    We had more problems before some with bugs DA for more then 1 Year ago and other with other http2 openssl versions and so on.

    There we had to change the gracefull restart in the normal restart for Apache that is a setting in .conf i think the DA not sure.

    After that only once and a while a problem that a "ghost Apache id" not stops so restart is not working and stop als not working we have to find out wich id, but reboot server also helps.

    Other known problems kernel updates and XEN and so on.
    DUTCH GERMAN, GERMAN DUTCH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •