Results 1 to 6 of 6

Thread: Request: move remote_smtp interface to exim.variables.conf

  1. #1
    Join Date
    Apr 2016
    Posts
    14

    Request: move remote_smtp interface to exim.variables.conf

    In some cases I want to use a different outgoing IP (not the server IP) for all domains without having to change anything in DirectAdmin.

    The current workaround is to comment this line in exim.conf:

    Code:
    interface = <; ${if exists{/etc/virtual/domainips}{${lookup{$sender_address_domain}lsearch*{/etc/virtual/domainips}}}}
    and replace this with the IP's I'd like to use:

    Code:
    interface = <; 11.22.33.44 ; 2a00:1111:2222:3333::1/48
    However, this will be overwritten when updating exim.conf with ./build exim_conf

    I would like to propose to move the "interface =" line from exim.conf to exim.variables.conf. If anyone needs to customize this setting it will be possible with the exim.variables.conf.custom file. This would prevent overwriting the interface line in exim.conf with future exim_conf build updates.
    Last edited by tomputer; 03-20-2018 at 06:47 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,829
    Alex Grebenschikov

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

  3. #3
    Join Date
    Apr 2016
    Posts
    14
    Quote Originally Posted by zEitEr View Post
    Yes I did:
    Code:
    domainips_default_ip=1.2.3.4
    When setting an IPv4 address, Exim will still use the default server IPv6 because that's prefered (when available). I still need to try if i can set both IPv4 and IPv6 with domainips_default_ip= .

  4. #4
    Join Date
    Jul 2006
    Posts
    91
    Did you ever find a work around to this? I'm looking for exactly the same thing.

    Thanks,

    Kevin

    Quote Originally Posted by tomputer View Post
    Yes I did:
    Code:
    domainips_default_ip=1.2.3.4
    When setting an IPv4 address, Exim will still use the default server IPv6 because that's prefered (when available). I still need to try if i can set both IPv4 and IPv6 with domainips_default_ip= .

  5. #5
    Join Date
    Mar 2006
    Location
    Netherlands
    Posts
    208
    Not exactly the fix you need but we have added this to exim.variables.conf:

    disable_ipv6=false
    dns_ipv4_lookup=*

    This way IPv6 is available for incoming emails (delivery from other servers to us) while outgoing (sending to other servers) is IPv4 only.
    Maybe it is helpful for your situation

  6. #6
    Join Date
    Jul 2006
    Posts
    91
    I've opened a ticket as disabling IPv6 outbound is not a solution.

    Appreciate the feedback.

    Kevin

    Quote Originally Posted by DutchTSE View Post
    Not exactly the fix you need but we have added this to exim.variables.conf:

    disable_ipv6=false
    dns_ipv4_lookup=*

    This way IPv6 is available for incoming emails (delivery from other servers to us) while outgoing (sending to other servers) is IPv4 only.
    Maybe it is helpful for your situation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •