Results 1 to 5 of 5

Thread: webapps_updates setting

  1. #1
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    394

    webapps_updates setting

    I never liked to enable automatic updates for almost anything (I want do to do it manually) so I disable it wherever I can. But with the following settings:

    notifications=yes
    da_autoupdate=no
    updates=no
    webapps_updates=no
    I still see this with ./build options:

    Auto updates: yes
    Does this only mean automatic ./build update with the nightly cron job and nothing else?
    Last edited by Erulezz; 04-13-2018 at 07:38 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,215
    Hello,

    The

    Code:
    ./build options

    should not show "Auto updates: yes" if they are disabled.

    I've got:

    Code:
    # ./build options | grep -i update
    exim.conf update: yes, release 4.5
    SpamAssassin rule updates: daily
    Cron for notifications and (or) updates: yes

    Make sure you've got no duplicates in options.conf and run
    Code:
    ./build cron

  3. #3
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    394
    Thanks for pointing me in the right direction, I didn't knew you needed to execute ./build cron again. But still.. with these settings;

    Code:
    #Cronjob Settings
    cron=yes
    cron_frequency=daily
    email=xx
    notifications=yes
    da_autoupdate=no
    updates=no
    webapps_updates=no
    I still see:

    Code:
    [root@web01 custombuild]# ./build cron
    Cronjob is set for xx:
    Cronjob frequncy: daily
    Automatic notifications: yes
    -----> Automatic updates: no
    It's recommended to have sa_update set to daily in the options.conf file to get SpamAssassin rules updated every day.
    Automatic SpamAssassin rule updates: no
    
    [root@web01 custombuild]# ./build options | grep "update"
    exim.conf update: yes, release 4.5
    SpamAssassin rule updates: no
    Cron for notifications and (or) updates: yes
    -----> Auto updates: yes

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,215
    Wrong title for an option? It's manged by "notifications" in options.conf... confusing.

    Code:
    egrep "cron|update|notifications" /usr/local/directadmin/custombuild/options.conf
    ?

    OK, check the build script:

    Code:
                    if [ "${NOTIFICATIONS_OPT}" = "yes" ]; then
                            echo "Auto updates: ${boldon}yes${boldoff}"
                    fi

  5. #5
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    394
    Indeed, very weird, something is definitely not right here. This is in the build script:

    When setting the cronjob;

    Code:
    if [ "${NOTIFICATIONS_OPT}" = "yes" ]; then
    	    echo "Cronjob is set for ${EMAIL_OPT}:"
        fi
    	echo "Cronjob frequncy: ${CRON_FREQUENCY_OPT}"
    	echo "Automatic notifications: ${NOTIFICATIONS_OPT}"
    	echo "Automatic updates: ${UPDATES_OPT}"
    And when using ./build options:

    Code:
    if [ "${NOTIFICATIONS_OPT}" = "yes" ]; then
    			echo "Auto notifications: ${boldon}yes${boldoff}"
    			echo "Auto notifications email address: ${boldon}${EMAIL_OPT}${boldoff}"
    		fi
    		if [ "${NOTIFICATIONS_OPT}" = "yes" ]; then
    			echo "Auto updates: ${boldon}yes${boldoff}"
    		fi
    So this explains why I was getting the different results in post #3... I'll open a ticket and link them to this thread for clarification. So I think the automatic updates are disabled with these settings, only the ./build options is showing wrong results because of the use ${NOTIFICATIONS_OPT}.

    // Edit

    Now fixed in CB 2.0 rev. 1863
    Last edited by Erulezz; 04-23-2018 at 12:16 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •