Results 1 to 3 of 3

Thread: Exim wont start after update

  1. #1
    Join Date
    Nov 2016
    Location
    Apeldoorn, Netherlands
    Posts
    39

    Exim wont start after update

    Hi,

    Please help!!

    I just let CB2(plugin) do the advised updates. And no Exim won't start anymore.

    It says:
    Code:
    Starting Exim Mail Transport Agent...
    Apr 16 12:43:28 ***.nl exim[23794]: 2018-04-16 12:43:28 Exim configuration error in line 38 of /etc/exim.easy_spam_fighter/check_mail.conf:
    Apr 16 12:43:28 ***.nl exim[23794]: error in ACL: unknown ACL condition/modifier in "spf = fail"

    --update
    I removed all 'spf = xxx' from the config. Now exim runs again. But I guess this is not a good, permanent solution.
    What can I do?

    Thanks in advance
    Lydia
    Last edited by flexjoly; 04-16-2018 at 05:04 AM.

  2. #2
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    404
    Do you have the latest exim.conf (currently 4.5.9) ? Do you have exim_conf = yes in options.conf?

  3. #3
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,545
    You now removed things from easy spam fighter too, which is indeed not a good practice.

    As Erulezz said, set exim_conf to yes in options.conf, I woud at least have i tlike this:
    #Mail Settings
    exim=yes
    eximconf=yes
    eximconf_release=4.5
    blockcracking=yes
    easy_spam_fighter=yes
    And spamassassin if you want etc.

    Then ./build update
    ./build clean
    ./build exim
    ./build exim_conf (also takes care you have the latest exim.pl file)
    ./build easy_spam_fighter

    Check that you have that line again in the ESF check_mail.conf.

    Should be fine and "original" then.
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •