Results 1 to 10 of 10

Thread: VPS low performance for Wordpress sites

  1. #1
    Join Date
    Jan 2018
    Posts
    12

    VPS low performance for Wordpress sites

    hi,
    I have a VPS (4x CPU 2,2GHz, 8GB RAM) on Debian 9 with apache+nginx.

    The server has a really low performance when it comes to wordpress sites hosted on it. For instance, online-business or promo-codes4u.com response time vary from 3-15s or even timeout and Wordpress sites being offline.

    at the same time, prestashop 1.6 with 500 products does not face any performance related issue.

    Prestashop is up all time. The issue is with Wordpress only.

    TOP shows:
    top - 20:06:55 up 1 day, 8:52, 3 users, load average: 0.37, 0.36, 0.28
    Tasks: 192 total, 2 running, 190 sleeping, 0 stopped, 0 zombie
    %Cpu(s): 5.5 us, 1.3 sy, 0.0 ni, 93.1 id, 0.0 wa, 0.0 hi, 0.1 si, 0.0 st
    KiB Mem : 8179364 total, 307372 free, 1976112 used, 5895880 buff/cache
    KiB Swap: 0 total, 0 free, 0 used. 5713108 avail Mem

    I can't see any issues / errrors neither in syslog nor messages.

    What might be the cause and where to search for issues?

  2. #2
    Join Date
    Feb 2005
    Posts
    184
    Have you tried installing a completely fresh wordpress install to see if it happens also?

  3. #3
    Join Date
    Aug 2015
    Posts
    314
    GTmetrix gives a lot of insights why your Wordpress website loads very slow.
    https://gtmetrix.com/reports/promo-codes4u.com/0Gm5Ubjr
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

  4. #4
    Join Date
    Jan 2018
    Posts
    12
    Quote Originally Posted by Awd View Post
    GTmetrix gives a lot of insights why your Wordpress website loads very slow.
    https://gtmetrix.com/reports/promo-codes4u.com/0Gm5Ubjr
    hi
    GTmetrix shows on average 7s before the server starts serving data. So, there's obviously a botteneck/misconfiguration. But to identify/resolve it?
    regards

  5. #5
    Join Date
    Feb 2005
    Posts
    184
    This can be perfectly related to wordpress itself.

    Please install a fresh wordpress installation and run tests again.

  6. #6
    Join Date
    Aug 2015
    Posts
    314
    I suggest follow the advice of #ViadCk, then delete cache, clean database. If it not solve the problem, remove unused and/pr unneccesary plugins, disable all plugins and activate one by one, after activiting every plugin, check server response, load time.
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

  7. #7
    Join Date
    Jul 2015
    Posts
    55
    We had the same issue (Wordpress sites with a TTFB of over 4 seconds, regardless of the amount of CPUs/RAM, no issues with non-Wordpress sites) when using pure Apache with mod_php or php-fpm. This was resolved for us by switching to pure Nginx + php-fpm (using Debian 9 as well).
    Last edited by wtptrs; 04-17-2018 at 06:57 AM.

  8. #8
    Join Date
    Jan 2018
    Posts
    12
    I'll think of complete switch to nginx, but it does not support rewrites..

  9. #9
    Join Date
    Jan 2018
    Posts
    12
    Quote Originally Posted by ViAdCk View Post
    This can be perfectly related to wordpress itself.

    Please install a fresh wordpress installation and run tests again.
    I've just installed a new fresh wordpress and the performance is much better

  10. #10
    Join Date
    Mar 2018
    Posts
    36
    Quote Originally Posted by tarta View Post
    hi,
    I have a VPS (4x CPU 2,2GHz, 8GB RAM) on Debian 9 with apache+nginx.

    The server has a really low performance when it comes to wordpress sites hosted on it. For instance, online-business or promo-codes4u.com response time vary from 3-15s or even timeout and Wordpress sites being offline.

    at the same time, prestashop 1.6 with 500 products does not face any performance related issue.

    Prestashop is up all time. The issue is with Wordpress only.

    TOP shows:
    top - 20:06:55 up 1 day, 8:52, 3 users, load average: 0.37, 0.36, 0.28
    Tasks: 192 total, 2 running, 190 sleeping, 0 stopped, 0 zombie
    %Cpu(s): 5.5 us, 1.3 sy, 0.0 ni, 93.1 id, 0.0 wa, 0.0 hi, 0.1 si, 0.0 st
    KiB Mem : 8179364 total, 307372 free, 1976112 used, 5895880 buff/cache
    KiB Swap: 0 total, 0 free, 0 used. 5713108 avail Mem

    I can't see any issues / errrors neither in syslog nor messages.

    What might be the cause and where to search for issues?
    %wa on the top i see it well. It does not have IOWait. Load Average correct, 93.1 id, 5.5 us, and 1.3 sy correct.

    Install some cache plugin in WordPress. I tried tuning Apache, MySQL and PHP.
    Last edited by nando89; 05-14-2018 at 11:11 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •