Results 1 to 13 of 13

Thread: Problem with Certificate Auto Renew Let's Encrypt

  1. #1
    Join Date
    Dec 2017
    Posts
    27

    Problem with Certificate Auto Renew Let's Encrypt

    Hello,


    I have a problem with my ssl renew. i need every 90 day renew manually any suggestions?

    http://prntscr.com/jfpk7e


    Thx

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    Hello,

    Try and check directadmin logs and system messages, they should give clues on why automatic renewal fails.

  3. #3
    Join Date
    Dec 2017
    Posts
    27
    System message no info about ssl
    Which exactly log? Error Log, Cron Log..?

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    If DIrectadmin fails to renew a cert admins get notified about it via system messages and by email.

    Check /var/log/directadmin/ for clues.

    Reset creation time to 0 in the files or selectively per domain:

    /usr/local/directadmin/data/users/*/domains/*.cert.creation_time

    and run a process in a debug mode:



    Code:
    echo "action=rewrite&value=letsencrypt" >> /usr/local/directadmin/data/task.queue && /usr/local/directadmin/dataskq d800

  5. #5
    Join Date
    Dec 2017
    Posts
    27
    I do not see any info in the logs about ssl maybe i gonna wait to 30 may
    In the domains/*.cert.creation_time there is on file 'cert.creation_time ' i do no how to reset creation time to 0


    Debug mode. Level 800

    root priv set: uid:0 gid:0 euid:0 egid:0
    pidfile written
    starting queue
    dataskq: command: action=rewrite&value=letsencrypt
    done queue


    Edit ok i found *.cert.creation_time i need open and change to 0?
    Last edited by michcio29; 05-09-2018 at 11:53 AM.

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    need open and change to 0

  7. #7
    Join Date
    Dec 2017
    Posts
    27

  8. #8
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    the second command should be executed now, it has no sense to run it without prior resetting creation time.

    #4

  9. #9
    Join Date
    Dec 2017
    Posts
    27
    Sorry, i do not expert in DA i get now :


    root priv set: uid:0 gid:0 euid:0 egid:0
    pidfile written
    starting queue
    dataskq: command: action=rewrite&value=letsencrypt
    done queue

  10. #10
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    expected reply:

    Code:
    Debug mode. Level 800
    
    
    root priv set: uid:0 gid:0 euid:0 egid:0
    pidfile written
    starting queue
    dataskq: command: action=rewrite&value=letsencrypt
    LetsEncrypt renewal on domain.com has succeeded. Not sending a notice.
    done queue
    Change time to 100 instead of 0, otherwise it will give

    Code:
    Unable to read the time from the string '0' from the file /usr/local/directadmin/data/users/userbob/domains/domain.com.cert.creation_time
    and try the same.

    + Then post here in text results from

    Code:
    /usr/local/directadmin/directadmin c | grep letsencrypt

  11. #11
    Join Date
    Dec 2017
    Posts
    27
    letsencrypt=1
    letsencrypt_renewal_days=60
    letsencrypt_max_requests_per_week=20
    letsencrypt_multidomain_cert=2
    letsencrypt_renewal_success_notice=0
    renew_letsencrypt_on_suspended_domain=0
    letsencrypt_list=www:mail:ftpop:smtp
    letsencrypt_list_selected=www

  12. #12
    Join Date
    Dec 2017
    Posts
    27
    Any idea how to fixed this issue?

  13. #13
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,039
    Contact directadmin developers for a possibly free audit on your server or me for a paid support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •