Results 1 to 4 of 4

Thread: what is

  1. #1
    Join Date
    Apr 2018
    Posts
    9

    what is

    Code:
    yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed autoconf automake libtool which patch mailx bzip2-devel lsof psmisc net-tools systemd-devel libdb-devel perl-DBI xfsprogs rsyslog logrotate crontabs -y
    may i know what is this error during i use the command as below:

    Code:
    Error: systemd conflicts with initscripts-9.49.17-1.el7.x86_64                                                 
     You could try using --skip-broken to work around the problem                                                  
     You could try running: rpm -Va --nofiles --nodigest

  2. #2
    Join Date
    Mar 2018
    Posts
    36
    Quote Originally Posted by stepup View Post
    Code:
    yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed autoconf automake libtool which patch mailx bzip2-devel lsof psmisc net-tools systemd-devel libdb-devel perl-DBI xfsprogs rsyslog logrotate crontabs -y
    may i know what is this error during i use the command as below:

    Code:
    Error: systemd conflicts with initscripts-9.49.17-1.el7.x86_64                                                 
     You could try using --skip-broken to work around the problem                                                  
     You could try running: rpm -Va --nofiles --nodigest
    For CentOS 7:

    Code:
    yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio \
    libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed \
    autoconf automake libtool which patch mailx bzip2-devel lsof glibc-headers kernel-devel expat-devel psmisc net-tools systemd-devel libdb-devel perl-DBI xfsprogs rsyslog logrotate crontabs file
    https://help.directadmin.com/item.php?id=354

    żUses a OpenVZ container?

    Update your initscripts and check version of initscripts:

    Code:
    grep exclude /etc/yum.conf
    Result:

    Code:
    exclude=initscripts*
    Changue for:

    Code:
    #exclude=initscripts*
    Code:
    grep exclude /etc/yum.conf
    Result:

    Code:
    #exclude=initscripts*
    Code:
    yum check-updates initscripts
    Code:
    rpm -qa | grep initscripts
    I commented out exclude=initscripts* from yum.conf and yum check-updates initscripts.
    Last edited by nando89; 05-12-2018 at 04:37 AM.

  3. #3
    Join Date
    Apr 2018
    Posts
    9
    Quote Originally Posted by nando89 View Post
    For CentOS 7:

    Code:
    yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio \
    libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed \
    autoconf automake libtool which patch mailx bzip2-devel lsof glibc-headers kernel-devel expat-devel psmisc net-tools systemd-devel libdb-devel perl-DBI xfsprogs rsyslog logrotate crontabs file
    https://help.directadmin.com/item.php?id=354

    żUses a OpenVZ container?

    Update your initscripts and check version of initscripts:

    Code:
    grep exclude /etc/yum.conf
    Result:

    Code:
    exclude=initscripts*
    Changue for:

    Code:
    #exclude=initscripts*
    Code:
    grep exclude /etc/yum.conf
    Result:

    Code:
    #exclude=initscripts*
    Code:
    yum check-updates initscripts
    Code:
    rpm -qa | grep initscripts
    I commented out exclude=initscripts* from yum.conf and yum check-updates initscripts.
    Code:
    [root@43595 ~]# grep exclude /etc/yum.conf
    exclude=initscripts*
    [root@43595 ~]# vi /etc/yum.conf
    [root@43595 ~]# grep exclude /etc/yum.conf
    #exclude=initscripts*
    [root@43595 ~]# yum check-updates initscripts
    Loaded plugins: fastestmirror
    base                                                     | 3.6 kB     00:00
    extras                                                   | 3.4 kB     00:00
    updates                                                  | 3.4 kB     00:00
    vz-base                                                  |  951 B     00:00
    vz-updates                                               |  951 B     00:00
    Loading mirror speeds from cached hostfile
     * base: centos.mirror.iweb.ca
     * extras: centos.mirror.iweb.ca
     * updates: centos.zswap.net
    
    initscripts.x86_64                      9.49.41-1.el7                       base
    [root@43595 ~]# rpm -qa | grep initscripts
    initscripts-9.49.17-1.el7.x86_64
    [root@43595 ~]#
    Like this correct?

  4. #4
    Join Date
    Mar 2018
    Posts
    36
    Quote Originally Posted by stepup View Post
    Code:
    [root@43595 ~]# grep exclude /etc/yum.conf
    exclude=initscripts*
    [root@43595 ~]# vi /etc/yum.conf
    [root@43595 ~]# grep exclude /etc/yum.conf
    #exclude=initscripts*
    [root@43595 ~]# yum check-updates initscripts
    Loaded plugins: fastestmirror
    base                                                     | 3.6 kB     00:00
    extras                                                   | 3.4 kB     00:00
    updates                                                  | 3.4 kB     00:00
    vz-base                                                  |  951 B     00:00
    vz-updates                                               |  951 B     00:00
    Loading mirror speeds from cached hostfile
     * base: centos.mirror.iweb.ca
     * extras: centos.mirror.iweb.ca
     * updates: centos.zswap.net
    
    initscripts.x86_64                      9.49.41-1.el7                       base
    [root@43595 ~]# rpm -qa | grep initscripts
    initscripts-9.49.17-1.el7.x86_64
    [root@43595 ~]#
    Like this correct?
    It is right.

    Re-uncomment exclude=initscripts* and try a yum update -y.

    Try installing DA again with that modification. You have uploaded the initscripts version to a new one.

    There are simply some versions of initscripts that cause dependency problems in containers with OpenVZ.
    Last edited by nando89; 05-13-2018 at 03:00 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •