Results 1 to 2 of 2

Thread: Feature request: CustomBuild and php selector with many php versions (php-fpm)

  1. #1
    Join Date
    Apr 2014
    Location
    Tel Aviv, IL
    Posts
    7

    Feature request: CustomBuild and php selector with many php versions (php-fpm)

    Currently the php version selector in the control panel supports up to two versions of php.
    If php is executed with php-fpm (which is probably the most common method as of now), then any number of php versions can be installed on the same number.
    There is also the easy method of installing an additional php version with custombuild 2.0:
    ./build php_expert php_release php_mode.

    So please add support to CustomBuild and the gui in the control panel for many versions of php that are installed with php-fpm (instead of only two).

    If, for example, the major (first) php version of the server is upgraded from 7.0 to 7.2, it might be ok for most web sites that are hosted on the server, but then some web sites will have a subtle failure, which will be discovered only later. The old web sites need stability in the php version that they are using.
    Last edited by dolphi; 05-16-2018 at 07:02 AM. Reason: fix minor style errors

  2. #2
    Join Date
    Nov 2003
    Location
    germany
    Posts
    120
    That would be awesome !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •