Results 1 to 6 of 6

Thread: Exim problem.

  1. #1
    Join Date
    Apr 2008
    Posts
    275

    Exim problem.

    I have this ramdom problem with a client into a vps, I have the lasted exim version and spamfighter installed.

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    raul@xxxxxx.tld
    local delivery failed

    The following text was generated during the delivery attempt:

    ------ raul@xxxxxx.tld ------

    exim: can't get the current working directory: No such file or directory

    On exim main log I see;
    2018-06-07 09:28:55 1fQoPn-0006wR-5A <xxx@xxx.com.tr>: spamcheck transport output: exim: can't get the current working directory: No such file or directory


    Any clues?
    Last edited by ozgurerdogan; 06-07-2018 at 01:12 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,010
    Hello,

    Restart Exim and SpamAssassin? Update exim to the latest?

  3. #3
    Join Date
    Apr 2008
    Posts
    275
    I did them. But wondering the cause of issue.

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,010
    It's probably a bug somewhere in Exim and/or exim.conf, I guess we are facing the same. They say:

    > Perhaps if os_getcwd() fails? Could it be that the spam-checker has
    > chdir()'d to a directory which it unlinks, but calls Exim from inside,
    > so that Exim's os_getcwd() fails

    What is your OS?

  5. #5
    Join Date
    Apr 2008
    Posts
    275
    It is centos7. I am thinking of disabling spam-checker function. But not sure where to edit in exim.conf.

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,010
    use custombuild script to disable spamassassin and re-install exim.conf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •