Results 1 to 7 of 7

Thread: Automake 1.16.1

  1. #1
    Join Date
    May 2008
    Posts
    817

    Automake 1.16.1

    It's a minor release with few bugfixes.

  2. #2
    Thanks, files1 updated to 1.16.1.
    Note, it requires autoconf 2.65, so if you see this:
    Code:
    configure: error: Autoconf 2.65 or better is required.
    then run
    Code:
    ./build autoconf
    ./build automake
    John

  3. #3
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    427
    In options.conf this was configured;

    Code:
    cat options.conf | grep "automake"
    automake=yes
    
    cat options.conf | grep "autoconf"
    autoconf=yes
    Despite these settings autoconf & automake didn't show up in ./build versions. After I did ./build autoconf & ./build automake they are correctly listed in ./build versions.

    After the ./build automake to install 1.16.1 I still see this (no errors when building);

    Code:
    automake --version
    automake (GNU automake) 1.13.4
    But ./build versions

    Code:
    Latest version of automake: 1.16.1
    Installed version of automake: 1.16.1
    Last edited by Erulezz; 06-18-2018 at 04:59 AM.

  4. #4
    Type:
    Code:
    which automake
    as the CB version would be installed to
    Code:
    /usr/local/bin/automake
    so there might be an rpm version causing the confusion (I don't believe it should be hurting anything).
    If both autoconf and automake were installed via CB, then the automake/autoconf rpms can in theory be removed to prevent confusion.

  5. #5
    Join Date
    May 2008
    Posts
    817
    Quote Originally Posted by Erulezz View Post
    You have two different installations of authomake - one by DA and another one, probably added as a dependency of a package that you installed.

  6. #6
    Join Date
    Aug 2015
    Posts
    316
    Hi,
    Just updated automake through custombuild and see these messages several times:
    warning: fread() expects parameter 1 to be resource, boolean given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

  7. #7
    Join Date
    Sep 2016
    Posts
    18
    Quote Originally Posted by Awd View Post
    warning: fread() expects parameter 1 to be resource, boolean given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26
    I dont think its Automake related, so i posted about this error here for other people that search for this:
    https://forum.directadmin.com/showthread.php?t=57915

    Bottom line is wait because i dont think the update is failing, its just the log output.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •