Results 1 to 6 of 6

Thread: Apache Errors : Won't start

  1. #1
    Join Date
    Jun 2016
    Posts
    10

    Question Apache Errors : Won't start

    Hello everyone,
    I'm trying to get a new server up and running with DirectAdmin. When I run ./build rewrite_confs I get the following errors...

    Starting php-fpm56: [18-Jun-2018 08:54:35] WARNING: Nothing matches the include pattern '/usr/local/directadmin/data/users/*/php/php-fpm56.conf' from /usr/local/php56/etc/php-fpm.conf at line 68.
    done
    Restarting apache.
    AH00526: Syntax error on line 52 of /usr/local/directadmin/data/users/winedb/httpd.conf:
    Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

    The last one prevents apache from starting. I can manually edit the lines in the conf file but if I run rewrite_confs again it just puts it right back. I checked in the admin area and there is no custom apache config data under that user. This account was transfered from another server if that matters. Can anyone tell me how to properly fix the issue / remove the offending lines and address the php-fpm56 issue.

    Thank you.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,273
    Hello,

    You should fix:

    Code:
    Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration
    What are options?

    Code:
    ./build options
    and what you have in /usr/local/directadmin/data/users/winedb/httpd.conf ?

  3. #3
    Join Date
    Jun 2016
    Posts
    10
    Thanks for the reply...

    [root@host custombuild]# ./build options
    Apache: 2.4.33
    mod_ruid2: 0.9.8
    ModSecurity: 2.9.2
    ModSecurity Rule Set: comodo
    htscanner: no
    Dovecot: 2.3.1
    Dovecot configuration: yes
    AWstats: no
    Exim: no
    exim.conf update: no
    BlockCracking: no
    Easy Spam Fighter: no
    SpamAssassin: no
    ClamAV: 0.100.0
    MySQL: 5.6.38
    MySQL backup: yes
    MySQL backup directory: /usr/local/directadmin/custombuild/mysql_backups
    MySQL compress backups: no
    PHP (default): 7.0 as php-fpm
    PHP (additional): 5.6 as php-fpm
    phpMyAdmin: 4.8.1-all-languages
    ProFTPD: no
    Pure-FTPd: 1.0.47
    RoundCube webmail: 1.3.6
    Replace "php.ini" with './build all' and './build php_ini': no
    Auto updates/notifications: no
    Run "clean" every time: yes
    Run "clean_old_webapps" every time: yes
    Run "clean_old_tarballs" every time: yes
    Show texts in bold: yes
    SquirrelMail: no
    Zend Guard Loader: no
    ionCube loader: no
    Suhosin: no
    The winedb.conf file has the following lines...

    php_admin_value display_errors 1
    php_admin_value max_input_time 100
    php_admin_value html_errors 1
    However if I remove them and then run

    ./build rewrite_confs
    It puts the lines right back in and I have no idea why...I appreciate your help

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,273
    Connect to directadmin as admin and remove those lines from custom area on httpd customization page.

    and you need to disable mod_ruid2: 0.9.8

  5. #5
    Join Date
    Jun 2016
    Posts
    10
    Thank you Alex for your help. The issue with apache not starting has been fixed.

    Can you explain why I need to disable mod_ruid2? If it matters I would like to run both php5.6 + php7 on this server.

  6. #6
    Join Date
    May 2008
    Posts
    747
    Quote Originally Posted by hendr1x View Post
    Can you explain why I need to disable mod_ruid2? If it matters I would like to run both php5.6 + php7 on this server.
    You are using php-fpm. Modruid2 is for mod_php only and you are not using it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •