Results 1 to 2 of 2

Thread: Configure phpMyAdmin for SSL connection

  1. #1
    Join Date
    Apr 2009
    Posts
    2,182

    Configure phpMyAdmin for SSL connection

    I have always used phpMyAdmin on https, and have used a .htaccess in /var/www/html/phpMyAdmin-4.8.2-all-languages to redirect to https

    However when I log into phpMyAdmin (on server hostname by the way), at the right column under the heading "Database server" it says: "Server connection: SSL is not being used"

    So I wanted to configure phpMyAdmin to use SSL in config.inc.php to avoid that warning, but after setting the following I am not able to log in anymore, and only get a "wrong username/password" message. This was my settings in config.inc.php:

    Code:
    $cfg['Servers'][$i]['ssl'] = true;
    $cfg['Servers'][$i]['ssl_key'] = '/etc/httpd/conf/ssl.key/server.key';
    $cfg['Servers'][$i]['ssl_cert'] = '/etc/httpd/conf/ssl.crt/server.crt';
    $cfg['Servers'][$i]['ssl_ca'] = '/etc/httpd/conf/ssl.crt/server.ca';
    Have anyone else been able to configure this? If not I am happy the way it is, because I am using SSL/https on phpMyAdmin already, but I only want to get rid of the message mentioned first in this post.

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,471
    Hello,

    Isn't it complaining about phpMyAdmin <=> MySQL connection being not encrypted with SSL/TLS? MySQL can not secure connections to sockets with SSL/TLS certs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •