Results 1 to 3 of 3

Thread: CXS on Directadmin

  1. #1
    Join Date
    Aug 2014
    Posts
    78

    CXS on Directadmin

    Hello, I have purchased a cxs license, Unfortunately neither configserver nor directadmin does not provide support it such a complicated situation.

    I have seen many people could install cxs without any problem but now I cannot figure out the following error.

    ClamAV socket [/tmp/clamd.socket] not found

    You must install ClamAV (Clamavconnector on cPanel) or ensure clamd is running to use this product correctly
    If the clamd socket is not automatically detected, and to clear this message, you must set clamdsock=/path/to/socket in /etc/cxs/cxs.defaults to the live socket location

    I have centos 7 and clamAV installed. I have done what the message says though that didn't work out.

    I will appreciate if you could share your idea.
    Last edited by NaSRi; 07-20-2018 at 02:37 PM.
    Freelance Linux and Windows system admin
    LPIC-1 and LPiC-2 certified
    Telegram @sysnasri
    https://web.telegram.org/#/im?p=@sysnasri
    ========================
    5 Years of experience in Web Hosting.
    www.amandahost.com

  2. #2
    Join Date
    Jan 2018
    Posts
    1
    Hi,

    As far as I am aware the core of the issue is in PrivateTmp enabled on ClamAV service on EL7 . There are two ways to fix it:

    1. Change PrivateTmp to false in /etc/systemd/system/clamd.service file, and restart service:
    Code:
    systemctl daemon-reload
    systemctl restart clamd
    or
    2. Define clamd socked manually - open /etc/clamd.conf, set:
    PHP Code:
     LocalSocket /run/clamd.socket 
    Restart clamd, then set same path to sicket in /etc/cxs/cxs.default :

    PHP Code:
    clamdsock=/run/clamd.socket 

  3. #3
    Join Date
    Aug 2014
    Posts
    78
    Quote Originally Posted by someB0dy View Post
    Hi,

    As far as I am aware the core of the issue is in PrivateTmp enabled on ClamAV service on EL7 . There are two ways to fix it:

    1. Change PrivateTmp to false in /etc/systemd/system/clamd.service file, and restart service:
    Code:
    systemctl daemon-reload
    systemctl restart clamd
    or
    2. Define clamd socked manually - open /etc/clamd.conf, set:
    PHP Code:
     LocalSocket /run/clamd.socket 
    Restart clamd, then set same path to sicket in /etc/cxs/cxs.default :

    PHP Code:
    clamdsock=/run/clamd.socket 
    Thank you dear, After digging into the /run/ directory I realized that the socket file is located at /var/run/clamd.socket
    Freelance Linux and Windows system admin
    LPIC-1 and LPiC-2 certified
    Telegram @sysnasri
    https://web.telegram.org/#/im?p=@sysnasri
    ========================
    5 Years of experience in Web Hosting.
    www.amandahost.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •