Results 1 to 9 of 9

Thread: Letsencrypt does not update via Custombuild

  1. #1
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548

    Letsencrypt does not update via Custombuild

    I think I'm missing something.

    We got several servers with Letsencrypt, and on the other servers Letsencrypt versions are updated automatically.
    But on a recently installed server, Letsencrypt 1.1.8 to 1.1.9 was not upgraded automatically.

    I thought this was done automatically on new installs?
    On all servers I do have webapps_updates=yes in options.conf

    The only difference was that I had set autover=no on the new server. So I set this to yes and did a ./build update and ./build updaet_versions, but still Letsencrypt did not get updated.
    I had to do a ./build Letsencrypt for that.

    What did I miss, why was it not autoupdating to the new version, not even with ./build update_versions command?
    Greetings, Richard.

  2. #2
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    I am the hosting provider. I thought I deleted this message, sorry.

    The ./build letsencrypt what I did was the solution. Now it's updating automatically, just had an update on all servers yesterday or the day before yesterday.
    Greetings, Richard.

  3. #3
    Join Date
    Mar 2014
    Posts
    72
    Hi,
    I have also some problems with let's encrypt
    I can't add certificate to a new domain since 2 days...
    Code:
    Challenge status: invalid. Challenge error: "type": "http-01", "status": "invalid", "error": { "type": "urn:ietf:params:acme:error:unauthorized", "detail": "The key authorization file from the server did not match this challenge [eYYmyUwcETog-eti_ToU5Fgi3_fEJk8doxYPQqUHP-k.tlIQA3MOKL8UWpPDMQJ_Qlg2EWv2Sx6eAzlwar5wZEA] != [eYYmyUwcETog-eti_ToU5Fgi3_fEJk8doxYPQqUHP-k.4E3VCTFsySjUrqnCg0ooULx-3kbdPBygi0aWkvg5Gd8]", "status": 403 . Exiting...
    Why? I have 50+ domains and everytime it's working.... yes I have DNS in this domain to my server etc.

  4. #4
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,244
    I'd suggest creating a ticket at tickets.directadmin.com with the domain name in question. Access to the server might also help.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  5. #5
    Join Date
    Mar 2014
    Posts
    72
    Quote Originally Posted by smtalk View Post
    I'd suggest creating a ticket at tickets.directadmin.com with the domain name in question. Access to the server might also help.
    But what this error is saying? What you suggest to do? Maybe it will working...

  6. #6
    Join Date
    Apr 2009
    Posts
    2,186
    Quote Originally Posted by Richard G View Post
    I am the hosting provider. I thought I deleted this message, sorry.

    The ./build letsencrypt what I did was the solution. Now it's updating automatically, just had an update on all servers yesterday or the day before yesterday.
    What might have caused the confusion: Let's say you have Let's Encrypt 1.1.10 installed, then you upgrade DirectAdmin to the newest version, then you might experience that Let's Encrypt is suddenly downgraded to for example version 1.1.9, that is because letsencrypt.sh is getting overwritten when you upgrade DirectAdmin, and if it recently was released a new letsecnrypt.sh file, the one in the new DirectAdmin version, might be a older letsencrypt.sh version.

    So it can be smart, that whenever you upgrade DirectAdmin, then do ./build update and ./build versions to check if letsencrypt.sh was downgraded.

  7. #7
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    Let's say you have Let's Encrypt 1.1.10 installed, then you upgrade DirectAdmin to the newest version, then you might experience that Let's Encrypt is suddenly downgraded to for example version 1.1.9
    I doubt it. Because I do all servers at the same time, and the update was from 1.1.8 to 1.1.9 and only on 1 server this issue occured. I can't imagine that a DA version would downgrade Letsencrypt. It would overwrite the script file, but is the script the same as the letsencrypt version? Anyway, as said, then it would have happened on all servers.
    I guess I just forgot to just do the ./build letsencrypt because it was a new server.

    I'll check the letsencrypt version after the next DA upgrade.
    Greetings, Richard.

  8. #8
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    406
    That also happened to me after the latest DA update. I verified it with ./build versions before the DA update, version 1.1.10 was installed. After the DA update 1.1.9 was installed and the update to 1.1.10 was available.

    So I went ahead and opened this feature request;

    https://forum.directadmin.com/showthread.php?t=56834

  9. #9
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    As said, that was not the case in my situation otherwise all 3 servers would have had issues.
    But this is good to know, that should not happen. There should be no downgrade of previously upgraded applications. I will second your request, might be a bug too then.
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •