Results 1 to 6 of 6

Thread: Dovecot not updating correctly

  1. #1
    Join Date
    Jun 2017
    Posts
    17

    Dovecot not updating correctly

    Hello!

    I have a couple of CentOS Directadmin VPSses running and with the latest update ran into a strange issue. When updating through ./build update, Directadmin does not seem to see the new Dovecot 2.3.x version. It keeps insisting that Dovecot 2.2.33 is the last version. The trouble is though, that the Dovecot conf is using the new 0.3 (or 2.3.x) settings in ssl.conf. This causes Dovecot to crash on startup. I altered the ssl.conf to the "old" 2.2.x use of settings and parameters, so for now Dovecot seems happy again.

    Strange this is; why won't Directadmin update Dovecot to the latest version?

    Kind Regards

  2. #2
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    4,066
    Can you check which server you are using? It seems files6 is running behind with some things.
    Try this:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build set_fastest
    After that, do a ./build update again and try to update Dovecot after that and see if it works.
    Greetings, Richard.

  3. #3
    Join Date
    Jun 2017
    Posts
    17
    Thanks Richard,

    Just tried that and was a bit suprised with the outcome:

    Code:
    Testing with file 10.kb:
    343932928 B/s   - files2.directadmin.com
    1981808 B/s     - files4.directadmin.com
    310378496 B/s   - files5.directadmin.com
    372244480 B/s   - files6.directadmin.com
    502267904 B/s   - files7.directadmin.com
    335544320 B/s   - files8.directadmin.com
    3271557 B/s     - files9.directadmin.com
    1363148 B/s     - files10.directadmin.com
    572522496 B/s   - files11.directadmin.com
    2107637 B/s     - files12.directadmin.com
    444596224 B/s   - files13.directadmin.com
    449839104 B/s   - files14.directadmin.com
    355467264 B/s   - files15.directadmin.com
    301989888 B/s   - files16.directadmin.com
    331350016 B/s   - files18.directadmin.com
    524288000 B/s   - files19.directadmin.com
    661651456 B/s   - files20.directadmin.com
    663748608 B/s   - files22.directadmin.com
    11114905 B/s    - files23.directadmin.com
    42257612 B/s    - files24.directadmin.com
    7497318 B/s     - files25.directadmin.com
    3795845 B/s     - files26.directadmin.com
    595591168 B/s   - files27.directadmin.com
    23488102 B/s    - files28.directadmin.com
    Total test duration: 10 seconds
    
    Testing with file 100.kb:
    337920 B/s      - files2.directadmin.com
    3030384 B/s     - files4.directadmin.com
    2338324 B/s     - files5.directadmin.com
    16252928 B/s    - files6.directadmin.com
    3240099 B/s     - files7.directadmin.com
    449536 B/s      - files8.directadmin.com
    260096 B/s      - files9.directadmin.com
    99020 B/s       - files10.directadmin.com
    1153433 B/s     - files11.directadmin.com
    164864 B/s      - files12.directadmin.com
    385024 B/s      - files13.directadmin.com
    140288 B/s      - files14.directadmin.com
    868352 B/s      - files15.directadmin.com
    756736 B/s      - files16.directadmin.com
    4487905 B/s     - files18.directadmin.com
    163840 B/s      - files19.directadmin.com
    347136 B/s      - files20.directadmin.com
    2946498 B/s     - files22.directadmin.com
    367616 B/s      - files23.directadmin.com
    957440 B/s      - files24.directadmin.com
    121856 B/s      - files25.directadmin.com
    3093299 B/s     - files26.directadmin.com
    217088 B/s      - files27.directadmin.com
    421888 B/s      - files28.directadmin.com
    Total test duration: 15 seconds
    
    Fastest server is files6.directadmin.com at 16252928 B/s
    Changed downloadserver option from files.directadmin.com to files6.directadmin.com
    After the update i did a /build versions which still shows:

    Code:
    Latest version of dovecot: 2.2.33
    Installed version of dovecot: 2.2.33
    
    Latest version of dovecot.conf: 0.3
    Installed version of dovecot.conf: 0.3

  4. #4
    Join Date
    Jun 2017
    Posts
    17
    Never mind, just fixed it myself.

    Turns out, because of an issue with a certain DoveCot update a while back, this version was hardcoded in custom_versions.txt. Tooks me a while to figure that one out...

    Kindly thanks for your help though, Richard!

  5. #5
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    4,066
    Ah I just wanted to suggest that if the issue persisted, but good you already found it yourself.
    Indeed, custom things sometimes take some remembering and figuring out, had that kind of issue myself too in the past.

    As for the help, you're welcome!
    Greetings, Richard.

  6. #6
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    4,066
    @rahul097: Please create a new thread with your issue, this has nothing to do with Dovecot update.
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •