Results 1 to 7 of 7

Thread: error connection IMAP

  1. #1
    Join Date
    Aug 2015
    Posts
    314

    error connection IMAP

    Hi,

    I try to connect from a webapplication on a subdomain to IMAP for email piping.

    I set imap server (mail.domain.com), username and password with TLS and also with SSL, but keep getting (cronjob) this error:

    Could not authenticate to IMAP server. Please check your IMAP server configuration in System > System Settings > Tickets.<br>Processing Escalation Rules<br>Auto Closing TicketsPHP Notice: Unknown: TLS/SSL failure for mail.domain.com: SSL negotiation failed (errflg=2) in Unknown on line 0

    when I run telnet -server-ip 143 imap is OK

    I have no idea what causes this. With Thunderbird I connect to IMAP without any problems (SSL/TLS).
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,398
    Hello Fred,

    So you have a valid cert for mail.domain.com in Dovecot?

    Will you provide a real domain name so that I could check it for you?

  3. #3
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,509
    when I run telnet -server-ip 143 imap is OK
    Isn't this the wrong port to test? Since you're using TLS/SSL shouldn't it be port 993 for imap?
    Maybe that's causing the error?
    Greetings, Richard.

  4. #4
    Join Date
    Aug 2015
    Posts
    314
    First thank you for your answers.

    Yes I have a valid certificate and with Thunderbird I can access Imap on port 993 without any problem. So first thought it was a bug in the application, but when I use it with Gmail Imap, it connects without problem. Maybe it has something to do with authentification method. In Thunderbird I can set it to normal or encrypted...but it is just guessing.
    Last edited by Awd; 09-13-2018 at 04:32 AM.
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

  5. #5
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,509
    When I do a test on sslshopper.com with port 993 all is oke.
    However, when I do a check with port 143 it says:
    No SSL certificates were found on mail.trails4fun.nl. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall
    Which seems normal to me as this is no SSL port.
    Does your cronjob uses port 993? Because that's not clear to me at this moment. And you can't use ssl on port 143.

    I also see that an ipv6 is found for that hostname, but ssllabs.com says:
    Unable to connect to the server
    Probably does not have anything to do with it, but maybe something you want to look in to for other reasons.

    I'm curious about what zEitEr will find.
    Greetings, Richard.

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,398
    You might need to enable TLS 1.0 back in Dovecot then.

  7. #7
    Join Date
    Aug 2015
    Posts
    314
    I think it must be something wrong in the script. I was affraid overlooking something. Probably the "wrong" port is called. Ipv6 is right, there is a problem with a router at the datacenter. I need to dig into the script. Thanks again.
    Kind regards, Fred

    Alentejo Webdesign
    Webdesign with Passion is what we do
    Web development, Hosting, Speed Optimizing & More......

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •