Results 1 to 5 of 5

Thread: Mail server does not sent bounce message to sender

  1. #1
    Join Date
    Sep 2018
    Posts
    4

    Question Mail server does not sent bounce message to sender

    Hello DA-folks,

    When I sent a message to e.g. a non-existent mail address the mail is directly frozen.
    But I do not receive a bounce mail at the sender the mail address.

    Is this standard or is there something wrong?

    I do see the following in the log:

    Code:
    Process failed (1) when writing error message to name@domain.ext (frozen)

    name@domain.ext = the sender mail address.


    What can I do to solve this?

    Many thanks

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,208
    Hello,

    What are the versions you use:

    - exim
    - exim.conf
    - OS version

    Normally bounces should be sent. What else you have in exim logs?

  3. #3
    Join Date
    Sep 2018
    Posts
    4
    Thank you zEitEr,


    • Exim 4.91
    • exim.conf 4.5.9 (SpamBlockerTechnology powered)
    • OS version: CentOS 6.10



    The bounce message is delivered, if I click manually on Bounce in DirectAdmin panel.


    A couple of lines from the main log:
    Code:
    2018-09-13 19:05:49 XxXxXx-XXXXXx-Xx <= name@domain.ext H=hostnamepc.com ([192.xx.xx.xx]) [xx.xx.xx.xx] P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=no A=plain:name@domain.ext S=2944 id=herewasanid@domain.ext T="Test" from <name@domain.ext> for inthiscasenonexistent@icloud.com
    2018-09-13 19:05:49 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc XxXxXx-XXXXXx-Xx
    2018-09-13 19:05:49 cwd=/usr/local/directadmin 2 args: /usr/sbin/exim -bpc
    2018-09-13 19:05:49 cwd=/usr/local/directadmin 2 args: /usr/sbin/exim -bpr
    2018-09-13 19:05:50 XxXxXx-XXXXXx-Xx ** inthiscasenonexistent@icloud.com F=<name@domain.ext> R=lookuphost T=remote_smtp H=mx2.mail.icloud.com [xx.x] X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=yes: SMTP error from remote mail server after RCPT TO:<inthiscasenonexistent@icloud.com>: 550 5.1.1 unknown or illegal alias: inthiscasenonexistent@icloud.com
    2018-09-13 19:05:50 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -XxXxXx-XXXXXx-Xx
    2018-09-13 19:05:50 XxXxXx-XXXXX-x2 acl_m_script_path '/' is never allowed for Users.
    2018-09-13 19:05:50 XxXxXx-XXXXX-x2 <= <> R=XxXxXx-XXXXXx-Xx U=mail P=local S=4475 T="Mail delivery failed: returning message to sender" from <> for name@domain.ext
    2018-09-13 19:05:50 XxXxXx-XXXXX-x2 => blackhole (non-SMTP ACL discarded recipients)
    2018-09-13 19:05:50 XxXxXx-XXXXX-x2 Completed
    2018-09-13 19:05:50 XxXxXx-XXXXXx-Xx Process failed (1) when writing error message to name@domain.ext (frozen)

    Should I look for something specific in the logs?

  4. #4
    Join Date
    Sep 2018
    Posts
    4
    Additional information

    • exim.pl version 24
    • blockcracking is set to version 1.7 (mentioned as: customized) I see in custombuild plugin.

  5. #5
    Join Date
    Sep 2018
    Posts
    4
    The problem is solved by removing the customized versions file of the custombuild plugin.

    - blockcracking updated to version 1.10.

    Further steps I have taken:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build exim
    ./build dovecot_conf
    ./build spamassassin
    ./build update
    ./build exim_conf

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •