Results 1 to 7 of 7

Thread: Not receiving e-mail, but can send it

  1. #1
    Join Date
    Oct 2018
    Posts
    4

    Not receiving e-mail, but can send it

    Hello,

    I am running DirectAdmin on my CentOS7 VPS. I created several e-mail accounts for a domain however I am not receiving any e-mail? I can send e-mail it is also delivered. But nothing comes into my inbox. The strangest thing is that the e-mails from WordPress I do get. But just not from regular accounts.

    I set up Let's Encrypt for smtp.domain.com pop.domain.com and mail.domain.com and they just answered fine and could set-up a key.

    My open ports:

    2222/tcp 80/tcp 443/tcp 465/tcp 995/tcp 587/tcp 993/tcp 25/tcp 110/tcp 143/tcp

    What am I doing wrong?

    domain: https://flekss.nl
    IP address: 148.251.209.150

    Best regards,

    Roef

  2. #2
    Join Date
    Oct 2018
    Posts
    4
    By the way, other domains with e-mailaccounts on my VPS are running just fine. Only this domain doesn't work, is there something wrong with the DNS settings?

  3. #3
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    I can't see anything wrong at this point, except that you do not have a correct rDNS setup for your mailserver.
    This should be fixed, the rDNS should point to your hostname because that is what the mailserver will use and it's better to do this for a couple of reasons.

    Unless you have set up something special via an external provider which you did not mention here, then the MX adresses and this rDNS is the cause of your problems.
    First MX address for your domain points to mx1.pub.mailpod6-cph3.one.com which has ip 185.164.14.70.
    So all your incoming mail is going that way and not to your server.

    Since you say other domains are working fine, except for this domain, I think the nameserver of this domain is not pointing to your server yet.
    Best practice is to set the nameservers of that domain to your nameservers.

    If you do not use nameservers, you have to change the DNS and MX records for this domain at the registrar.

    You can send me a pm in Dutch if you would find it easier to talk in Dutch, because I'm also Dutch.

    Regards, Richard.
    Greetings, Richard.

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,485
    Hello,

    The domain flekss.nl is configured to use remote MX seervers:


    Code:
    flekss.nl mail is handled by 10 mx1.pub.mailpod6-cph3.one.com.
    flekss.nl mail is handled by 10 mx2.pub.mailpod6-cph3.one.com.
    flekss.nl mail is handled by 10 mx3.pub.mailpod6-cph3.one.com.
    I believe those 3 MX servers are not hosted on the same server as Directadmin.

    In this case you should either disable Local Mail server for the domain or change MX records in DNS.

  5. #5
    Join Date
    Oct 2018
    Posts
    4
    Thankyou, that is indeed true. So those MX records are interfering. However there is no option in the contropl panel of one.com to disable those records. How to solve this?

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,485
    If you use Nameservers of a provider which does not allow not to use their MX, then you might want to use nameservers of another service, it might be your own nameservers hosted on the same server with Directadmin.

    For example: ns1.flekss.nl, ns2.flekss.nl, properly configured at registrar and directadmin.

    Please check https://site-helper.com/ , https://help.directadmin.com/ and forums for further information.

  7. #7
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    You control panel has the option to change MX records. I just pointed to it by PM.
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •